WoWInterface

WoWInterface (http://www.wowinterface.com/forums/index.php)
-   MoP archived threads (http://www.wowinterface.com/forums/forumdisplay.php?f=162)
-   -   GetAddOnMetadata? (http://www.wowinterface.com/forums/showthread.php?t=43672)

CobraA1 07-08-12 03:55 AM

GetAddOnMetadata?
 
Anybody know what the deal is with GetAddOnMetadata?

Apparently it stopped working with the "X-" fields. I was actually using them a bit for various things, but now it looks like I may have to move all of that into my code.

Haleth 07-08-12 04:08 AM

http://www.wowpedia.org/Patch_5.0.1/API_changes

Quote:

GetAddOnMetadata returns nil for fields starting with "X-".

CobraA1 07-08-12 11:09 PM

Right. Is that it? Have we lost all of our ability to use custom fields in the TOC altogether?

Phanx 07-09-12 01:49 AM

Nobody knows, as Blizzard has not addressed the issue. You -- like the rest of us -- will just have to wait and see if Blizzard fixes this bug, or tells us it's a bug but they won't fix it right now, or tells us it's an intended change, or tells us nothing and does nothing.

zork 07-09-12 09:32 AM

So we are ...
http://www.youtube.com/watch?v=DpnvS7kM4Fs

Seerah 07-09-12 12:48 PM

No. You just need to be patient. ;)

Guillotine 07-09-12 01:04 PM

This is a known bug. It should be fixed in the next build.

Sinaris 08-03-12 06:51 AM

Quote:

Originally Posted by CobraA1 (Post 257879)
Anybody know what the deal is with GetAddOnMetadata?

Apparently it stopped working with the "X-" fields. I was actually using them a bit for various things, but now it looks like I may have to move all of that into my code.

Are there some more infos about that?
Currently i am working on my interface, and it seems that things like ColorGradient and some other oUF parts are still not working if i used it via X-oUF into my toc file

Phanx 08-03-12 09:41 PM

The bug with X fields was fixed already. If you're having some problem with embedding oUF, it's likely a bug in your code, or a bug in oUF. Make sure you have the latest version from GitHub, and then post in the oUF forum with your code if you still have issues.

Sinaris 08-04-12 12:55 PM

i found the error i had.
haste had changed the ColorGardient function into the oUF core files.

the old way i used some month was this:

Lua Code:
  1. local r, g, b = oUFTukui.ColorGradient( min / max, unpack( C["unitframes"]["gradient"] ) )

the first value of the function was value X / value Y
the new function said this:

Lua Code:
  1. local r, g, b = oUFTukui.ColorGradient( min, max, unpack( C["unitframes"]["gradient"] ) )

now i have to put in both variables into the function instead of one single variable.

Phanx 08-04-12 08:52 PM

That really belongs in the oUF forum; it has nothing to do with GetAddOnMetadata, and likely nobody looking for the information you're posting will ever look at this thread.


All times are GMT -6. The time now is 10:35 AM.

vBulletin © 2014, Jelsoft Enterprises Ltd
©2012 ZAM Network LLC