WoWInterface

WoWInterface (http://www.wowinterface.com/forums/index.php)
-   Site help, bugs, suggestions/questions (http://www.wowinterface.com/forums/forumdisplay.php?f=18)
-   -   Why is your CDN so lazy? (http://www.wowinterface.com/forums/showthread.php?t=44997)

Phanx 10-28-12 08:40 PM

Why is your CDN so lazy?
 
Sometimes it just decides it's taking a nap and can't be bothered to respond with the CSS, and I get HTML only (and sometimes images). I'd say this happens every 36 hours on average; sometimes it doesn't happen for a few days, while other times it happens multiple times in the same day. Clearing my browser's cache and reloading doesn't fix it. I just have to wait, anywhere from 30 seconds to 10 minutes, and then it will magically start sending me CSS again. I'm in the San Francisco Bay Area. Anyone else having this issue, or am I just special?

Dolby 10-28-12 09:52 PM

Yeah I would like to know if any one else is having trouble. The CDN is Akamai one of the largest and most widely used.

Phanx 10-28-12 10:26 PM

Is there anything I can do to help track down the issue?

Dolby 10-28-12 10:32 PM

When you have issues try doing a trace route to cdn.wow.mmoui.com

Also if you have access to curl or wget try downloading an image or CSS that won't display for you. See if you get some HTML doc or something and share it here.

Thanks for your help.

Phanx 10-28-12 10:52 PM

tracert #1:
Code:

Tracing route to cdn.wow.mmoui.com [23.3.68.129]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms    my.router [192.168.1.1]
  2    33 ms    39 ms    28 ms    98.248.144.1
  3    10 ms    10 ms    9 ms    te-5-6-ur04.pinole.ca.sfba.comcast.net [68.86.142.205]
  4    34 ms    11 ms    11 ms    te-0-2-0-12-ar01.oakland.ca.sfba.comcast.net [68.85.154.86]
  5    14 ms    22 ms    23 ms    he-2-12-0-0-cr01.sacramento.ca.ibone.comcast.net [68.86.90.129]
  6    28 ms    49 ms    29 ms    [pos-2-13-0-0-cr01.seattle.wa.ibone.comcast.net [68.86.85.161]
  7    55 ms    55 ms    55 ms    [pos-0-5-0-0-cr01.denver.co.ibone.comcast.net [68.86.88.5]
  8    52 ms    55 ms    53 ms    68.86.82.198
  9    52 ms    85 ms    67 ms    a23-3-68-129.deploy.akamaitechnologies.com [23.3.68.129]

Trace complete.

Reloaded the page. Still no CSS.

tracert #2:
Code:

Tracing route to cdn.wow.mmoui.com [23.3.68.129]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms    my.router [192.168.1.1]
  2    28 ms    27 ms    29 ms    98.248.144.1
  3    10 ms    12 ms    9 ms    te-5-6-ur04.pinole.ca.sfba.comcast.net [68.86.142.205]
  4    20 ms    11 ms    23 ms    te-0-2-0-12-ar01.oakland.ca.sfba.comcast.net [68.85.154.86]
  5    39 ms    11 ms    22 ms    he-2-12-0-0-cr01.sacramento.ca.ibone.comcast.net [68.86.90.129]
  6    29 ms    31 ms    27 ms    [pos-2-13-0-0-cr01.seattle.wa.ibone.comcast.net [68.86.85.161]
  7    55 ms    56 ms    54 ms    [pos-0-5-0-0-cr01.denver.co.ibone.comcast.net [68.86.88.5]
  8    53 ms    53 ms    51 ms    68.86.82.198
  9    53 ms    52 ms    54 ms    a23-3-68-129.deploy.akamaitechnologies.com [23.3.68.129]

Trace complete.

Reloaded again, and things were back to normal.

I'll try wget next time.

Dolby 10-28-12 10:55 PM

Thanks I'll send this to our CDN contact for them to investigate. If you can get a wget of what its really sending you that will help to.

Thanks again.

Phanx 10-29-12 01:06 AM

Happened again.

Code:

wget -o log.txt http://cdn.wow.mmoui.com/clientscript/vbulletin_css/style-0ae33178-00016.css
Resulted in no CSS file being downloaded, and the following in log.txt:

Code:

--2012-10-29 00:04:06--  http://cdn.wow.mmoui.com/clientscript/vbulletin_css/style-0ae33178-00016.css
Resolving cdn.wow.mmoui.com... 23.3.68.129
Connecting to cdn.wow.mmoui.com|23.3.68.129|:80... failed: Connection refused.

When I hit Post Reply on this thread, it was working again, so I ran the same wget command again and got the CSS file and this log:

Code:

--2012-10-29 00:07:43--  http://cdn.wow.mmoui.com/clientscript/vbulletin_css/style-0ae33178-00016.css
Resolving cdn.wow.mmoui.com... 23.3.68.129
Connecting to cdn.wow.mmoui.com|23.3.68.129|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/css]
Saving to: `style-0ae33178-00016.css'

    0K .......... .......... .......... .......... ..........  304K
    50K .......... ..                                          212K=0.2s

2012-10-29 00:07:43 (280 KB/s) - `style-0ae33178-00016.css' saved [63860]



All times are GMT -6. The time now is 02:34 AM.

vBulletin © 2014, Jelsoft Enterprises Ltd
©2012 ZAM Network LLC