WoWInterface

WoWInterface (http://www.wowinterface.com/forums/index.php)
-   OpenRDX: Community Chat (http://www.wowinterface.com/forums/forumdisplay.php?f=107)
-   -   Shading object alpha @ range (http://www.wowinterface.com/forums/showthread.php?t=45354)

AznNoProblem 12-02-12 04:08 PM

Shading object alpha @ range
 
I've done this a few times but this time it's not working for some reason.
In my party frames I've attached a 'Shade object conditional alpha'.

Flag variable: Vars Unit In Set: Unit In Range (2,4)

When the party unit is in range, they're at 1 alpha. When it's false, they're at 0.25.

The error that comes up is Invalid Flag Variable.

http://i.imgur.com/OZsQU.jpg
http://i.imgur.com/E33sV.jpg

Is what it looks like ^

I've also tried to make a fileset with range and link it through Vars Unit In Set / Fileset / InRange but the same error happens.

Brainn 12-02-12 04:13 PM

you need to place the flag variable above the shader stuff - the way you set it up the variable gets defined after the shader, so its not available when the shader is created.

AznNoProblem 12-02-12 04:24 PM

Well don't I feel silly =/ Thanks.

Cripsii 12-02-12 05:22 PM

For my experience and recent create unitframe, It seem the Unit In Set: Unit In Range (2,4) is bugged..

For me it's work well until I enter in dungon (or had a loading screen)... After the load the flag is inversed....
example:
the flag is set for alpha @ 1 when unit in range and 0.3 when not in range.
But after load, all my uf return an alpha @ 0.3... I change the flag for 0.3 when in range and 1 when not in range and it worked.. BUT just for the dungon... After next loading screen All my unitfram returne out of range and I rechange for 1 when in range and 0.3 for not in range...

I suggest you to create a Unit In Set: Exact spell range and select an helpful spell for range!
Then create an condition alpha shader and it's work fine!!! Even after loading !


All times are GMT -6. The time now is 09:07 PM.

vBulletin © 2014, Jelsoft Enterprises Ltd
©2012 ZAM Network LLC