Showing results 1 to 25 of 162
Search took 0.01 seconds.
Search: Posts Made By: Mayron
Forum: Lua/XML Help 09-12-14, 01:50 PM
Replies: 11
Views: 666
Posted By Mayron
Excellent, I knew that order mattered but was...

Excellent, I knew that order mattered but was getting confused on how to find out the right order and assumed it should be correct due to my old AddOn still working (before I completely rewrote it)....
Forum: Lua/XML Help 09-12-14, 12:42 PM
Replies: 11
Views: 666
Posted By Mayron
I don't understand why I copied the same files...

I don't understand why I copied the same files over from my old UI which makes use of this same library and that uses the same embeds file as the one I linked but that works.

Not sure how I embed it...
Forum: Lua/XML Help 09-12-14, 12:16 PM
Replies: 11
Views: 666
Posted By Mayron
In my TOC file I have embeds.xml and in that it...

In my TOC file I have embeds.xml and in that it has this:


<Ui xsi:schemaLocation="http://www.blizzard.com/wow/ui/ ..\FrameXML\UI.xsd">
<Script file="libs\LibStub\LibStub.lua"/>
<Include...
Forum: Lua/XML Help 09-12-14, 12:00 PM
Replies: 11
Views: 666
Posted By Mayron
Cannot setup SharedMediaWidgets lib - Need help

Hi,

I have rewrote my UI and I am trying to setup options in my GUI using the Ace library but I cannot get the Shared Media Widgets working. I decided to set up the libs in the exact same way my old...
Forum: Lua/XML Help 08-17-14, 07:45 AM
Replies: 8
Views: 860
Posted By Mayron
Ah ok, well then I just won't worry about it. ty!

Ah ok, well then I just won't worry about it. ty!
Forum: Lua/XML Help 08-17-14, 06:12 AM
Replies: 8
Views: 860
Posted By Mayron
Thank you Haleth :) I am trying to keep some of...

Thank you Haleth :)

I am trying to keep some of the UI more "Blizzard-like" while trying to clean up other parts. I have also made the frames move-able however because of pixel perfect borders, the...
Forum: Lua/XML Help 08-17-14, 04:18 AM
Replies: 8
Views: 860
Posted By Mayron
Sure! But I haven't used any code. Which part...

Sure! But I haven't used any code. Which part looks like I have?
I am trying to Reskin the Blizzard UI all by myself while putting my own spin on it.

I honestly have tried doing everything all by...
Forum: Lua/XML Help 08-16-14, 12:20 PM
Replies: 8
Views: 860
Posted By Mayron
Reskin Frame problem

Hi all,

I wanted to try adding a skinning module and almost finished. I am just finishing some bugs and wanted help with one of them. I know there is Aurora but wanted to make it integrated with my...
Forum: Released Compilations 08-16-14, 05:18 AM
Replies: 30
Views: 18,738
Posted By Mayron
This is because you have the Blizzard Raid Frames...

This is because you have the Blizzard Raid Frames enabled to be shown while also using the Grid raid frames AddOn included in the UI Pack. You can choice which ones you want to use. If you want the...
Forum: Lua/XML Help 07-05-14, 04:47 AM
Replies: 1
Views: 759
Posted By Mayron
Trying to make simple DropDown Box.

I fixed the problem, sorry :)
Forum: Lua/XML Help 06-03-14, 06:48 AM
Replies: 0
Views: 620
Posted By Mayron
ScrollBar for a large FontString?

Never mind, fixed it :)
Forum: Lua/XML Help 06-01-14, 04:43 PM
Replies: 11
Views: 1,259
Posted By Mayron
Ah well at least its working and was not any...

Ah well at least its working and was not any unknown bug causing it. Well now everything is awesome so thanks guys :)
Forum: Lua/XML Help 06-01-14, 04:17 PM
Replies: 11
Views: 1,259
Posted By Mayron
Thanks Phanx, Usually I only keep major elements...

Thanks Phanx, Usually I only keep major elements of an AddOn in separate files. In this case I have my "BottomUI" module in one, my CastBar mod in another, and Chat Module in another. Other smaller...
Forum: Lua/XML Help 06-01-14, 10:28 AM
Replies: 11
Views: 1,259
Posted By Mayron
That is completely understandable, just need to...

That is completely understandable, just need to setup GitHub again and post it there. I thought it was going to be a typical beginners error with the use of Ace3 so thought I would post the major...
Forum: Lua/XML Help 06-01-14, 10:23 AM
Replies: 13
Views: 1,474
Posted By Mayron
I always use Notepad++ but it is not an IDE :S

I always use Notepad++ but it is not an IDE :S
Forum: Lua/XML Help 06-01-14, 02:31 AM
Replies: 11
Views: 1,259
Posted By Mayron
So I just found out the body of the function is...

So I just found out the body of the function is not the problem because this does not work either:

function MayronUI:OnEnable()
print("TEST")
end

To load this file with this function in I am using...
Forum: Lua/XML Help 06-01-14, 02:07 AM
Replies: 11
Views: 1,259
Posted By Mayron
Ah so at least I can cross that off the list. No...

Ah so at least I can cross that off the list. No idea why no Lua error is appearing then. The OnEnable function shows a few visual frames on the screen and does not do it when I launch WoW and login...
Forum: Lua/XML Help 05-31-14, 04:45 PM
Replies: 11
Views: 1,259
Posted By Mayron
Issue with Ace3 not loading AddOn

Hi, I have never had this issue before but recently started and need help. When I load WoW and login for the first time on a character it does not load the AddOn I am making until I "/reload" the...
Forum: Lua/XML Help 05-27-14, 03:36 PM
Replies: 13
Views: 1,474
Posted By Mayron
Ah yes I see that now. Thank you, that helped me...

Ah yes I see that now. Thank you, that helped me out a lot and makes a lot of sense, appreciated!
Forum: Lua/XML Help 05-27-14, 02:46 PM
Replies: 13
Views: 1,474
Posted By Mayron
Thank you so very much Fizzlemizz! That worked!...

Thank you so very much Fizzlemizz! That worked! So it was just because I had chosen a different parent for my sub frame, that makes a lot of sense.

Glad I know that for future and will make a note...
Forum: Lua/XML Help 05-27-14, 02:39 PM
Replies: 13
Views: 1,474
Posted By Mayron
I read that: So I added the sub frame that...

I read that:



So I added the sub frame that needs to be a child of the main frame inside of an opening and closing <Frames> tag but still no luck.
Forum: Lua/XML Help 05-27-14, 02:21 PM
Replies: 13
Views: 1,474
Posted By Mayron
Just can't understand why the sub frame won't...

Just can't understand why the sub frame won't work. Is it not possible? I can't find information on this.
This is the full code so I had a button I created which I commented out as that too did not...
Forum: Lua/XML Help 05-27-14, 02:16 PM
Replies: 13
Views: 1,474
Posted By Mayron
Thank you I will try that out. Not heard of that...

Thank you I will try that out. Not heard of that IDE before. SciTE looks very nice, just wish I could get it to work. I tried some tutorials but no one could answer my question and on forums where...
Forum: Lua/XML Help 05-27-14, 02:10 PM
Replies: 13
Views: 1,474
Posted By Mayron
Sorry if you already know this but, If you use...

Sorry if you already know this but,
If you use "$parent" it grabs the parents name and adds any extra text to the end of the parents name for the new element name so if the parent is MUI_Bottom like...
Forum: Lua/XML Help 05-27-14, 11:06 AM
Replies: 13
Views: 1,474
Posted By Mayron
I used http://dev.averageurl.com/wow/xml/ and it...

I used http://dev.averageurl.com/wow/xml/

and it says its valid XML but still no luck getting the frame to show again. I did not alter the file structure so the bgFile is valid.

EDIT: I got it to...
Showing results 1 to 25 of 162