View Single Post
Unread 04-20-12, 01:47 AM   #7
Zirgo
A Fallenroot Satyr
AddOn Compiler - Click to view compilations
Join Date: Nov 2007
Posts: 20
Originally Posted by Phanx View Post
There is a syntax error in the original saved variables file. This means that either you or the UI uploader tried to modify the file by hand, and did not do it correctly. BugSack should have reported an error message. Here is the section of the file with the error (with some levels of indentation removed for readability):

Code:
["scripts"] = {
	["LOAD"] = "self:SetParent("PitBull4_Frames_targettarget")
",
	["EVENT"] = "if UnitExists(\"targettarget\") == nil then\n   self:Hide()\n   return\nend\nlocal cl = UnitClassification(\"target\")\nif (cl == \"elite\") or (cl == \"worldboss\") or (cl == \"rareeleite\") then\n   self:SetBackdropColor(0.1, 0.1, 0.1, 0.1)\n   self:Show()\nelse\n   self:SetBackdropColor(1, 1, 1, 1)\n   self:Show()\nend",
},
The part in orange is incorrect; that line should look like this instead:
Code:
	["LOAD"] = "self:SetParent(\"PitBull4_Frames_targettarget\")",
You can either fix it yourself, or use the fixed copy attached to this post.

If you did not modify the original file yourself, you should probably direct the UI uploader to this thread, or at least tell them about the problem, so they can fix it in the download.

That fixed it. Thank you very much.
Zirgo is offline   Reply With Quote