View Single Post
Unread 07-23-12, 07:17 PM   #17
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,746
Originally Posted by Haleth View Post
In a situation where two addons do include it, then the addon folders themselves will naturally conflict, and the user will only choose to keep one.
The problem with this is that most users are completely ignorant of how anything works, and may first download an addon with Notifications v1.1, and then later download an addon with Notifications v1.0, thus overwriting the current version of Notifications with an older version.

Originally Posted by Haleth View Post
In your example where the latest version of Notifications is always used, there can still be a problem. If an addon is written for an older version of it, and some core functionality changed, then it will still break when the user updates Notifications.
The usual approach is that versions which are backwards-compatible increment the minor version number -- eg. Notifications v1.0 will upgrade to Notifications v1.1, leaving only the latter loaded and available to addons -- while backwards-incompatible versions increment the major version number -- eg. Notifications v1.1 and Notifications2 v1.0 will coexist and both be available to addons.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote