View Single Post
Old 08-27-12, 10:13 AM   #1
tukz
A Fallenroot Satyr
 
tukz's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2009
Posts: 20
Anyone with this issue on beta with dropdownmenu?

Playing with dropdowns at the moment on beta. I have an issue that I can't figure out. oO

Does anybody is having Lua errors with minimap, unitframes, etc dropdown on beta with addons? They seem to happen rarely and randomly.

By just making an addon with this code...

Code:
Minimap:SetScript("OnMouseUp", function(self, btn)
	if btn == "RightButton" then	
		ToggleDropDownMenu(1, nil, MiniMapTrackingDropDown, "Minimap", 0, 0)
	end
end)
i'm getting a lua error from UIDropDownMenu.lua.

Code:
Message: Interface\FrameXML\UIDropDownMenu.lua:1016: attempt to concatenate global 'UIDROPDOWNMENU_MENU_LEVEL' (a userdata value)
screenshot:
http://www.tukui.org/storage/viewer....712_123843.jpg

How to reproduce:
1- Enable "Show Objective" via Map.
2- Get a quest showing a POI on map.
3- Open tracking on minimap with right click button. (do not close, do not select anything)
4- Open minimap with the M keybind.

If you can't reproduce, reload your UI and try again step 3 and 4.

I'm also having random lua error sometime DropDownMenu.lua at line 656, UIDROPDOWNMENU_MENU_LEVEL being nil, when I play with unitframes dropdown. :/

I would like to know if some addon authors have the same issues since a couple of beta builds on beta/ptr.

Last edited by tukz : 08-27-12 at 10:41 AM.
tukz is offline   Reply With Quote