View Single Post
Unread 08-29-12, 12:38 PM   #275
Stabilo
An Aku'mai Servant
Join Date: Jul 2009
Posts: 36
Another bug report, not really sure how to go about this so I'll just retrace my steps:

I have a bunch of cooldown displays "grouped" up depending what they're like, dps cooldowns in one bunch, defensive in one etc.

I was trying out some triggers to help people on curse, and made one of the auras hide 2 seconds before cooldown ending. Also made an action that would change the opacity of the icon when off cooldown, which doesn't make sense when it's not showing all. Anyway, deleted the action, disabled the time trigger, aura stopped showing.

Did various things to try and get it back, couldn't get it to show. Deleted the display to re-do it, which is when **** hit the fan. I've grouped up the display bunches with parent displays, and deleting one from between seems to have been a bad idea. Nothing that was parented to the deleted aura or anything "behind" that is showing up now, and I'm getting a LUA error.

Removing the parent info from any of the vanished auras doesn't bring them back, so I'm guessing it fubared something in the saved variables.


Message: ...nterface\AddOns\PowerAuras\Classes\Layouts\Fixed.lua:209: <unnamed>:SetPoint(): trying to anchor to itself
Time: 08/29/12 21:26:16
Count: 1
Stack: [C]: ?
[C]: in function `SetPoint'
...nterface\AddOns\PowerAuras\Classes\Layouts\Fixed.lua:209: in function `PositionDisplayPreview'
...owerAurasOptions\Widgets\Editor\Displays\Preview.lua:352: in function `RefreshDisplay'
...owerAurasOptions\Widgets\Editor\Displays\Preview.lua:280: in function `AttachDisplay'
...rface\AddOns\PowerAurasOptions\Widgets\Workspace.lua:87: in function `CreatePreviews'
...rface\AddOns\PowerAurasOptions\Widgets\Workspace.lua:199: in function <...rface\AddOns\PowerAurasOptions\Widgets\Workspace.lua:193>
[C]: in function `Show'
...rface\AddOns\PowerAurasOptions\Widgets\Workspace.lua:256: in function `Toggle'
Interface\AddOns\PowerAuras\Main.lua:673: in function `?'
Interface\FrameXML\ChatFrame.lua:4358: in function `ChatEdit_ParseText'
Interface\FrameXML\ChatFrame.lua:4052: in function `ChatEdit_SendText'
Interface\FrameXML\ChatFrame.lua:4091: in function <Interface\FrameXML\ChatFrame.lua:4087>
[C]: in function `ChatEdit_OnEnterPressed'
[string "*:OnEnterPressed"]:1: in function <[string "*:OnEnterPressed"]:1>

Edit Deleting all individual displays from the aura didn't get rid of the error, but deleting the entire aura did.

Last edited by Stabilo : 08-29-12 at 12:47 PM.
Stabilo is offline