View Single Post
Unread 10-18-12, 02:51 PM   #13
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,034
okay, think I found out the cause, as I know through my tests it did the same .. all I can think of is that people testing had made the changes but then I forgot to add that file to the change files.

Sorry Scott for not doing that as I am assuming you used my fix file zip to update nUI.

The problem line is :
RegisterStateDriver(nUI_ActionBar, "page", "[vehicleui] 12; [extrabar] 13; [overridebar] 14; [bar:2] 2; [bar:3] 3; [bar:4] 4; [bar:5] 5; [bar:6] 6; [bonusbar:1] 7; [bonusbar:2] 8; [bonusbar:3] 9; [bonusbar:4] 10; [bonusbar:5] 11;1" );

which is line 392 in nUI_ButtonBar.lua

I had added [extrabar] 13; to the mix but this just turns off the main action bar when the extra button is displayed ... erm .. sound familiar ?

If you can locate this line in that file simply remove that segment so the line then reads:
RegisterStateDriver(nUI_ActionBar, "page", "[vehicleui] 12; [overridebar] 14; [bar:2] 2; [bar:3] 3; [bar:4] 4; [bar:5] 5; [bar:6] 6; [bonusbar:1] 7; [bonusbar:2] 8; [bonusbar:3] 9; [bonusbar:4] 10; [bonusbar:5] 11;1" );


This will then ( hopefully ) get it working the way it should be. I apologise to the runs that have been massacred due to this little oversight.

If you have access to a daily or other quest to quickly test this that would be great but I believe my druid is close to a quest that uses it so will hunt down the quest chain for it and send her on that route.
__________________
Xrystal is offline