View Single Post
Unread 12-17-12, 07:29 PM   #452
tehfm
A Murloc Raider
Join Date: Mar 2011
Posts: 7
Originally Posted by TylerGamer84 View Post
Is this a known issue/bug or do I just have something configured incorrectly here? I have timers set up for my shaman's totem, but it won't show them if I have more than one totem down.

Example: I drop a fire totem and the timer is there, but if I drop a water totem it goes away until the water totem is gone. This even happens if they are fake totems with the Totemic Encirclement minor glyph.
I'm not sure I would call it a bug, it's more like it's not working as one might expect.

Assuming you are using the "Totems" trigger and for the fire totem you have in "Slot 1" selected "Any" and for the other three slots "None". For the water totem you have in "Slot 3" selected "Any" and "None" for the other slots. With that setup it's working like it's intended. With only ONE totem active it will show the aura, if both are active it will fail to match the "None" setting and not show anything.

For a simple "Texture" display you can work around it by selecting the "Any or None" option instead of just "None", but if you have a "Timer" it will always show the shortest time for any of your totems.

The best solution, as far as I can tell, is to use the "Ignore" option instead of "None", with that it will just skip over those slots that are flagged with ignore and not care how much time they have left. The only problem that's left is that there isn't an "Ignore" option... so I made one...

Copy "Totems.lua" to "PowerAuras\Classes\Triggers" and "enUS.lua" to "PowerAurasOptions\Localisation" and you should be set.
Attached Files
File Type: lua Totems.lua (10.6 KB, 373 views)
File Type: lua enUS.lua (16.3 KB, 382 views)
tehfm is offline