Reply
 
Thread Tools Display Modes
Unread 09-29-12, 01:34 PM   #1
thespillmonkey
A Deviate Faerie Dragon
Join Date: Oct 2010
Posts: 11
Vehicle and Extra buttons mapping to pet

I am a druid using state changing bars for my primary.
My vehicle and extra function buttons are mapping to my "pet 1" bar, and no matter what I do, even if buttons are mapped, it disappears.

Is this a known issue ?
Vehicles to me also includes quests like the story-telling one where you control the different characters as the plane goes down in jade forest, and extra buttons would be something like the 4winds quest where you lasso the white bird and need to jump on it's back. No button pops up.
The button that always shows up in the "special button" area is the vehicle eject.

Thanks,

TSM
thespillmonkey is offline   Reply With Quote
Unread 10-07-12, 11:53 AM   #2
Phaedre
A Murloc Raider
Join Date: Aug 2006
Posts: 8
Originally Posted by thespillmonkey View Post
The button that always shows up in the "special button" area is the vehicle eject.
That's the only button that ever shows up for me on the special button bar. I've had the bar show up, but with no buttons, or with the vehicle eject button. I believe that Maul is aware of this, but has been extremely busy with RL issues.
Phaedre is offline   Reply With Quote
Unread 10-07-12, 07:33 PM   #3
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,750
Originally Posted by thespillmonkey View Post
The button that always shows up in the "special button" area is the vehicle eject.
That's the only button that shows up in the "vehicle button" bar in any actionbar mod. I don't know about Ion (I'm not currently using it) but in Bartender you just set your main action bar to switch in the overridebar and possessbar states. If you see any options related to "override", "possess", or "vehicle" in the Ion options panel for your main bar, try checking them.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 10-08-12, 04:48 PM   #4
thespillmonkey
A Deviate Faerie Dragon
Join Date: Oct 2010
Posts: 11
The vehicle eject button was part of a wrong button mapping bug in the current version of the addon.
The manual fix for it is in the love and hate thread on this forum.

The vehicle bar not showing up is still an issue for me.

Also, has anyone gotten the stealth/prowl states to work ?
thespillmonkey is offline   Reply With Quote
Reply

Go BackWoWInterface » Featured Projects » Ion Engines, Engage! » Vehicle and Extra buttons mapping to pet

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off