Reply
 
Thread Tools Display Modes
Unread 10-10-12, 10:41 AM   #1
Xully
A Deviate Faerie Dragon
Join Date: Jul 2010
Posts: 19
SavedVariables question in the WTF folder.

first of all , allow me to apologize for the butchering of the English language that you're about to witness here, English isn't my native, or even my 2nd language for that matter, please bare with me.

I have some of the lau files that should be placed in the SavedVariables folder in the WTF directory, I have done this million of times in the past, whenever a newer version of addon releases , or if I have to delete my whole WTF folder, i save those lau files configs of the specific addon, that was originally in my /SavedVariables folder, then I just place it in there one more time, and my profiles, settings, would showup in the game for that specific addon, normally I do this with two main addons, MikScrollingCombatText & Tidyplates....They have massive installation and setup, but I have done my own profiles in both, and I save the savedvariables file that said Addonname.lau and Addonname.lau.bak , and as i said, whenever i put these back in my wtf folder, my profile would show up.


Sorry for making this longer than it should , After the expansion, my problem is that I installed the newest version of these addons, now I bring my profiles lau savedvariables back in my wtf folder, and try to login into the game, whenever I log inside, it rewrites those files back to default , and empty, as if i just installed the addon, i done this millions of time, it keeps deleting my lau files, replacing them with the Default files.

please let me know why is that happening to me, I don't want to reconfigure everything from scratch.
Xully is offline   Reply With Quote
Unread 10-10-12, 10:55 AM   #2
Dridzt
A Pyroguard Emberseer
 
Dridzt's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2005
Posts: 1,191
If you are on a Windows7 or Vista PC this might help:
http://forums.wowace.com/showpost.ph...postcount=2357
Dridzt is offline   Reply With Quote
Unread 10-10-12, 11:02 AM   #3
Xully
A Deviate Faerie Dragon
Join Date: Jul 2010
Posts: 19
Originally Posted by Dridzt View Post
If you are on a Windows7 or Vista PC this might help:
http://forums.wowace.com/showpost.ph...postcount=2357
i don't think it's admin issue, because I've done this million of times on this same computer, in the past, before the expansion, I've done this here, didn't change a thing, also my WoW directory isn't in C:\Program Files to begin with, it's in D:\ ,but yea the point is , i dont this before with no problem.
Xully is offline   Reply With Quote
Unread 10-10-12, 12:43 PM   #4
lerb
Shadow Priest
 
lerb's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2008
Posts: 258
Hm.. Lau? Have you named them "addonname.lau"? That's wrong, it should be "Lua".

Addoname.lua

At first I thought you typed it wrong but you wrote it as "Lau" everywhere so I figured you did the same for the files? It's a long-shot from my side though.
__________________
lerb is offline   Reply With Quote
Unread 10-10-12, 02:22 PM   #5
Xully
A Deviate Faerie Dragon
Join Date: Jul 2010
Posts: 19
Originally Posted by lerb View Post
Hm.. Lau? Have you named them "addonname.lau"? That's wrong, it should be "Lua".

Addoname.lua

At first I thought you typed it wrong but you wrote it as "Lau" everywhere so I figured you did the same for the files? It's a long-shot from my side though.
no man, i wrote it wrong everywhere lol, i didn't write the files or anything, i just configured my addons, then went into the SavedVariables folder thats inside WTF directory, then copy those files, and yes its Lua as you mentioned, and then i paste them into that folder whenever i renew my addons, or go to another computer, which will make my profiles+configurations perfect...but not anymore, its not working for me now and I have no clue why.
Xully is offline   Reply With Quote
Unread 10-10-12, 03:17 PM   #6
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,262
You shouldn't need to restore your SavedVariables files after updating an addon on the same computer, unless you used a program like the Curse Client to completely uninstall the addon and remove its saved variables before installing the update, which is not necessary; you can just install the update right over the top of the previous version.

As for your actual problem, try deleting your entire WTF folder (after making a backup) and then logging into WoW, and logging back out. Now run a search on your computer for the WTF folder, to see where WoW is creating the new one.

Finally, if you are copying files into the SavedVariables (or any other) folder while WoW is running, that is your problem -- if WoW is running, it's holding a copy of every file in memory, and will write those copies to disk when it exits, overwriting the new files you moved into the folder. Make sure WoW is not running, and then copy the files, and then start WoW.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Reply

Go BackWoWInterface » General Discussion » Tech Chat » SavedVariables question in the WTF folder.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off