Thread Tools Display Modes
Old 04-08-10, 08:47 PM   #1
Dan147
A Murloc Raider
Join Date: Apr 2010
Posts: 4
Lua error

I'm very sorry if this has already been posted. I tried searching and didnt find anything helpful.

I keep getting this error at random, usually in cities. Sometimes i get it when bringing out my mount, other times when doing things with my bag. (actually the latter might be a different error but it pops up with similar frequency.. the mount one happened just now)

Message: Interface\FrameXML\Cooldown.lua:3: attempt to compare number with nil
Time: 04/08/10 22:21:40
Count: 4
Stack: Interface\FrameXML\Cooldown.lua:3: in function <Interface\FrameXML\Cooldown.lua:2>
[C]: in function `CooldownFrame_SetTimer'
Interface\FrameXML\WatchFrame.lua:1194: in function `WatchFrameItem_UpdateCooldown'
Interface\FrameXML\WatchFrame.lua:1210: in function `WatchFrameItem_OnEvent'
[string "*:OnEvent"]:1: in function <[string "*:OnEvent"]:1>

Locals: self = NxListFrms1Cooldown {
0 = <userdata>
}
start = nil
duration = nil
enable = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to compare number with nil"

I have no idea what this coding stuff means lol... just hoping to stop the weird pop-ups. It doesn't seem to be a major bug as everything still works perfectly fine when it happens.
Dan147 is offline  
Old 04-08-10, 08:54 PM   #2
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
I haven't seen this error myself. Besides nUI, what other mods and nUI plugins are you using?
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 04-08-10, 08:57 PM   #3
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,026
Hmm, you wouldn't have carbonite by chance would you ? Nx is if I recall right the prefix for a lot of their variables.

That said, these errors seem to be a more recent occurrence so it makes me suspect that blizzard changed something and didn't document it so now some addons that were coded a certain way are having problems.
__________________
Xrystal is offline  
Old 04-08-10, 09:56 PM   #4
Dan147
A Murloc Raider
Join Date: Apr 2010
Posts: 4
Yeah, I'm running Carbonite, GBot, and Rating Buster. It's not a huge crippling issue, just annoying to have pop ups half the time i bring out my horse.

By the way I just recently upgraded to nui+. I -think- I did a clean install (deleted the old nui folder and put in the new one), maybe I need to delete or replace some other old file?

Also, in both the older nui and the new nui+ I am experiencing the blank frames bug on loggin issue. Reload fixes it, happens about 50% of loggins.

I was curious if maybe GBot was the culprit for the chatframe thingie but no one mentioned it in the other thread.
Dan147 is offline  
Old 04-09-10, 06:35 AM   #5
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Deleting the nUI folder is not, in and of itself, a clean install. A clean install is deleting *all* addons and their saved variables (more or less) if you follow the directions in the FAQ.

The idea behind this type of a clean install is to eliminate as many "unknowns" and "artifacts" as possible to get a "new" UI. If you follow the directions you start out with nothing except nUI and a brand new set of saved variables at which point, if you still have a problem, then we know something we didn't know before. If you don't have a problem then you can start adding your other addons one at a time looking for the problem to appear... if it reappears, we know where the conflict is. If it doesn't then the problem was an artifact of old addons which isn't uncommon.

In any event, the benefit of a thorough clean install is that no matter what the outcome, we have a "known" set of conditions which makes debugging the problem much easier.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 04-09-10, 12:19 PM   #6
Dan147
A Murloc Raider
Join Date: Apr 2010
Posts: 4
Ah I see. Do I need to reinstall my game or just clear out all my addons?

Edit:

Nevermind, i found the FAQ. Doin it now.

Last edited by Dan147 : 04-09-10 at 12:28 PM.
Dan147 is offline  
Old 04-09-10, 12:57 PM   #7
Dan147
A Murloc Raider
Join Date: Apr 2010
Posts: 4
Unhappy

Ok, I did the clean install and with only nui+ I ran around doing some netherwing dailies, went to dalaran and summoned my mounts over and over, and messed with my bags and the error from that seems to be gone.

I tried logging in to some other toons to see if the blank frames issue was still there, and yes it is....
Dan147 is offline  
Old 04-09-10, 01:26 PM   #8
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
OKay -- well at least we have one of the problems resolved. THe other is a known issue that I am trying to find a solution to. For now, a simple '/nui rl' fixes the missing frames at login (even though you can't see the chat edit, you can still do the command)
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Bug Reports » Lua error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off