Thread Tools Display Modes
Unread 11-30-10, 12:11 AM   #1
fjordstorm
A Murloc Raider
Join Date: Dec 2008
Posts: 7
Show tooltip on mouseover of buffs?

Title pretty self explanatory, but is there any way to have a tooltip when you mouseover the areas I have circled in the picture here?

http://gallery.me.com/marklong77#100...&bgcolor=black

Many thanks...
fjordstorm is offline  
Unread 11-30-10, 05:28 AM   #2
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Generally we do not like to click out to another site to view images... it's a security risk. When you have screen shots, you should just attach them to your forum post... you can use the paperclip icon at the top of the message editor, or scroll down to the "Manage Attachments" button, to upload your screen shot with your forum post directly. It's much more secure and less of a hassle for everyone.

That said, I did try to view your screen shot and all I got was a blank page with the gallery header. Please upload your screen shot here and I'll be glad to look at it.

In any event, without having viewed the screen shot, if you're talking about the tooltips on your action bars not displaying while you are in combat, try the command '/nui combattips' -- that should do the trick.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 11-30-10, 01:32 PM   #3
fjordstorm
A Murloc Raider
Join Date: Dec 2008
Posts: 7
Originally Posted by spiel2001 View Post
Generally we do not like to click out to another site to view images... it's a security risk. When you have screen shots, you should just attach them to your forum post... you can use the paperclip icon at the top of the message editor, or scroll down to the "Manage Attachments" button, to upload your screen shot with your forum post directly. It's much more secure and less of a hassle for everyone.

That said, I did try to view your screen shot and all I got was a blank page with the gallery header. Please upload your screen shot here and I'll be glad to look at it.

In any event, without having viewed the screen shot, if you're talking about the tooltips on your action bars not displaying while you are in combat, try the command '/nui combattips' -- that should do the trick.
Sorry about that. Lets try this again. I am talking about the buffs that are either above the chat frame or in the bottom of the HUD (see attached)
Attached Thumbnails
Click image for larger version

Name:	Screen shot 2010-11-30 at 12.55.25 AM copysmall.png
Views:	726
Size:	1.73 MB
ID:	5375  
fjordstorm is offline  
Unread 11-30-10, 01:43 PM   #4
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Okay -- the ones on the left will show you a tooltip if you place the mouse over the icon. The ones under the HUD do not (if I recall correctly) as they are not mouse active (otherwise they would interfere with targeting)
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 11-30-10, 02:27 PM   #5
fjordstorm
A Murloc Raider
Join Date: Dec 2008
Posts: 7
Originally Posted by spiel2001 View Post
Okay -- the ones on the left will show you a tooltip if you place the mouse over the icon. The ones under the HUD do not (if I recall correctly) as they are not mouse active (otherwise they would interfere with targeting)
That is fine for the ones in the middle but I do not get any tooltip on the ones on the left. Is this default behavior and if I accidentally changed something where would I find the option to change it back? (I have looked through the commands and tooltips are set to mouseover in combat so I am not sure why I cannot see them).
fjordstorm is offline  
Unread 11-30-10, 02:44 PM   #6
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
You never get tooltips for the ones on the left, or do you only get the tooltips when not in combat? Do you get any tooltips at all?

Try '/nui tooltips owner' and use '/nui combattips' until you see tooltips are enabled in combat, then see what happens.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 11-30-10, 05:50 PM   #7
fjordstorm
A Murloc Raider
Join Date: Dec 2008
Posts: 7
Originally Posted by spiel2001 View Post
You never get tooltips for the ones on the left, or do you only get the tooltips when not in combat? Do you get any tooltips at all?
I dont get anything at all, regardless of combat state.

Try '/nui tooltips owner' and use '/nui combattips' until you see tooltips are enabled in combat, then see what happens.
Owner seems to done the trick, thanks!
fjordstorm is offline  
Unread 12-01-10, 03:02 PM   #8
Belechannas
A Warpwood Thunder Caller
Join Date: May 2010
Posts: 86
I am having a possibly related issue with the *debuff* icons that appear to the upper left of my HUD. I don't get a tooltip when I mouse over them.

The only way I can actually see the tooltip for the debuff is to target myself. I do get a tooltip when I mouse over the debuff icon on the upper-right of the HUD (my "target", which is myself).

I have /nui combattips set already, and I tried /nui tooltips owner but it didn't solve the issue.

I checked with /nui movers to see if maybe something invisible was occluding the debuff area, and I also tried without the centered HUD extension, which I normally use. Neither of these helped either.

Last edited by Belechannas : 12-01-10 at 03:10 PM.
Belechannas is offline  
Unread 12-01-10, 05:05 PM   #9
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
I suspect all of this is related to the aura changes in 4.0 and I'm not real keen on investing the time to try and fix it in nUI5. If someone can spot the exact cause and code up a quick fix, I'll put it out there, otherwise, I'm going to stay on the nUI6 effort.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 12-05-10, 07:29 PM   #10
Belechannas
A Warpwood Thunder Caller
Join Date: May 2010
Posts: 86
Just to follow-up on this, I looked at the code, but being more of a novice than an expert, I couldn't identify the problem. From some debugging statements I put in, it appears the debuff icon isn't getting mouse-over events.

More weirdly, the behavior seems to change.

When I went to test it, neither the player (debuffs) or target (buffs) were getting tooltips.

On the other hand, for a whole day of questing yesterday, both were working fine.

Later, after taking a break and logging in on a different character, it was back to target buffs getting tooltips, but player debuffs not showing them.
Belechannas is offline  
Unread 12-05-10, 08:02 PM   #11
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Yeah... I'm just about certain this is a taint thing. It's just going to have to wait for the auras in nUI6.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 12-08-10, 07:41 PM   #12
Belechannas
A Warpwood Thunder Caller
Join Date: May 2010
Posts: 86
I played around some more and I think I understand the code and the problem a bit better.

Maybe this was obvious, but it appears that the problem is caused by calling EnableMouse on the secure debuff "button" while in combat. This happens, for instance, when a new debuff is received and a previously invisible "slot" becomes active in combat.

There is a simple fix (simply leave the empty buttons mouse-enabled all the time). This will result in the mouse enter/leave events firing for empty slots, but the handler already checks whether an aura is present before doing anything, so the only side-effect (I think) is some unnecessary calls and immediate returns.

A slightly less ugly fix is to attach/detach the handler for the tooltip (which can be done in combat) as necessary without calling EnableMouse. That is what is done in the attached file.

In the process of looking into this, I think I found a second problem, which is that removing buffs in combat is buggy. The buff you click on may not be the one removed (I think the problem is if buffs are applied in combat). Unlike inspecting my debuffs, this is not something I ever care about doing, so I haven't looked into it closely.
Attached Files
File Type: lua nUI_UnitAura.lua (61.9 KB, 696 views)
Belechannas is offline  
Unread 12-08-10, 11:07 PM   #13
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Yeah... you're up against the ugly dragon boss called taint... it is the bane of an addon author's existence.

What is happening is that nUI is trying to sort the auras based on which one has the least time remaining. It is also trying to show and hide auras. That was fine until 4.0 when the aura buttons became secure code... you cannot show/hide/move secure frames while in combat from an addon... that's what causes taint.

Once tainted, then everything starts to fall apart. So you end up with nUI thinking the aura got moved from one button to another, but the traint broken that, so you're not clicking off the aura you thing you are. THere's a whole cascade of other things that happen.

The fix is not as simple as replacing the regular aura frame with the secure template, or not actually hiding the buttons, it's the whole sort system, secure execution, taint, etc. The only true "fix" is a complete re-write using the new secure aura header logic.... and that's an utter waste of time to do on nUI5 since it's gasping its last breaths as we speak.

By all means, have at it, but understand that the only "fix" is to eliminate all taint in the aura code... no sorting, no show/hide, no moving, resizing, no modifying a variable attached to the frame, etc. Any "touch" of the secure frame while in combat will taint it.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 12-09-10, 12:45 AM   #14
Belechannas
A Warpwood Thunder Caller
Join Date: May 2010
Posts: 86
Yes, I figured it was the updating/sorting of the buffs, since you can't reposition a secure frame and the cancelaura target corresponding to a given button (on the buff bar) is locked in when combat starts.

Anyway, the file attached to my previous post fixes the problem that was bothering me (inability to inspect debuffs).
Belechannas is offline  
Unread 12-09-10, 06:00 AM   #15
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
I appreciate that very much... if I do another nUI5 update, I'll include it.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Technical Support » Show tooltip on mouseover of buffs?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off