Thread Tools Display Modes
Unread 01-10-11, 05:09 PM   #1
dwiechman
A Fallenroot Satyr
Join Date: May 2010
Posts: 22
mouse problems

First of all, I'd like to start out by saying I am not sure what this problem is and have had no luck identifying the source, but here goes:

I am using the Steelseries Wow Special Edition mouse (not the new Cataclysm version). I've been using it for some time now with no trouble, until recently.

At random moments in the game, I can not click on action buttons on any of the action bars. I have to ctrl+alt+del in order to go to task manager and click cancel before it allows me to start clicking on things again.

I am running dual monitors also, and whn this happens, if I move the mouse to the right screen (I play on the left screen) and attempt to click on anything, it will reposition the mouse in the dead middle of my left screen.

I am running Kaspersky 2010 and have scanned my system like 7 times, reinstalled Windows 7, and still nothing. I reloaded the Steelseries Mouse driver twice now, and this is not helping anything.

I'm fresh out of ideas, and ctrl+alt+del is a bad way to deal with this crap. Any help would be greatly appreciated.
dwiechman is offline  
Unread 01-11-11, 12:20 AM   #2
Solgath
A Chromatic Dragonspawn
 
Solgath's Avatar
Join Date: Nov 2008
Posts: 139
first question would be, does it only do it in WoW?
2nd question, have u tried changing usb ports for u mouse? could be a faulty connection,

cause from i have read here, sounds like a issue with the mouse or the connection.
__________________
Solgath is offline  
Unread 01-11-11, 10:36 AM   #3
dwiechman
A Fallenroot Satyr
Join Date: May 2010
Posts: 22
Originally Posted by Solgath View Post
first question would be, does it only do it in WoW?
2nd question, have u tried changing usb ports for u mouse? could be a faulty connection,

cause from i have read here, sounds like a issue with the mouse or the connection.
I just sent the mouse back to Steelseries. If it is the problem, then with any luck, it'll be fixed.
dwiechman is offline  
Unread 01-12-11, 04:38 PM   #4
dwiechman
A Fallenroot Satyr
Join Date: May 2010
Posts: 22
I think you were right, and it was the mouse all along. I am using a cordless mouse now and I have had no issues with not being able to click things.

I can't wait to get my old mouse back though, cause this one sucks.
dwiechman is offline  
Unread 01-18-11, 06:53 AM   #5
Marthisdil
An Onyxian Warder
AddOn Author - Click to view addons
Join Date: Jan 2005
Posts: 350
Hmm - haven't seen that one. Did you install the software and it detected the correct profile?
__________________

Marth



Marthisdil is offline  
Unread 01-19-11, 11:39 AM   #6
dwiechman
A Fallenroot Satyr
Join Date: May 2010
Posts: 22
Well, I was at a buddy's house with the mouse, and in the process of me being there, it shocked me... I mean, not 120v, but ever since, the mouse hadn't worked correctly...

now, I have my old pos cordless mouse and I'm not having the same issues. On the other hand, it is a normal mouse and I totally miss my old mouse.
dwiechman is offline  
Unread 01-19-11, 12:07 PM   #7
Wasgij
A Cliff Giant
 
Wasgij's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2009
Posts: 64
It is a Steel-series Mouse issue . Since the release of Cata the drive has been glitchy they are aware of it and are working on the issue ..... I had the same issue with my WotlK mouse.
__________________
Wasgij is offline  
Unread 01-27-11, 09:00 PM   #8
dwiechman
A Fallenroot Satyr
Join Date: May 2010
Posts: 22
Turns out, the mouse had a short in it at button 4 that caused the problem. They gave me a new mouse.
dwiechman is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Bug Reports » mouse problems

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off