Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-11-12, 05:50 PM   #1
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Viewport bug

Tom --

I'm going to post several here as I confirm them along with the details I can get from the users. When you're sick of me posting them, let me know and I'll stop ~grin~

Simple code snippet to set a fair approximation the viewport being shown...

(pardon me if I do something stupid... not at my computer and doing this off the top of my head)

Code:
local height = UIParent:GetTop() - UIParent:GetBottom();
local width  = UIParent:GetRight() - UIParent:GetLeft();
local frame = CreateFrame( "Frame", "testFrame", UIParent );

frame:SetHeight( 512 * height / 768 );
frame:SetWidth( width );
frame:SetPoint( "BOTTOMLEFT", UIParent, "BOTTOMLEFT", 0, 0 );
frame:SetPoint( "BOTTOMRIGHT", UIParent, "BOTTOMRIGHT", 0, 0 );

WorldFrame:SetPoint( "BOTTOM", frame, "CENTER", 0, 0 );
.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/

Last edited by spiel2001 : 01-11-12 at 05:59 PM.
spiel2001 is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Technical Support » Viewport bug

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off