Reply
Thread Tools Display Modes
Unread 08-05-12, 05:32 AM   #1
Brainn
A Frostmaul Preserver
AddOn Author - Click to view addons
Join Date: Apr 2009
Posts: 263
[Bug] RDX9: Text Info objects not updating

The 'Text Info' object is not updating its text - the text gets set when the window is build, but then never updates. For testing i added a periodic repaint to the window, but even with that the text does not update.
Brainn is offline   Reply With Quote
Unread 08-05-12, 07:24 AM   #2
Brainn
A Frostmaul Preserver
AddOn Author - Click to view addons
Join Date: Apr 2009
Posts: 263
looking at the code, this seems to be caused by a change in RDX\Designs\Texts\InfoText.lua, Line 461:
Code:
--VFLT.AdaptiveSchedule("artf_]] .. objname .. [[", ]] .. otherText[desc.ty].interval .. [[, artf_]] .. objname .. [[);
this line was enabled in the older versions, and from what i understand this creates the repaint schedule for TextInfo objects that are registered with repaintType="interval" - in the destroy code you still have the VFLT.AdaptiveUnschedule enabled.

i reenabled the AdaptiveSchedule in the create code and now it refreshes the text as it should again.
Brainn is offline   Reply With Quote
Unread 08-06-12, 12:03 PM   #3
sigg
Featured Artist
 
sigg's Avatar
Featured
Join Date: Aug 2008
Posts: 1,206
Fixed

I remember, I disabled it when working on the new timer engine.

Thanks
__________________
RDX manager
Sigg
sigg is offline   Reply With Quote
Reply

Go BackWoWInterface » Featured Projects » OpenRDX » OpenRDX Support » OpenRDX: Bug/Error Reports » [Bug] RDX9: Text Info objects not updating

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off