Reply
 
Thread Tools Display Modes
Old 08-25-12, 07:34 AM   #1
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 3,944
[BUG] Invalid property supplied for wowi:dirname.

Error when trying to push a release for my new LibResInfo-1.0 library:

Invalid property supplied for wowi:dirname. Must contain only letters, numbers, underscore, exclamation and dash
Periods are also a valid characters in folder names, and are used by virtually every LibStub library. Please fix so I can publish my library!
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Old 08-25-12, 12:20 PM   #2
Cladhaire
Salad!
 
Cladhaire's Avatar
Premium Member
WoWInterface Super Mod
Featured
Join Date: Jul 2005
Posts: 1,933
You could just add that directory to your repository.. but go ahead and try it again. I've added period to the regexp.
__________________
"There's only one thing that I know how to do well and I've often been told that you only can do what you know how to do well, and that's be you-- be what you're like-- be like yourself. And so I'm having a wonderful time, but I'd rather be whistling in the dark..."
Cladhaire is offline   Reply With Quote
Old 08-25-12, 06:29 PM   #3
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 3,944
Got the same error.

wowi:dirname is set to LibResInfo-1.0

Edit:

I think you accidentally the regexp. I'm now getting the same error on another addon that only has letters in its wowi:dirname property (Progress) and cannot push a release for it either.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!

Last edited by Phanx : 08-25-12 at 06:38 PM.
Phanx is offline   Reply With Quote
Old 08-27-12, 12:43 PM   #4
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,905
Hi Phanx, I rolled back the change for now until we can figure out the regex issue.
Dolby is online now   Reply With Quote
Reply

Go BackWoWInterface » Site Forums » Site help, bugs, suggestions/questions » [BUG] Invalid property supplied for wowi:dirname.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off