Thread Tools Display Modes
Unread 08-29-12, 03:04 PM   #1
lars_ulrich62
A Fallenroot Satyr
Join Date: Jul 2010
Posts: 29
nui lag

installed the new nui. when i run it i get 10 fps.. cant play. when i disable it i get the normal 55 to 60 fps... any idea?
lars_ulrich62 is offline  
Unread 08-29-12, 03:20 PM   #2
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,028
nUI 5 has been known to cause fps issues. I used to go down to 5fps in dungeon runs until I upgraded my computer. Then it went back up to 30+. With all the changes theyve done to the game I wouldn't be surprised that the fps would dip when something like nUI hits it as well. It gathers a lot of information but does eventually release it. I believe nUI 6 alleviates this problem somewhat but I can't remember how much.

But yeah I hear your pain. I used to have to duck out of raids when that happened to me as it was either wipe with me in with nUI running or wipe with me in there without nUI running as I have simply spent too much time with nUI to play without it haha.

That said, it has been noted that since the 5.0.4 patch the fps dipped again. It could be linked to problems that aren't triggering error messages. Unfortunately it is hard to identify the cause in such a big addon without knowing where to start.

On my laptop doing nothing I am at 33 fps which in my eyes is good. With some addons activated it has been known to dip down so I disable them a few times to confirm which ones cause the problem. At present I have nUI+ running with a bulk of my own nUI related plugins turned on and running. But when I was in stormwind it was hell due to the amount of people there.
__________________
Xrystal is offline  
Unread 08-29-12, 05:31 PM   #3
lars_ulrich62
A Fallenroot Satyr
Join Date: Jul 2010
Posts: 29
wel

well that sucks to say the least. i like nui but i guess its time to learn how to use all the single addones. i cant play with 9 fps... its not my pc either..its not a packed stormwind either.. but seems like im the only with the problem. i didnt see a 6 version. but tks for the reply
lars_ulrich62 is offline  
Unread 08-29-12, 07:54 PM   #4
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
nUI6 should be much better... give the nUI6 5.00.00.01 alpha a go and see if you get a better frame rate.

That said, nUI6 is alpha code at present and incomplete... so you won't get all of the features in the current public release of nUI, but it may get the job done for you until I finish adding the features.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 08-30-12, 02:35 AM   #5
UrbanArmitage
An Aku'mai Servant
Join Date: Jun 2012
Posts: 37
Post

A lot of people have been complaining on the Blizzard forums about a significant drop in frame rates with 5.0.4, and I experienced the same both with the vanilla client and nUI last night. Overall I would say there has been a drop in FPS due to the MoP update of around 35% as I am now getting +/- 30 FPS in places I previously got 45 FPS or so.

One thing I have noticed is that they have now included an Ambient Occlusion control in the graphics options in the client, and it causes a significant hit in FPS in some places when enabled as it is by default. I have also noticed some graphics anomalies with AO and Multisampling that weren't there before. Obviously Blizzard have overhauled the graphics engine quite a bit and I am inclined to think that is the main cause of drops in FPS.

That said, last night at the training dummies in Stormwind I was getting around 5 FPS because of all the activity and high number of players in the area. This improved significantly when moving to a quieter area. There was also a significant increase in latency last night so I think before we can make an informed opinion of where FPS losses are coming from we need to let things settle down a bit from the patch rollout and then evaluate the impact of the various graphics options due to the changes in the graphics engine.

My 2c.
UrbanArmitage is offline  
Unread 08-30-12, 02:26 PM   #6
lars_ulrich62
A Fallenroot Satyr
Join Date: Jul 2010
Posts: 29
blind

i must be blind. all i can find is nUI_6.04.03.00.01_Alpha and its no different. 10FPS.. all worked fine til this new patch. i hate new patches.. i think its getting close to retire from wow. real close.

update.. nui seems to be ok now.. it was carbonite causing the lag.. i sorry...

Last edited by lars_ulrich62 : 08-30-12 at 02:39 PM.
lars_ulrich62 is offline  
Unread 08-30-12, 03:28 PM   #7
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,028
Well its good to know that you resolved the issue. It might not be just carbonite, but may be the combination. But then again the official creators of carbonite haven't released a new version. At the moment its just a fan update from what I understand from the threads.
__________________
Xrystal is offline  
Unread 09-06-12, 10:13 AM   #8
lars_ulrich62
A Fallenroot Satyr
Join Date: Jul 2010
Posts: 29
more

more issues now would be the mini map buttonbag. when i click on it, it does not show my icons. just green squares..
and i cant get recount/omen dual stats to show up...
i still have an addon that is causing major lag. to the point of it freezing. but slowly working on it.

Last edited by lars_ulrich62 : 09-06-12 at 10:22 AM. Reason: add more
lars_ulrich62 is offline  
Unread 09-10-12, 01:53 AM   #9
UrbanArmitage
An Aku'mai Servant
Join Date: Jun 2012
Posts: 37
Xrystal has released a patch to fix the green button bag issue, and it works 100%. Take a look at this thread for the patch - http://www.wowinterface.com/forums/s...t=43990&page=2

Hope that helps.
UrbanArmitage is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Bug Reports » nui lag

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off