Thread Tools Display Modes
Unread 08-29-12, 12:51 AM   #1
rmcelroy
A Defias Bandit
Join Date: Dec 2011
Posts: 3
party members not showing

My party when i go into a dungeon does not show on the UI only i am there.
rmcelroy is offline  
Unread 08-29-12, 08:59 AM   #2
Blanckaert
A Flamescale Wyrmkin
Join Date: May 2010
Posts: 121
did you try clicking the party button ? lower left corner, a red button, might say 'Player' 'Party' it will then go through Raid (10/25/40) type thing....
__________________
Have fun, and remember WOW is just a game, for us to enjoy, and all the Addons we use.... remember the programmer is a human too, and MOST times, is doing this as a hobby, so give them time to have their life, so they can fix the addons, so we can have our WOW life.
Blanckaert is offline  
Unread 08-29-12, 01:51 PM   #3
wacko1
A Cyclonian
AddOn Author - Click to view addons
Join Date: Aug 2009
Posts: 48
Originally Posted by Blanckaert View Post
did you try clicking the party button ? lower left corner, a red button, might say 'Player' 'Party' it will then go through Raid (10/25/40) type thing....
yes that does work.

but to give scott or Xrystal a little feedback.......

when u start a party , nui sets it as a 10 man raid and then it doesnt show your party as a normal 5 man.

probably a small typo in the code , but im no coder just giving some feed back of whats happening ;-)
wacko1 is offline  
Unread 08-29-12, 02:17 PM   #4
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,030
I think its something in the new blizz party/raid stuff as I never changed how it switched. Just fixed the variable and function names that were changed and caused the error messages.

Hmm, maybe time to look at how regular wow codes the system as they may be doing something different now.
__________________
Xrystal is offline  
Unread 08-29-12, 02:34 PM   #5
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,030
okay found the problem.

As my brother told me earlier when I mentioned the problem to him. It seems nUI has been informed that when we join a group we are automatically shown as being in raid. Which means nUI is going through the raid group checks to decide which frames to display. Adding the check that there are more than 5 people in the group before switching to raid10 resolves the problem back to how it worked before ...

oooh deja vu effect ... Im sure I've done this all before rofl.


AddOns/nUI/Units/nUI_UnitPanel.lua

Before:
Lua Code:
  1. if unit_info.in_raid then
  2.            
  3.                 -- 5.0.1 Change Start - Function name change
  4.                 -- local size = GetNumRaidMembers();       
  5.                 local size = GetNumGroupMembers();     
  6.                 -- 5.0.1 Change End
  7.                
  8.                 if size > 25 and AutoSwitchPanels["raid40"] then
  9.                     panel_mode = "raid40";
  10.                 elseif size > 20 and AutoSwitchPanels["raid25"] then
  11.                     panel_mode = "raid25";
  12.                 elseif size > 15 and AutoSwitchPanels["raid20"] then
  13.                     panel_mode = "raid20";
  14.                 elseif size > 10 and AutoSwitchPanels["raid15"] then
  15.                     panel_mode = "raid15";
  16.                 elseif AutoSwitchPanels["raid10"] then
  17.                     panel_mode = "raid10";
  18.                 else
  19.                     panel_mode = "party";
  20.                 end
  21.                
  22.             elseif unit_info.in_party then
  23.                 panel_mode = "party";
  24.             end

After:
Lua Code:
  1. if unit_info.in_raid then
  2.            
  3.                 -- 5.0.1 Change Start - Function name change
  4.                 -- local size = GetNumRaidMembers();       
  5.                 local size = GetNumGroupMembers();     
  6.                 -- 5.0.1 Change End
  7.                
  8.                 if size > 25 and AutoSwitchPanels["raid40"] then
  9.                     panel_mode = "raid40";
  10.                 elseif size > 20 and AutoSwitchPanels["raid25"] then
  11.                     panel_mode = "raid25";
  12.                 elseif size > 15 and AutoSwitchPanels["raid20"] then
  13.                     panel_mode = "raid20";
  14.                 elseif size > 10 and AutoSwitchPanels["raid15"] then
  15.                     panel_mode = "raid15";
  16.                 elseif size > 5 and AutoSwitchPanels["raid10"] then
  17.                     panel_mode = "raid10";
  18.                 else
  19.                     panel_mode = "party";
  20.                 end
  21.                
  22.             elseif unit_info.in_party then
  23.                 panel_mode = "party";
  24.             end
__________________

Last edited by Xrystal : 09-01-12 at 04:53 PM.
Xrystal is offline  
Unread 08-29-12, 07:43 PM   #6
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Xrystal --

If you can, keep a tree of your file changes like the last one you sent me and I'll put out another update as things settle down. At present, I can't keep up with fixing both versions... just don't have that much computing power. We can just do another overlay zip file like we just did if that's okay with you.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 08-30-12, 02:22 AM   #7
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,030
Yep it's no problem.

I'll list what to change for those confident enough to do the change as well. If the changes pile up I'll do another patch update for people to tie them over until the next time you do an official patch.
__________________
Xrystal is offline  
Unread 09-01-12, 02:06 PM   #8
flinder5
A Murloc Raider
 
flinder5's Avatar
Join Date: Sep 2012
Posts: 7
im not that known with coding so can u make clear what/where i need to change something?

EDIT: nvm, looked in files and found it it works! im very thankfull next time plz name the filename. its alot easyer for people like me!

Last edited by flinder5 : 09-01-12 at 02:42 PM. Reason: solved
flinder5 is offline  
Unread 09-01-12, 04:21 PM   #9
Daveo77
A Flamescale Wyrmkin
 
Daveo77's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2010
Posts: 138
The file you need to edit is nUI/Units/nUI_UnitPanel.lua to apply Xrystal's fix
Daveo77 is offline  
Unread 09-01-12, 04:52 PM   #10
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,030
oops, my apologies .. I thought I had, I usually do.
__________________
Xrystal is offline  
Unread 09-01-12, 10:25 PM   #11
rmcelroy
A Defias Bandit
Join Date: Dec 2011
Posts: 3
ok that all helped

Ty all it works now :banana
rmcelroy is offline  
Unread 09-02-12, 12:40 PM   #12
IDragonlordI
A Murloc Raider
 
IDragonlordI's Avatar
Join Date: Apr 2012
Posts: 5
Group going to 10 man instead of party

yes please if you could patch this so it works as before because i dont know code or how to fix on my own it would be great and ty
IDragonlordI is offline  
Unread 09-02-12, 12:53 PM   #13
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,030
Okay, for those that aren't sure how to add the extra text to make it work .. here's a file.

You will have to save it manually to where the current version of the file is.

The folder it needs to go in is:

Interface/AddOns/nUI/Units/ which is located where your World of Warcraft installation was made out to.

It will ask you if you want to overwrite. Say Yes.

Then either do a reload of the UI if you were still logged in or log out and then log back in again.
Attached Files
File Type: lua nUI_UnitPanel.lua (24.4 KB, 498 views)
__________________
Xrystal is offline  
Unread 09-11-12, 02:53 PM   #14
IDragonlordI
A Murloc Raider
 
IDragonlordI's Avatar
Join Date: Apr 2012
Posts: 5
raid party member fix

im a noob here
IDragonlordI is offline  
Unread 09-11-12, 02:56 PM   #15
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,030
What stage do you get stuck at Dragon ?

Without the fixed file ( if you're having problems manually updating the addon ) you can simply click your party/raid10/solo etc button until it is at party
__________________
Xrystal is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Bug Reports » party members not showing

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off