Reply
 
Thread Tools Display Modes
Old 09-21-12, 05:44 PM   #1
Kendian
A Molten Giant
 
Kendian's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 614
Custom_class_colors

Ok...I use Stuf, and I use ClassColors. Patch 5.0.4 broke Stuf, but a workable patch was provided by SuicidalKatt, altho its without party frames.

Both addons mentioned have now been reliably updated for this patch/expansion, but they will not work with each other, and it's frustrating me to no ends. I believe it has to do with how Stuf is RegisteringCallBack, but can't figure out where the mistake is being made.

I've tried a fresh WTF folder, just deleting saved variables, and just deleting saved variables for both addons, nothing seems to work. I know its a simple thing I'm over looking, but for the life of me can NOT see it.
__________________
Kendian is offline   Reply With Quote
Old 09-21-12, 05:59 PM   #2
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 3,675
Can you be more specific about what the problem is?
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Old 09-21-12, 06:00 PM   #3
suicidalkatt
A Rage Talon Dragon Guard
 
suicidalkatt's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2008
Posts: 302
Originally Posted by Kendian View Post
Ok...I use Stuf, and I use ClassColors. Patch 5.0.4 broke Stuf, but a workable patch was provided by SuicidalKatt, altho its without party frames.

Both addons mentioned have now been reliably updated for this patch/expansion, but they will not work with each other, and it's frustrating me to no ends. I believe it has to do with how Stuf is RegisteringCallBack, but can't figure out where the mistake is being made.

I've tried a fresh WTF folder, just deleting saved variables, and just deleting saved variables for both addons, nothing seems to work. I know its a simple thing I'm over looking, but for the life of me can NOT see it.
There have been updates to Stuf, are you using the latest version?
suicidalkatt is offline   Reply With Quote
Old 09-21-12, 06:52 PM   #4
Kendian
A Molten Giant
 
Kendian's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 614
Originally Posted by suicidalkatt View Post
There have been updates to Stuf, are you using the latest version?
Yes, its the latest update that's causing the problem. While appreciating your patch, I really would like to have my party frames back, lol~

@Phanx: Yes, it's trying to register a callback and failing, says it has a nil value...I can post the swatter report.

Date: 2012-09-21 18:19:41
ID: -14
Error occured in: Global
Count: 1
Message: ..\AddOns\Stuf\core.lua line 173:
attempt to index field '?' (a nil value)
Debug:
[C]: ?
Stuf\core.lua:173: CCC_CB()
Stuf\core.lua:178: ?()
Stuf\core.lua:109:
Stuf\core.lua:108
__________________

Last edited by Kendian : 09-21-12 at 07:26 PM.
Kendian is offline   Reply With Quote
Old 09-21-12, 09:50 PM   #5
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 3,675
Sounds like Stuf is doing something wrong. Can you post a link to the specific version you're using?
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Old 09-22-12, 07:15 AM   #6
Kendian
A Molten Giant
 
Kendian's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 614
Originally Posted by Phanx View Post
Sounds like Stuf is doing something wrong. Can you post a link to the specific version you're using?
Let me figure out how, lady~

http://www.wowinterface.com/download...nitFrames.html
__________________
Kendian is offline   Reply With Quote
Old 09-22-12, 02:42 PM   #7
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 3,675
Okay, that error indicates that Stuf is not properly initializing its classcolors table, and a class is missing. Try adding this line in Stuf/core.lua, around line 173:
Code:
for class, color in pairs(CUSTOM_CLASS_COLORS) do
	if not classcolor[class] then
		classcolor[class] = {}
		print("Stuf classcolor table was missing an entry for", class)
	end
	classcolor[class].r, classcolor[class].g, classcolor[class].b = color.r, color.g, color.b
It should fix the error and tell you which class wasn't properly initialized, so you can let its author know.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Old 09-22-12, 11:07 PM   #8
Kendian
A Molten Giant
 
Kendian's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 614
My thanks, lady, worked like a charm.

P.S. Is missing entry for monk~
__________________

Last edited by Kendian : 09-22-12 at 11:10 PM.
Kendian is offline   Reply With Quote
Reply

Go BackWoWInterface » AddOns, Compilations, Macros » AddOn Help/Support » Custom_class_colors

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off