Reply
Thread Tools Display Modes
Unread 08-31-12, 02:24 PM   #1
Worcester
A Deviate Faerie Dragon
 
Worcester's Avatar
Join Date: Apr 2008
Posts: 13
Picture Viewer Not Working

I'm trying to find out if this is a browser problem, but so far I don't think it shows up anywhere besides this site. When I try to select one of the pictures showing an addon, instead of the old pop-up picture viewer, I get a new window with just the one picture and no way to view the others. I don't think the mouseover pictures are showing up either, but I need to double-check that.

Any advice would be helpful. I'm running Safari on an iMac.

Edit: The mouseover picture is loading. It just switches to a full view when I click it.
__________________
I prefer rogues to imbeciles, because they sometimes take a rest.
--Alexandre Dumas

Last edited by Worcester : 08-31-12 at 02:28 PM. Reason: Updated info
Worcester is offline   Reply With Quote
Unread 08-31-12, 02:28 PM   #2
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,965
I wonder if you have some bad cache? maybe command-R a few times on the page?

This is what it looks like for me on Safari on 10.8.1
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2012-08-31 at 3.27.08 PM.png
Views:	335
Size:	91.9 KB
ID:	7124  
Dolby is offline   Reply With Quote
Unread 08-31-12, 06:30 PM   #3
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,405
Sounds like either:

(1) you have JavaScript disabled in your browser, or
(2) you have JavaScript disabled on wowinterface.com, or
(3) you're opening the picture link in a new tab/window, so it's bypassing the JavaScript that normally hooks the link click to pop open the overlay, and opening the actual HTML link URL.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 09-03-12, 01:02 PM   #4
Worcester
A Deviate Faerie Dragon
 
Worcester's Avatar
Join Date: Apr 2008
Posts: 13
Still having issues

Yeah, that screen shot is how this website used to function for me. The Command-R didn't seem to help, and I definitely have javascript enabled at the browser level. Not sure I know how to change that on a per-website basis. I'm still running Safari 5 on 10.6.8. To my knowledge, no significant updates have come through except for maybe a Flash update. Would that be an issue? I don't really know how to distinguish one problem from another in that sense. Thanks for the help!

Edit: I should also note that when I first click on the picture window, it starts to expand as it once did, but then almost instantly switches to the "full view" with no option to look at the other pictures in the batch.
__________________
I prefer rogues to imbeciles, because they sometimes take a rest.
--Alexandre Dumas

Last edited by Worcester : 09-03-12 at 01:06 PM. Reason: New info
Worcester is offline   Reply With Quote
Unread 09-11-12, 11:58 AM   #5
Tarquin
A Murloc Raider
Join Date: Dec 2005
Posts: 7
Same problem here.

The picture starts to appear in the grey pop-up overlay and then it rapidly switches to a new window with only the single picture and no way to view the others.

I am running 10.6.8 and have tried in Safari, Chrome and Firefox and no difference between them.

I do have JavaScript turned on in each.
Tarquin is offline   Reply With Quote
Unread 10-07-12, 02:09 PM   #6
Worcester
A Deviate Faerie Dragon
 
Worcester's Avatar
Join Date: Apr 2008
Posts: 13
Researching...

After some research, it looks like the problem and solution may lie in the Java Preferences app in the Utilities folder. However, I'm quite confused as to all the settings.
__________________
I prefer rogues to imbeciles, because they sometimes take a rest.
--Alexandre Dumas
Worcester is offline   Reply With Quote
Unread 10-07-12, 02:43 PM   #7
myrroddin
Premium Member
 
myrroddin's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Oct 2008
Posts: 384
I was wondering about this myself. I was a bit confused for a while because it wasn't exclusive to WowInterface; Curse's pictures were not loading properly either. After some thought, I figured it out: some of FireFox's plugins are not working as intended.
  • FireFox 16.0
  • GoPhotoIt 1.4 <<< disabled now
  • schillr 1.7 <<< disabled now
With these two turned off, pictures load properly for me. What if you don't have those plugins? Check your other plugins, see if any affect pictures, thumbnails, etc, and turn them off.
myrroddin is offline   Reply With Quote
Unread 10-07-12, 07:16 PM   #8
Worcester
A Deviate Faerie Dragon
 
Worcester's Avatar
Join Date: Apr 2008
Posts: 13
Still not working on Safari

So... I'm pretty sure I checked out this site on Firefox months ago and I don't think it was working. Now it is, though. Tried comparing the settings in Safari to Firefox... but no luck so far. It's a minor inconvenience, I suppose. Still, wish I could figure it out.

Actually, I suppose I could just play WoW instead.
__________________
I prefer rogues to imbeciles, because they sometimes take a rest.
--Alexandre Dumas
Worcester is offline   Reply With Quote
Unread 10-08-12, 10:59 PM   #9
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,965
We use the standard jquery.lightbox for the pictures and this is the script that needs to load... http://cdn.wow.mmoui.com/clientscrip...lightbox.js?v2

Is that blank for you? If so then there may be in issue with our CDN in your area.
Dolby is offline   Reply With Quote
Unread 10-09-12, 11:19 PM   #10
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,405
On a related note, rather than hardcoding style="display:none" on images other than the first one, it would be better to apply this style from the lightbox script itself, so that users without JavaScript, or users for whom the lightbox script isn't loading for some reason, can still see those images.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 10-09-12, 11:21 PM   #11
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,965
Originally Posted by Phanx View Post
On a related note, rather than hardcoding style="display:none" on images other than the first one, it would be better to apply this style from the lightbox script itself, so that users without JavaScript, or users for whom the lightbox script isn't loading for some reason, can still see those images.
Then you get a flash of images on slower to load systems, it would quickly show all the images and then hide them as it loads the js. Now this would only happen when the js isn't cached and they hit the fileinfo page directly. It would be better to just put some css in noscript.
Dolby is offline   Reply With Quote
Reply

Go BackWoWInterface » Site Forums » Site help, bugs, suggestions/questions » Picture Viewer Not Working

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off