Reply
Thread Tools Display Modes
Unread 02-22-13, 01:31 AM   #1
ravagernl
Premium Member
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 1,156
AddOn image lightbox not working correctly on chrome, os x

So this has been bugging me lately.

Whenever I click the image thumbnail of any AddOn/compilation I see the lightbox open but the event is not prevented correctly (at least for chrome on os x), and thus I can not see any images except for the first one. The image is opened in a full window/tab instead of in a lightbox.

Chrome on windows however does open the lightbox correctly and I'm not having this problem with os x chrome on any other site so I think it's not a webkit bug.

Would it be possible for wowi to upgrade the lightbox script / use a different lightbox implementation (such as colorbox or fancybox)?

Last edited by ravagernl : 02-22-13 at 11:47 AM.
ravagernl is offline   Reply With Quote
Unread 02-22-13, 01:35 AM   #2
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,993
Hi ravagernl,

Sorry to hear your having trouble with our lightbox script.

I've had a few people running ad blocking extentions have issues with the cdn that serves the js for the lightbox. It works just great in OSX using chrome so you may want to check your ad blocking extension in chrome. It's been tested many times in OSX Chrome, Safari, Firefox, Win7/8 Chrome, Firefox, IE9+, Ubtunu Firefox.

If you are not running adblock please please disable all your extensions and see if it works for you, then re-enable until you find what is blocking it. Or list your installed extentions here and I'll do some testing too.

Unfortunately colorbox or fancybox has some compatibility issues as well, at least the last time I had checked into them.

http://cdn.wow.mmoui.com/clientscrip...lightbox.js?v2
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2013-02-16 at 7.25.18 PM.png
Views:	158
Size:	659.0 KB
ID:	7578  

Last edited by Dolby : 02-22-13 at 01:50 AM.
Dolby is online now   Reply With Quote
Unread 02-22-13, 10:35 AM   #3
ravagernl
Premium Member
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 1,156
Originally Posted by Dolby View Post
If you are not running adblock please please disable all your extensions and see if it works for you, then re-enable until you find what is blocking it. Or list your installed extentions here and I'll do some testing too.

http://cdn.wow.mmoui.com/clientscrip...lightbox.js?v2
I indeed am running adblock plus.

I see what you did there... the function "hideAds" and "restoreAds" are preventing the lightbox from returning false because they are trying to find #cubeAd and #header-ad and as a result of not finding them, chrome throws an error about trying to modify the style property.

I guess I'll just have to make up my mind if I want to see ads or see the lightbox images because I think this was done on purpose hihi
Or I might subscribe to premium.. hmm..

EDIT: After messing around with dotjs, I can tell you that e.preventDefault() fixes the lightbox.

Last edited by ravagernl : 02-22-13 at 11:10 AM.
ravagernl is offline   Reply With Quote
Unread 02-22-13, 12:48 PM   #4
Cairenn
Credendo Vides
 
Cairenn's Avatar
Premium Member
WoWInterface Admin
Join Date: Mar 2004
Posts: 6,938
Well, ads and premium are how we pay our bills.
Cairenn is offline   Reply With Quote
Unread 02-22-13, 01:23 PM   #5
ravagernl
Premium Member
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 1,156
Yeah, I figured I would just subscribe now anyway
ravagernl is offline   Reply With Quote
Unread 02-22-13, 01:29 PM   #6
Cairenn
Credendo Vides
 
Cairenn's Avatar
Premium Member
WoWInterface Admin
Join Date: Mar 2004
Posts: 6,938
*hugs ravagernl*

Thank you.
Cairenn is offline   Reply With Quote
Reply

Go BackWoWInterface » Site Forums » Site help, bugs, suggestions/questions » AddOn image lightbox not working correctly on chrome, os x

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off