Quantcast AddOn constantly being deleted. Why? - WoWInterface
Thread Tools Display Modes
08-19-17, 10:06 AM   #1
myrroddin
A Molten Giant
 
myrroddin's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2008
Posts: 878
AddOn constantly being deleted. Why?

I am baffled by this behaviour. Everytime I install WIM_ElvUI, it gets deleted by Windows 10. None of my other addons suffer the random deletion. This is not a permissions issue, as I have WoW installed to my D:\ drive, meaning there should be no write conflicts.

As for installer clients like Twitch, Zygor, TSM, or TukUI, they don't have issues either, and WoW itself saves variables no problem. I have never seen this oddity before, and I've been scratching my head for a week or two trying to figure it out.

Just to clarify, I can unzip and install the addon, load the game, and it works; however, if I reload the UI, log out, or exit the game, then WIM_ElvUI promptly disappears. It is like Warcraft itself doesn't want that addon!
  Reply With Quote
08-19-17, 02:12 PM   #2
Ketho
A Molten Giant
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 846
It does not seem to happen for me at least

https://streamable.com/uip0g

Last edited by Ketho : 08-19-17 at 02:14 PM.
  Reply With Quote
08-19-17, 02:29 PM   #3
Dridzt
A Pyroguard Emberseer
 
Dridzt's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2005
Posts: 1,251
Are you using some kind of addon installer (curse or mmoui one?)
  Reply With Quote
08-19-17, 06:41 PM   #4
myrroddin
A Molten Giant
 
myrroddin's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2008
Posts: 878
Yes, I am using Curse/Twitch. But I think I fixed it by experimenting. I suspect I didn't save the Curse client's "sync" feature, as the addon is staying installed this time.
  Reply With Quote

WoWInterface » AddOns, Compilations, Macros » AddOn Help/Support » AddOn constantly being deleted. Why?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off