Quantcast Custom sound files disabled? - Page 2 - WoWInterface
 
Thread Tools Display Modes
10-02-14, 08:19 PM   #21
Gello
A Firelord
AddOn Author - Click to view addons
Join Date: Jan 2005
Posts: 484
PlaySoundFile("Interface\\AddOns\\MyAddon\\CustomSound.ogg")

works now.

Replacing sounds in the default Data\Sound directory does not work still.
 
10-11-14, 01:01 PM   #22
oscarucb
A Murloc Raider
 
oscarucb's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2009
Posts: 5
Custom ogg files work in PlaySoundFile, custom MP3 files still do not (silent failure).

Not sure if this is a remaining bug or if they are intentionally dropping MP3 support.
 
10-11-14, 10:22 PM   #23
Talyrius
An Onyxian Warder
 
Talyrius's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2008
Posts: 354
At this point, it's probably intentional.
 
10-11-14, 11:32 PM   #24
Fizzlemizz
I did that?
 
Fizzlemizz's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2011
Posts: 816
Given the environmental differences between live and beta/ptr I wouldn't accept anything as gospel until it's presented on the live servers.
__________________
Fizzlemizz
Maintainer of Discord Unit Frames and Discord Art.
Author of FauxMazzle and Move Pad Plus.
 
10-15-14, 07:33 PM   #25
Resike
A Pyroguard Emberseer
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 1,222
So they really removed the .mp3 support for custom sounds?
 
10-15-14, 07:40 PM   #26
Fizzlemizz
I did that?
 
Fizzlemizz's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2011
Posts: 816
I can't get any custome sounds to be audible even though PlaySoundFile true for willPlay (.ogg, .wav, .mp4).
__________________
Fizzlemizz
Maintainer of Discord Unit Frames and Discord Art.
Author of FauxMazzle and Move Pad Plus.
 
10-15-14, 07:48 PM   #27
Resike
A Pyroguard Emberseer
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 1,222
Originally Posted by Fizzlemizz View Post
I can't get any custome sounds to be audible even though PlaySoundFile true for willPlay (.ogg, .wav, .mp4).
I can play .oggs but it's dogshit. You must use single forward slash in the playstring.
 
10-15-14, 08:10 PM   #28
Fizzlemizz
I did that?
 
Fizzlemizz's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2011
Posts: 816
Originally Posted by Resike View Post
I can play .oggs but it's dogshit. You must use single forward slash in the playstring.
I've tried single forward and double back, nada. I know the files work outside WoW and PlaySoundFile seems to think they're ok. So much for my first attemt to use custom audio unless they need specific formating like textures.
__________________
Fizzlemizz
Maintainer of Discord Unit Frames and Discord Art.
Author of FauxMazzle and Move Pad Plus.
 
10-16-14, 08:31 AM   #29
Resike
A Pyroguard Emberseer
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 1,222
The thing is .mp3 sounds worked fine on the wod beta/ptr builds.
 
10-16-14, 11:33 AM   #30
Resike
A Pyroguard Emberseer
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 1,222
Any confirmation on the mp3 unsupport? Because if Blizzard realises "Oh guys it wasn't working because we slipped 1 char with the file extension" while i'm converting my fuckloads of mp3 files, i'll be mad.
 
10-16-14, 12:56 PM   #31
Fizzlemizz
I did that?
 
Fizzlemizz's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2011
Posts: 816
Originally Posted by Resike View Post
Any confirmation on the mp3 unsupport? Because if Blizzard realises "Oh guys it wasn't working because we slipped 1 char with the file extension" while i'm converting my fuckloads of mp3 files, i'll be mad.
I'm not sure if you're not suffering from the same thing I am. I played an mp3 files and PlaySoundFile returned true for willPlay but I heard nothing. I downloaded FemaleAnnouncer to test and the .ogg files in that addon played and I heard but my .ogg files "willPlay" but I don't hear anything. It's a mystery.

Edit: It turns out my problem is that not all .ogg files are the same.
__________________
Fizzlemizz
Maintainer of Discord Unit Frames and Discord Art.
Author of FauxMazzle and Move Pad Plus.

Last edited by Fizzlemizz : 10-16-14 at 01:42 PM.
 
10-16-14, 02:42 PM   #32
Resike
A Pyroguard Emberseer
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 1,222
Originally Posted by Fizzlemizz View Post
I'm not sure if you're not suffering from the same thing I am. I played an mp3 files and PlaySoundFile returned true for willPlay but I heard nothing. I downloaded FemaleAnnouncer to test and the .ogg files in that addon played and I heard but my .ogg files "willPlay" but I don't hear anything. It's a mystery.

Edit: It turns out my problem is that not all .ogg files are the same.
Wow was very pricky about the mp3 encoding either, the willPlay probably only test if it's a right extension or not.
 
10-16-14, 02:59 PM   #33
Seerah
Fishing Trainer
 
Seerah's Avatar
WoWInterface Super Mod
Featured
Join Date: Oct 2006
Posts: 10,395
Originally Posted by Resike View Post
You must use single forward slash in the playstring.
Where did you hear/see this?
__________________
"You'd be surprised how many people violate this simple principle every day of their lives and try to fit square pegs into round holes, ignoring the clear reality that Things Are As They Are." -Benjamin Hoff, The Tao of Pooh

 
10-16-14, 03:38 PM   #34
Fizzlemizz
I did that?
 
Fizzlemizz's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2011
Posts: 816
It works both ways, \\ or /.... \o/
__________________
Fizzlemizz
Maintainer of Discord Unit Frames and Discord Art.
Author of FauxMazzle and Move Pad Plus.
 
10-16-14, 04:47 PM   #35
Resike
A Pyroguard Emberseer
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 1,222
Originally Posted by Seerah View Post
Where did you hear/see this?
Not sure, just tested it with yesterday's patch, however seems like it's working with both ways today. However i could have made a typo and thats why it failed after beeing up for 15 hours of coding.

Last edited by Resike : 10-16-14 at 04:56 PM.
 
10-24-14, 07:02 AM   #36
Haleth
This Space For Rent
 
Haleth's Avatar
WoWInterface Super Mod
Featured
Join Date: Sep 2008
Posts: 1,173
A fix is in the works for this issue:

http://us.battle.net/wow/en/forum/to...8132?page=2#27
 
10-24-14, 10:50 AM   #37
Resike
A Pyroguard Emberseer
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 1,222
Originally Posted by Haleth View Post
A fix is in the works for this issue:

http://us.battle.net/wow/en/forum/to...8132?page=2#27
Oh mai facken god, already finished with the converting.
 
 

WoWInterface » Site Forums » Archived Beta Forums » WoD Beta archived threads » Custom sound files disabled?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off