Quantcast Creating 100 SecureActionButtons -> Lag - WoWInterface
Thread Tools Display Modes
06-03-18, 08:56 AM   #1
jofmayer
A Murloc Raider
Join Date: Jul 2008
Posts: 6
Creating 100 SecureActionButtons -> Lag

Hi,

I want to use a bunch (100+) of SecureActionButtons in the result list of my addon (https://github.com/endymonium/keystrokelauncher).

BUT that takes some time (~0.5s for 100) and they do not seem to be cached. Even through I understood that Ace3 has a frame pool build in and is already doing some kind of caching.

Here is the Ace3 widget: https://github.com/endymonium/keystr...tionButton.lua
Here is where I use that: https://github.com/endymonium/keystr.../Core.lua#L817

Any ideas how to solve this? Is there any other frame object which allows me to execute spells when I click on it?

Thanks,
Jan
  Reply With Quote
06-03-18, 05:04 PM   #2
MunkDev
A Scalebane Royal Guard
 
MunkDev's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2015
Posts: 401
Lua Code:
  1. AceGUI:Release(widget)
Use this to return them to the object pool.

My personal solution to generating/setting up a crap ton of frames is to use a coroutine that yields after a couple of frames, which gives the appearance of the data loading in chunks. It was the only way I could get it to not stall the game because of the large quantity of frames used for this particular use case.
__________________
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Creating 100 SecureActionButtons -> Lag

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off