Quantcast Not saveing position on exit of vehicle? - WoWInterface
Thread Tools Display Modes
12-04-10, 12:01 AM   #1
dreamcatcher
A Black Drake
 
dreamcatcher's Avatar
AddOn Author - Click to view addons
Join Date: Sep 2010
Posts: 82
Question Not saveing position on exit of vehicle?

Having a hard time here. I have all action bars set and sized how I want them, but when I exit a vehicle the placement of the action bars gets reset. If I do a reload UI there back to how I have them set in the file.

How do I lock the placement of my action bars and vehicle frame so they don't reset?

Code:
-- DreamBars
local MainScale = 0.8

--Main Bar
MainMenuBar:ClearAllPoints();
MainMenuBar:SetPoint("BOTTOM", UIParent, 0, 0);
MainMenuBar:SetScale(MainScale);

--Vehicle Bar
VehicleMenuBar:ClearAllPoints();
VehicleMenuBar:SetPoint("BOTTOM", MainMenuBar, 0, 0);
VehicleMenuBar:SetScale(MainScale);
Secound question: I got the side bars to change from vertical to horizontal and was able to move the position of the left side bar but I could not get the right side bar to move out only up or down.

Any one know how I can do this? Or better yet I would love to make the right side bar into 2 rows.

Code:
--Right Bar 1
MultiBarRight:ClearAllPoints();
MultiBarRight:SetPoint("CENTER", MainMenuBar, 22, -236);
MultiBarRight:SetScale(MainScale);

for i,v in ipairs{"Right"} do for i = 2, 12 
	do local n = "MultiBar"..v.."Button" 
	local btn = _G[n..i] 
	btn:ClearAllPoints();
	btn:SetPoint("LEFT", n..i - 1, "RIGHT", 6, 0) end 
end

--Right Bar 2
MultiBarLeft:ClearAllPoints();
MultiBarLeft:SetPoint("CENTER", MainMenuBar, 22, -236);
MultiBarLeft:SetScale(MainScale);

for i,v in ipairs{"Left"} do for i = 2, 12 
	do local n = "MultiBar"..v.."Button" 
	local btn = _G[n..i] 
	btn:ClearAllPoints();
	btn:SetPoint("LEFT", n..i - 1, "RIGHT", 6, 0) end 
end

local DreamBars  = CreateFrame("Frame", "dreambars", nil);
	DreamBars :RegisterEvent("PLAYER_ENTERING_WORLD")

Last edited by dreamcatcher : 12-04-10 at 12:03 AM. Reason: miss spelled
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Not saveing position on exit of vehicle?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off