Quantcast Blame the addon sending messages to the wrong channel - WoWInterface
Thread Tools Display Modes
07-04-18, 10:38 AM   #1
yoshimo
A Fallenroot Satyr
Join Date: May 2006
Posts: 22
Blame the addon sending messages to the wrong channel

Every now and then i stumble upon an addon that tries to use SendAddonMessage with the wrong channel as argument. This results in "you aren't in a party/raid/.." being printed repeatedly by the game.

I think there once was an addon that hooked this function and called out the offender, but the memory is too vague and i can't find it anymore.
My chatlogs also do no longer have a lua snippet of the same function.
Does anyone remember what we used back then?
  Reply With Quote
07-04-18, 04:53 PM   #2
Xrystal
nUI Maintainer
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,144
A simple addon search on this site for the word Addon in the title and 3 pages down found this one.

http://www.wowinterface.com/download...onMessage.html

It sounds like it will do what you want even if it isn't the one you were talking about. Otherwise, do a search and see if the one you recall jumps out at you.
__________________
  Reply With Quote
07-07-18, 05:37 AM   #3
yoshimo
A Fallenroot Satyr
Join Date: May 2006
Posts: 22
Something like that yea. Needs a little work though as 5.0.4 has changed the api a little bit.
More specifically https://www.wowace.com/projects/youarentinapartyfix but it didn't show up on the initial search

Last edited by yoshimo : 07-07-18 at 06:06 AM.
  Reply With Quote

WoWInterface » AddOns, Compilations, Macros » AddOn Search/Requests » Blame the addon sending messages to the wrong channel

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off