Quantcast Beta - Aurora Error - WoWInterface
Thread Tools Display Modes
07-04-18, 02:21 PM   #1
Koleckai
A Fallenroot Satyr
Join Date: Aug 2008
Posts: 22
Beta - Aurora Error

After the last patch, I started receiving this error:
Code:
x1  ...ins\Aurora\Skin\SharedXML\SharedUIPanelTemplates.lua:383: attempt to index local 'Slider' (a nil value)
Stack: ...ins\Aurora\Skin\SharedXML\SharedUIPanelTemplates.lua:383: in function 'HorizontalSliderTemplate'
...Skins\Aurora\Skin\FrameXML\OptionsPanelTemplates.lua:52: in function 'OptionsSliderTemplate'
...I_Skins\Aurora\Skin\SharedXML\VideoOptionsPanels.lua:23: in function 'VideoOptionsSliderTemplate'
...I_Skins\Aurora\Skin\SharedXML\VideoOptionsPanels.lua:151: in function '?'
RealUI_Skins\Aurora\Skin\init.lua:116: in function <RealUI_Skins\Aurora\Skin\init.lua:88>
Time: 2018/07/04 13:17:46 Index: 1/4
Version: 2.0.0.Beta2
Locals:
Slider = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index local 'Slider' (a nil value)"
Base = <table> {
    SetHighlight = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:416
    GetSkinList = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:41
    SetTexture = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:550
    CreateBackdrop = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:320
    SetBackdrop = <function> defined =[C]
    CreateColor = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:910
    Post = <table> {}
    IsTextureRegistered = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:545
    RegisterTexture = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:588
    CropIcon = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:55
    Pre = <table> {}
    AddSkin = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:33
    SetFont = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:348
    SetBackdropColor = <function> defined @RealUI_Skins\Aurora\Skin\deprecated.lua:38
}
Color = <table> {
    highlight = <table> {}
    cyan = <table> {}
    Lightness = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:894
    grayLight = <table> {}
    Saturation = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:890
    button = <table> {}
    red = <table> {}
    Hue = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:886
    blue = <table> {}
    Post = <table> {}
    Create = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:910
    white = <table> {}
    frame = <table> {}
    grayDark = <table> {}
    black = <table> {}
    green = <table> {}
    Pre = <table> {}
    yellow = <table> {}
    violet = <table> {}
    gray = <table> {}
}
I noticed there was an update for Aurora (on Curseforge) but there hasn't been one for "RealUI_Skins" yet. Is there something I need to update to clear this error?

Doesn't seem related but since this error started, the buttons in the actionbar are also overlapping each other.
  Reply With Quote
07-04-18, 04:02 PM   #2
Koleckai
A Fallenroot Satyr
Join Date: Aug 2008
Posts: 22
Also receiving this error which appears to be a conflict with another Addon.

Code:
x35  ...ns\RealUI_Skins\Aurora\Skin\FrameXML\GameTooltip.lua:23: attempt to index field '_auroraIconBorder' (a nil value)
Stack: ...ns\RealUI_Skins\Aurora\Skin\FrameXML\GameTooltip.lua:23: in function <...ns\RealUI_Skins\Aurora\Skin\FrameXML\GameTooltip.lua:22>
[C] in function 'EmbeddedItemTooltip_PrepareForItem'
FrameXML\GameTooltip.lua:934: in function 'EmbeddedItemTooltip_SetItemByQuestReward'
FrameXML\GameTooltip.lua:202: in function 'GameTooltip_AddQuestRewardsToTooltip'
WorldQuestTab\WorldQuestTab-8.0.01.lua:1560: in function 'ScanTooltipRewardForPattern'
WorldQuestTab\WorldQuestTab-8.0.01.lua:1600: in function 'SetQuestReward'
WorldQuestTab\WorldQuestTab-8.0.01.lua:1708: in function 'AddQuest'
WorldQuestTab\WorldQuestTab-8.0.01.lua:1729: in function 'AddQuestsInZone'
WorldQuestTab\WorldQuestTab-8.0.01.lua:1751: in function 'LoadQuestsInZone'
WorldQuestTab\WorldQuestTab-8.0.01.lua:1825: in function 'UpdateFlightMapPins'
WorldQuestTab\WorldQuestTab-8.0.01.lua:2220: in function <WorldQuestTab\WorldQuestTab.lua:2220>
[C] in function 'RefreshAllData'
...rd_SharedMapDataProviders\WorldQuestDataProvider.lua:167: in function 'OnEvent'
...ns\Blizzard_MapCanvas\MapCanvas_DataProviderBase.lua:99: in function 'SignalEvent'
...ace\Blizzard_MapCanvas\Blizzard_MapCanvas.lua:75: in function 'OnEvent'
...ace\Blizzard_FlightMap\Blizzard_FlightMap.lua:93: in function <...ace\Blizzard_FlightMap\Blizzard_FlightMap.lua:88>
Time: 2018/07/04 14:56:09 Index: 6/6
Version: 2.0.0.Beta2
Locals:
self = <unnamed> {
    0 = <userdata>
    Text = <unnamed> {}
    FollowerTooltip = WQT_TooltipGarrisonFollowerTooltip {}
    yspacing = 13
    IconOverlay = <unnamed> {}
    Count = <unnamed> {}
    IconBorder = <unnamed> {}
    itemID = 157871
    Tooltip = WQT_TooltipTooltip {}
    Icon = <unnamed> {}
}
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index field '_auroraIconBorder' (a nil value)"
  Reply With Quote
07-08-18, 02:09 PM   #3
Koleckai
A Fallenroot Satyr
Join Date: Aug 2008
Posts: 22
Thanks for Beta 3. It resolves both of these issues.
  Reply With Quote

WoWInterface » Featured Projects » RealUI » Beta - Aurora Error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off