Quantcast Error in Blizzard API when Hiding - WoWInterface
Thread Tools Display Modes
05-29-18, 01:01 AM   #1
Galaxy119
A Flamescale Wyrmkin
 
Galaxy119's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2014
Posts: 111
Error in Blizzard API when Hiding

When I hide the MainMenuArtBar.LeftEndCap, RightEndCap and MainMenuArtBarBackground.BackgroundSmall textures, I get this UI error
Code:
Message: Interface\FrameXML\MainMenuBar.lua:378: attempt to compare number with nil
Time: Mon May 28 23:59:24 2018
Count: 1
Stack: Interface\FrameXML\MainMenuBar.lua:378: attempt to compare number with nil
Interface\FrameXML\MainMenuBar.lua:378: in function `ChangeMenuBarSizeAndPosition'
Interface\FrameXML\MainMenuBar.lua:110: in function <Interface\FrameXML\MainMenuBar.lua:56>

Locals: self = MainMenuBar {
 0 = <userdata>
 OnShow = <function> defined @Interface\FrameXML\MainMenuBar.lua:28
 OnLoad = <function> defined @Interface\FrameXML\MainMenuBar.lua:10
 ChangeMenuBarSizeAndPosition = <function> defined @Interface\FrameXML\MainMenuBar.lua:352
 OnEvent = <function> defined @Interface\FrameXML\MainMenuBar.lua:56
 state = "player"
 SetPositionForStatusBars = <function> defined @Interface\FrameXML\MainMenuBar.lua:33
 slideOut = <unnamed> {
 }
 OnStatusBarsUpdated = <function> defined @Interface\FrameXML\MainMenuBar.lua:6
}
rightMultiBarShowing = nil
_ = 1721259
width = 550
height = 49
scale = 1
rightGryphon = nil
xOffset = 0
(*temporary) = 958.3193359375
(*temporary) = MicroButtonAndBagsBar {
 0 = <userdata>
 MicroBagBar = <unnamed> {
 }
}
(*temporary) = 958.3193359375
(*temporary) = -3
(*temporary) = <userdata>
(*temporary) = 0.64453125
(*temporary) = false
(*temporary) = false
(*temporary) = "attempt to compare number with nil"
I'm hiding the textures simply by using SetTexture(nil) but I feel this is wrong, due to the errors.
I don't get this error using this method to hide those textures on live.
__________________
My Addons | "If someone says something is impossible, they either lack imagination, or lack determination."
  Reply With Quote
05-29-18, 04:48 AM   #2
Ammako
A Cobalt Mageweaver
 
Ammako's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2016
Posts: 246
What if you used :Hide() or :SetAlpha(0) on the textures instead?
__________________
  Reply With Quote
05-29-18, 05:26 AM   #3
Galaxy119
A Flamescale Wyrmkin
 
Galaxy119's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2014
Posts: 111
SetAlpha worked beautifully, thank you.
__________________
My Addons | "If someone says something is impossible, they either lack imagination, or lack determination."
  Reply With Quote

WoWInterface » PTR » PTR API and Graphics Changes » Error in Blizzard API when Hiding

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off