Quantcast Version: 10.0.1_alpha - WoWInterface
Thread Tools Display Modes
10-26-14, 06:36 AM   #1
A Theradrim Guardian
Join Date: Oct 2008
Posts: 60
Version: 10.0.1_alpha

I have seen a few things I think are bugs.

I went through the shattrath portal to Orgrimmar and I got a [VFL] id already existnameplatesearch
Not sure if it is a bug but it didn't seem normal.

I am using the defaultui raid frames. Been using these since wotlk and I see a role icon has been added to them. It displays a healing symbol for me even though I am feral kitty spec. This is while I am solo'ing. I have not tested in a group or raid yet. I prefer to use the raid frame while solo.

This is just stuff I seen right off hand, without doing much digging yet.

First edit:
Ok, I went out to Pandaria the jade forest through the Org portal. I then went to the flight master to fly to vale of eternal blossoms, horde one. But no matter what flight path I clicked on it would not register. I first disabled all add-ons except OpenRDX. Still would not let me click, fly, to any location on the map. I disabled OpenRDX and the first flight path I clicked on it worked. So this tells me it's something with OpenRDX but I did not get any error messages.

Second Edit:
This might be my problem with a custom definition on bar id mainbar 1.

I use a custom definition on mainbar1 and mainbar2. But to my knowledge I included the proper commands for mainbar1 to switch over to vehicle, possess etc. Anyways here is the definition.

[mod:ctrl] 2; [bar:2] 1; [bar:3] 2; [bar:4] 3; [bonusbar:1,stealth] 8; [bonusbar:1] 6;

At this point everything worked as expected. So I continued and added in the parts for possess, and vehicles. The full custom definition below.

[mod:ctrl] 2; [bar:2] 1; [bar:3] 2; [bar:4] 3; [bonusbar:1,stealth] 8; [bonusbar:1] 6; [vehicleui] 11; [possessbar] 11; [overridebar] 13;

I have no idea what overridebar does except I seen it in the defaultui definition so thought I would need it. If these look correct then RDX is not switching the bars over to vehicle. I can get the vehicle bar to show up on a reloadui however. This might be user error but I can't seem to figure it out so......

Edit 3:
Ok, more info on the flight path issue. I was at Splintertree post trying to fly to Orgrimmar. This time I recieved a Lua Error.

[VFL][*] Lua Error: Interface\AddOns\RDX\MapMgr\Travels\Travel.lua:122 attempt to index global 'NxCData' (a nil value)
[VFL[ TakeTaxiNode : get data from RDX FS
[VFL][*] Lua Error: Interface\AddOns\RDX\MapMgr\Travels\Travel.lua:252 attempt to index global 'NxCData' (a nil value)

Stack trace:
Interface\AddOns\RDX\MapMgr\Travels\Travel.lua:112: in function `hsig'
Interface\AddOns\VFL\Core\DispatchTable.lua:119: in function <Interface\AddOns\VFL\Core\DispatchTable.lua:117>

Stack trace:
Interface\AddOns\RDX\MapMgr\Travels\Travel.lua:198: in function `TakeTaxiNode'
[string "*:OnClick"]:1: in function <[string "*:OnClick"]:1>

Last edited by MNKyDeth : 10-26-14 at 07:12 PM.
  Reply With Quote
10-27-14, 01:07 PM   #2
Featured Artist
sigg's Avatar
Join Date: Aug 2008
Posts: 1,250
Many issues are fixed with 10.0.2

About the bar states, leave the vehicle first, apply the change then enter a vehicle to see if it works.

If not, could you please send me a way to test it ?

RDX manager
  Reply With Quote
10-27-14, 05:47 PM   #3
A Theradrim Guardian
Join Date: Oct 2008
Posts: 60
Ok, I replaced all the folders, files in the Interface - Addons. But I did not replace the files in the WTF folder as I am unsure how to backup my current theme and then import it into the new files.

Flight path = Now works I can use the flight paths. However when I do I get a "[VFL] TakeTaxiNode : get data from RDX FS" displayed in my chat. It doesn't look like an error but thought I would mention in.

Vehicle Bar switching = I went and tested a vehicle and my bars switch properly now to the vehicle bar. I have not tested a possess state but I assume that would work just fine since the vehicle switches now.

Portal from Shattrath to Org = [VFL] id already existnameplatesearch is no longer displayed. <- That's a good thing.

Raid Frame = I still have the healing symbol on the default raid frame. However I did not replace the files in the WTF folder as I want to keep my theme. When I did replace the files the name of my theme was still there but was blank. So I kept my files in WTF without replacing them. We need a way to backup and then import our themes when new WTF files come out. If there is a way already it's not clear what I need to do.

Anyways, so far so good Sigg, thanks for the work, RDX is now in a usable state for me where I don't need to do any work arounds like reloadui or disable the addon to take flight paths. Much appreciated. When I find more issues I will let you know.

Edit: I was just randomly clicking buttons and found a lua error in 10.0.2_alpha. I clicked on duplicate a theme.

Interface\AddOns\RDX\DesktopMgr\DuiMenu.lua:134: attempt to index global 'DXDK' (a nil value)

Stack trace:

Last edited by MNKyDeth : 10-27-14 at 05:50 PM.
  Reply With Quote

WoWInterface » Featured Projects » OpenRDX » OpenRDX Support » OpenRDX: Bug/Error Reports » Version: 10.0.1_alpha

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off