Quantcast Minion stuck at load screen - WoWInterface
Thread Tools Display Modes
02-12-15, 08:16 PM   #1
Direbane
A Kobold Labourer
Join Date: Apr 2009
Posts: 1
Minion stuck at load screen

When I attempt to load Minion it sometimes hangs on the loading screen. Specifically when it reaches "Detecting WoW-1 Addons." Last time I let it sit there for 15 minutes and it never got beyond this point.

If I close and restart Minion it will then function as normal, sometimes.

What is WoW-1 anyway?

The requested information is below, along with the two attachments (.log, .xml):

Minion: v2.1.2-beta (Downloaded today)
OS: Windows 8.1 64bit

Screenshot:
Attached Files
File Type: log minion0.log (9.2 KB, 135 views)
File Type: xml minion.xml (6.9 KB, 147 views)
  Reply With Quote
02-12-15, 09:20 PM   #2
Dolby
PPAP
 
Dolby's Avatar
WoWInterface Admin
Join Date: Feb 2004
Posts: 2,168
Thanks for posting in such detail and especially your error log Direbane! The log has a nice exception error for us to look into and possibly solve this problem asap.

To answer your question WOW-1 is the ID that Minion assigned to your World of Warcraft install it detected. If you look in your minion.xml you'll see that id used. If Minion detected more installs of World of Warcraft you could see WOW-2, or -3... etc.

Last edited by Dolby : 02-13-15 at 08:24 AM.
  Reply With Quote
02-13-15, 08:40 AM   #3
Renwa
Premium Member
 
Renwa's Avatar
Premium Member
Join Date: Jun 2005
Posts: 6
Sticks at detecting "wow-1" addons since update. Restarting does not help
  Reply With Quote
02-13-15, 09:21 AM   #4
Dolby
PPAP
 
Dolby's Avatar
WoWInterface Admin
Join Date: Feb 2004
Posts: 2,168
I just released patch 2.1.2pl2-beta that should fix this problem. Please restart Minion again and perform the update and it should work for you now.

Sorry for the trouble.
  Reply With Quote
03-08-15, 09:53 AM   #5
Aleskan
A Kobold Labourer
Join Date: Mar 2015
Posts: 1
I too was experiencing this issue on OSX 10.10.2. I watched the system logs and this is the only thing it mentions:

3/8/15 10:41:45.000 AM kernel[0]: Sandbox: Minion(34194) System Policy: deny file-write-unlink /Users/xxxxxxx/Library/Saved Application State/com.zam.minion.savedState/restorecount.plist
3/8/15 10:42:02.000 AM kernel[0]: process Minion[34194] caught causing excessive wakeups. Observed wakeups rate (per sec): 1992; Maximum permitted wakeups rate (per sec): 150; Observation period: 300 seconds; Task lifetime number of wakeups: 45343

The only work around I have found to "fix" this is:
  1. Click the "cogs" (settings) button in the top right of the window (next to username)
  2. Click the "Reset Addon detection" button
  3. Click the "Done" button to close the settings
  4. Close the entire app by clicking the "X" button in the top right corner of the window (CMD+q causes the app to hang and then requires a manual force quit btw).

NOTE: The recent update (2.1.4-beta4) does fix this, but the above steps are required at least once to clear out whatever the previous version did and actually "fix" it.
  Reply With Quote

WoWInterface » Site Forums » Minion » Minion stuck at load screen

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off