Quantcast LUA errors seem to start after running the game for a while - WoWInterface
Thread Tools Display Modes
07-30-18, 10:31 AM   #1
Jethz
A Murloc Raider
Join Date: Sep 2017
Posts: 6
LUA errors seem to start after running the game for a while

Has anyone the same experience that LUA errors start rolling after a while of running the game?

I will catch them next time it happens and update this topic with the exact errors, but I believe it's in the skinning parts.
  Reply With Quote
08-09-18, 04:12 PM   #2
Jethz
A Murloc Raider
Join Date: Sep 2017
Posts: 6
I get loads of errors like this after running the game for a while.

Code:
x115  C stack overflow
Stack: [C] ?
[C] ?
[C] ?
[C] ?
[C] ?
[C] ?
[C] ?
[C] ?
[C] ?
[C] ?
[C] ?
[C] ?
...
[C] ?
[C] ?
[C] ?
[C] ?
[C] ?
[C] ?
[C] in function 'SetStatusBarColor'
...RealUI_Skins\Aurora\Skin\FrameXML\PVPHonorSystem.lua:16: in function <...RealUI_Skins\Aurora\Skin\FrameXML\PVPHonorSystem.lua:12>
[C] in function 'PVPHonorXPBar_Update'
[string "*:OnEvent"]:1: in function <[string "*:OnEvent"]:1>
Time: 2018/08/09 22:55:44 Index: 11/11
RealUI Version: 2.0.2
Locals:
(*temporary) = <unnamed> {
    0 = <userdata>
    GetTargetValue = <function> defined @FrameXML\AnimatedStatusBar.lua:87
    StartTilingAnimation = <function> defined @FrameXML\AnimatedStatusBar.lua:349
    Anim = <unnamed> {}
    SetupAnimationGroupForValueChange = <function> defined @FrameXML\AnimatedStatusBar.lua:233
    accumulationTimeout = 0.1
    OnAnimFinished = <function> defined @FrameXML\AnimatedStatusBar.lua:292
    matchBarValueToAnimation = false
    ProcessChangesInstantly = <function> defined @FrameXML\AnimatedStatusBar.lua:121
    accumulationTimeoutInterval = 0.1
    OnSetStatusBarAnimUpdateCallback = <function> defined @FrameXML\AnimatedStatusBar.lua:10
    OnFinishedCallback = <function> defined *:OnLoad:1
    pendingMin = 0
    GetOnAnimatedValueChangedCallback = <function> defined @FrameXML\AnimatedStatusBar.lua:47
    GetMatchLevelOnFirstWrap = <function> defined @FrameXML\AnimatedStatusBar.lua:26
    SparkBurstMove = <unnamed> {}
    matchLevelOnFirstWrap = true
    SetDeferAnimationCallback = <function> defined @FrameXML\AnimatedStatusBar.lua:43
    SetMatchLevelOnFirstWrap = <function> defined @FrameXML\AnimatedStatusBar.lua:22
    tileTemplateWidth = 37
    SetupAnimationForValueChange = <function> defined @FrameXML\AnimatedStatusBar.lua:241
    OnLoad = <function> defined @FrameXML\AnimatedStatusBar.lua:5
    GetContinuousAnimatedValue = <function> defined @FrameXML\AnimatedStatusBar.lua:99
    BarGlow = <unnamed> {}
    ReleaseAllTileTemplate = <function> defined @FrameXML\AnimatedStatusBar.lua:329
    OnValueChanged = <function> defined @FrameXML\AnimatedStatusBar.lua:286
    tileTemplate = "AnimatedStatusBarGlowLinesTemplate"
    SetAnimatedValues = <function> defined @FrameXML\AnimatedStatusBar.lua:67
    MarkDirty = <function> defined @FrameXML\AnimatedStatusBar.lua:83
    GetMatchBarValueToAnimation = <function> defined @FrameXML\AnimatedStatusBar.lua:35
    SetMatchBarValueToAnimation = <function> defined @FrameXML\AnimatedStatusBar.lua:31
    BarTrailGlow = <unnamed> {}
    OnUpdate = <function> defined @FrameXML\AnimatedStatusBar.lua:103
    GetBackdropTexture = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:314
    Spark = <unnamed> {}
    GetBackdropBorderLayer = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:309
    BarGain = <unnamed> {}
    SetBackdrop = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:91
    GetBackdropBorderColor = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:288
    GetBackdrop = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:214
    OverlayFrame = <unnamed> {}
    pendingReset = true
    AnimatedTextures = <table> {}
    GetAnimatedValue = <function> defined @FrameXML\AnimatedStatusBar.lua:95
    AcquireTileTemplate = <function> defined @FrameXML\AnimatedStatusBar.lua:314
    pendingLevel = 3
    ColorableTextures = <table> {}
    tileTemplateOverlap = 0
    Background = <unnamed> {}
    SetBackdropBorderLayer = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:294
    SetStatusBarColor = <function> defined =[C]
    _auroraBackdrop = <table> {}
    ExhaustionTick = <unnamed> {}
    tileTemplateDelay = 0.30000001192093
    ExhaustionLevelFillBar = <unnamed> {}
    SetBackdropBorderColor = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:254
    GetBackdropColor = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:248
    SetBackdropColor = <function> defined @RealUI_Skins\Aurora\Skin\api.lua:226
    pendingMax = 5500
    pendingValue = 641
    OnSetStatusBarAnimUpdate = <function> defined @FrameXML\AnimatedStatusBar.lua:274
    ProcessChanges = <function> defined @FrameXML\AnimatedStatusBar.lua:146
    SetOnAnimatedValueChangedCallback = <function> defined @FrameXML\AnimatedStatusBar.lua:39
    IsAnimating = <function> defined @FrameXML\AnimatedStatusBar.lua:117
    SetAnimatedT
  Reply With Quote
08-10-18, 08:42 AM   #3
Gethe
RealUI Developer
 
Gethe's Avatar
Premium Member
Featured
Join Date: Sep 2008
Posts: 898
What are the other errors you're getting?
__________________
Knowledge = Power; Be OP
  Reply With Quote
08-12-18, 02:05 AM   #4
Jethz
A Murloc Raider
Join Date: Sep 2017
Posts: 6
Looking at the forum, it looks like the same issue as in this thread:

http://www.wowinterface.com/forums/s...ad.php?t=56093

Does seem to happen a lot after going AFK, but also at other times. I'm sorry that I can't really pin down what causes it. I will keep trying to figure out what kicks it off.
  Reply With Quote

WoWInterface » Featured Projects » RealUI » LUA errors seem to start after running the game for a while

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off