Quantcast Extra Set of Eyes - WoWInterface
Thread Tools Display Modes
08-12-18, 02:53 PM   #1
candrid
Premium Member
 
candrid's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Aug 2008
Posts: 58
Extra Set of Eyes

Hey Friends.

I have the following lua, which is supposed to make a frame appear. It throws no error and nothing appears but I can confirm the .blp is working as I use it elsewhere. Did I miss something?

Lua Code:
  1. local addonName, addonData = ...
  2.  
  3. local Installer = CreateFrame("Frame", addonName.."_Installer", UIParent);
  4.  
  5. Installer.texture = Installer:CreateTexture(nil, "LOW");
  6. Installer.texture:SetTexture("Interface\\Addons\\PawsUI\\Art\\bg.blp");
  7. Installer.texture:SetVertexColor(0, 0, 0, 0.9);
  8.  
  9. Installer:RegisterEvent("PLAYER_ENTERING_WORLD");
  10. Installer:SetScript("OnEvent", function(self,event,...)
  11.     self:SetSize(600, 600);
  12.     self:SetPoint("CENTER");
  13. end)
Thank you for taking your time to assist me.
  Reply With Quote
08-12-18, 02:58 PM   #2
Fizzlemizz
I did that?
 
Fizzlemizz's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2011
Posts: 913
Code:
Installer.texture:SetAllPoints()
__________________
Fizzlemizz
Maintainer of Discord Unit Frames and Discord Art.
Author of FauxMazzle and Move Pad Plus.
  Reply With Quote
08-12-18, 04:27 PM   #3
candrid
Premium Member
 
candrid's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Aug 2008
Posts: 58
Originally Posted by Fizzlemizz View Post
Code:
Installer.texture:SetAllPoints()
Yay! Thank you! Now I can tinker some more.
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Extra Set of Eyes

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off