Quantcast Learning XML help! - WoWInterface
Thread Tools Display Modes
06-28-05, 01:42 PM   #1
Wing/
A Murloc Raider
Join Date: Jun 2005
Posts: 8
Learning XML help!

i wrote down this in a file ->


<Ui xmlns="http://www.blizzard.com/wow/ui/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.blizzard.com/wow/ui/
C:\Projects\WoW\Bin\Interface\FrameXML\UI.xsd">
<Script file="ReCast.lua"/>


<CheckButton name="ReCastButtonTemplate" inherits="ActionButtonTemplate" parent="ReCast" virtual="true">
<Size>
<AbsDimension x="32" y="32"/>
</Size>
<Anchors>
<Anchor point="CENTER" relativeTo="ReCastFrame" relativePoint="CENTER">
<Offset>
<AbsDimension x="0" y="0"/>
</Offset>
</Anchor>
</Anchors>
</CheckButton>
</Ui>


but the checkbutton dosent show up )= why?
(i got a Frame called ReCastFrame in a other file that includes the file were that is in ^ )
  Reply With Quote
06-28-05, 02:31 PM   #2
Beladona
A Molten Giant
 
Beladona's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2005
Posts: 539
Originally Posted by Wing/
i wrote down this in a file ->


<Ui xmlns="http://www.blizzard.com/wow/ui/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.blizzard.com/wow/ui/
C:\Projects\WoW\Bin\Interface\FrameXML\UI.xsd">
<Script file="ReCast.lua"/>


<CheckButton name="ReCastButtonTemplate" inherits="ActionButtonTemplate" parent="ReCast" virtual="true">
<Size>
<AbsDimension x="32" y="32"/>
</Size>
<Anchors>
<Anchor point="CENTER" relativeTo="ReCastFrame" relativePoint="CENTER">
<Offset>
<AbsDimension x="0" y="0"/>
</Offset>
</Anchor>
</Anchors>
</CheckButton>
</Ui>


but the checkbutton dosent show up )= why?
(i got a Frame called ReCastFrame in a other file that includes the file were that is in ^ )
You are using ReCast as your parent and then attaching it to ReCastFrame. I would try changing parent to be ReCastFrame...
  Reply With Quote
06-29-05, 11:19 AM   #3
Wing/
A Murloc Raider
Join Date: Jun 2005
Posts: 8
tnx but it didnt change any thing when i changed that.....
ok im a bit now to uimods what does parent= mean?
i just wanna put a spell place in a frame but i dont get it to work!

:Edit
well i dont know what it does but virtual="false" did make it show up
so now next problem how do i use "CheckButton" to put a spell in it i tryed to look at other codes but it dosent tell me any thing )= i just get confused

Last edited by Wing/ : 06-29-05 at 11:23 AM.
  Reply With Quote
06-29-05, 02:37 PM   #4
Beladona
A Molten Giant
 
Beladona's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2005
Posts: 539
I was gonna mention that, but the name of the frame was a template, so I assumed you were using at a template, and had another button somewhere that was inheriting it. If this is THE button you want to make appear, then yes, you need to not use virtual. Use virtual when you want that element to be a template and you plan to inherit the settings in other elements...

you can remove the virtual setting completely because it default to false when not present...
  Reply With Quote
06-29-05, 02:50 PM   #5
Wing/
A Murloc Raider
Join Date: Jun 2005
Posts: 8
tnx now i undersand a bit more of the xml of wow ^_^
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Learning XML help!

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off