Thread Tools Display Modes
Unread 04-03-09, 07:03 AM   #1
bkray1
A Deviate Faerie Dragon
Join Date: Oct 2008
Posts: 17
Windows instant messenger (WIM) v 3

I keep getting this error when i receive a chat from someone using WIM. I was wondering if anyone had wim set up with Nui that was not getting this error. Thanks for the info. I posted it on the wim forums and they suggested that it was the way the animations are handled when the window closes.

Date: 2009-04-02 19:39:53
ID: 1
Error occured in: Global
Count: 1
Message: ..\AddOns\WIM\Sources\WindowHandler.lua line 543:
attempt to perform arithmetic on a nil value
Debug:
[C]: ?
WIM\Sources\WindowHandler.lua:543:
WIM\Sources\WindowHandler.lua:523
AddOns:
Swatter, v5.4.4128 (WallabyII)
AckisRecipeList, v1.0 RC3 1516
Atlas, v1.13.0
AtlasBattlegrounds, v1.13.0
AtlasDungeonLocs, v1.13.0
AtlasOutdoorRaids, v1.13.0
AtlasTransportation, v1.13.0
AtlasLoot, vv5.03.03
AtlasLootFu, vv5.03.03
AucAdvanced, v5.4.4128 (WallabyII)
AucFilterBasic, v5.4.4128 (WallabyII)
AucFilterOutlier, v5.4.4128.2531
AucMatchUndercut, v5.4.4128.2531
AucScanData, v5.4.4128 (WallabyII)
AucStatClassic, v5.4.4128 (WallabyII)
AucStatHistogram, v5.4.4128 (WallabyII)
AucStatiLevel, v5.4.4128 (WallabyII)
AucStatPurchased, v5.4.4128 (WallabyII)
AucStatSales, v5.4.4128.2842
AucStatSimple, v5.4.4128 (WallabyII)
AucStatStdDev, v5.4.4128 (WallabyII)
AucStatWOWEcon, v5.4.4128.2530
AucUtilAHWindowControl, v5.4.4128.3311
AucUtilAppraiser, v5.4.4128.2530
AucUtilAskPrice, v5.4.4128.3175
AucUtilAutoMagic, v5.4.4128.3142
AucUtilCompactUI, v5.4.4128.2530
AucUtilEasyBuyout, v5.4.4128.3583
AucUtilItemSuggest, v5.4.4128.3108
AucUtilPriceLevel, v5.4.4128.2545
AucUtilScanButton, v5.4.4128.2530
AucUtilScanFinish, v5.4.4128.2530
AucUtilScanProgress, v5.4.4128.2530
AucUtilSearchUI, v5.4.4128.3655
AucUtilSimpleAuction, v5.4.4128.0
AucUtilVendMarkup, v5.4.4128.2530
Babylonian, v5.1.DEV.130
Bagnon, v1.6.10
BagnonForever, v1.1.1
BagnonTooltips, v
BeanCounter, v5.4.4128 (WallabyII)
Carbonite, v3.001
CarboniteTransfer, v1.01
Configator, v5.1.DEV.130
DBMCore, v
DebugLib, v5.1.DEV.130
Enchantrix, v5.4.4128 (WallabyII)
EnchantrixBarker, v5.4.4128 (WallabyII)
FishingBuddy, v0.9.6n
FuBar, v
FuBarAtlasFu, v
FuBarBagFu, vv1.1.1
FuBarDurabilityFu, v2.11
GuildLaunchProfiler, v00.09.14 BETA
Informant, v5.4.4128 (WallabyII)
LightHeaded, v277
nUI, v5.01.01
nUIInfoPanelCarbonite, v
Omen, v3.0.6
Recount, v
SlideBar, v5.4.4128 (WallabyII)
Stubby, v5.4.4128 (WallabyII)
WIM, v3.0.10
(ck=772)
bkray1 is offline  
Unread 04-03-09, 07:15 AM   #2
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
I haven't used WIM (which, by the way, is "WoW Instant Messenger" -- not Windows) with nUI, however, there are quite a few who do, this is the first time I've heard of this problem.

Are you using the latest WIM version? On the live realms or PTR?
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-03-09, 07:58 AM   #3
bkray1
A Deviate Faerie Dragon
Join Date: Oct 2008
Posts: 17
hi woops,

Yeah my brain is all over the place this morning. Yes I am using the version of wim updated april 2, but i have been having this problem for sometime. Not a huge issue, i get a whisper and then close the window and will get that popup error. Any whispers after that, i don't get an error window so no biggie, just wondered if anyone else had the same issue. The WIM forums, can't really replicate the problem either. I probably did something somewhere, but don't know what. I started over with a clean NUI pro install, ie., new wtf folder etc. so all of my old mods and whatnot were cleaned out. All of this is on the live servers. Thanks B
bkray1 is offline  
Unread 04-03-09, 08:04 AM   #4
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
OKay -- I'll look into it... I've been wanting to see if I couldn't embed WIM into my info panels anyway.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-03-09, 11:47 AM   #5
Baltharus
A Chromatic Dragonspawn
 
Baltharus's Avatar
AddOn Author - Click to view addons
Join Date: Dec 2008
Posts: 189
i am also having this ssue.. when i close a Wim window i get an error.. its not a big deal i have bug grabber so i dont have to constantly close errors >.<

as far as i can tell it doesnt impact gameplay at all.. doesnt break anything.. so i just havent posted it..
Baltharus is offline  
Unread 04-03-09, 11:58 AM   #6
beatific
Priest, Arygos
Premium Member
Join Date: Feb 2009
Posts: 10
The fix for this that I found is to disable animations in the display settings. Hopefully it's just a temporary fix but the error is gone.
beatific is offline  
Unread 04-03-09, 12:05 PM   #7
Baltharus
A Chromatic Dragonspawn
 
Baltharus's Avatar
AddOn Author - Click to view addons
Join Date: Dec 2008
Posts: 189
ahh i never thought about that ill do that then ty
Baltharus is offline  
Unread 04-03-09, 01:46 PM   #8
bkray1
A Deviate Faerie Dragon
Join Date: Oct 2008
Posts: 17
Ah thx for the info about the animations. I'll try that.
I wonder if it conflicts with nui icon animations and therefore may be fixed by /nui anim


I can't recall if i had that enabled this morning or not when I got the error, but I did apply /nui anim in an attempt to improve my framerates as best I can for my crappy laptop. Anything that helps is good. I also lowered my max aura to 10, but haven't tested out these changes yet.

Thanks for the info, hopefully its fixed then when i log in tonight.

Last edited by bkray1 : 04-03-09 at 02:07 PM.
bkray1 is offline  
Unread 04-03-09, 08:41 PM   #9
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,030
Yeah same problem here too .. so I'll do the same
Xrystal is online now  
Unread 04-04-09, 08:48 AM   #10
Seer
A Molten Giant
Join Date: Dec 2007
Posts: 649
Originally Posted by beatific View Post
The fix for this that I found is to disable animations in the display settings. Hopefully it's just a temporary fix but the error is gone.
It worked a bit better if you kept the button bag open. But disabling the animations is the best and safest option.
__________________
Take it as you want or leave it as it is.
Seer is offline  
Unread 04-04-09, 09:58 AM   #11
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Hmmm... I wonder if this has something to do with something odd WIM is doing with their bag bar button (thus keeping the button bag open keeps the button visible and prevents the bug from occurring)
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-04-09, 11:28 AM   #12
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,030
well theres an option or two in regards to the button so maybe some validating going on .. but yeah the animations have stopped the error for me as well.
Xrystal is online now  
Unread 04-04-09, 12:23 PM   #13
trezy
A Cliff Giant
Join Date: Jan 2006
Posts: 72
Ya Scott, I think its got something to do with the button bag, as it only happens for me when I have the button bag closed and then its only sometimes.
Its very strange.
trezy is offline  
Unread 04-04-09, 03:46 PM   #14
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,030
Yeah, once I turned off animations and then turned them back on I don't seem to be getting the problem since. Ive kept the button bag open, closed. Kept an inventory bag open / closed. Tried to let it automatically shift while in combat but nada. Seems to have fixed itself but will keep checking the error log to see if I spot it during another play session.
Xrystal is online now  
Unread 04-04-09, 11:04 PM   #15
SirWilliam92
An Aku'mai Servant
Join Date: Sep 2008
Posts: 24
sorry for not being able to chime in earlier..

It is exactly to do with the button bag..
when you "minimise" the WIM window, the animation is meant to show the window getting sucked into the wim button. Because the wim button is not available on screen anywhere, the animations thows an error. This is why having the button visable (and therefore, the animation can find it) or disabling the animations will stop the error.
SirWilliam92 is offline  
Unread 04-05-09, 07:48 AM   #16
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Well you guys and gals sure just made my job easier... ~lol~ At least I know exactly what I need to find and fix in WIM.

Thanks all.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-30-10, 07:04 PM   #17
Tsuroyu
A Defias Bandit
 
Tsuroyu's Avatar
Join Date: Mar 2010
Posts: 3
Is the fix for this still to disable animations in WoW? Just wondering, as I searched the forums (I may have missed it) and only found the above fix, as I still get the error.

Tsuroyu
Tsuroyu is offline  
Unread 04-30-10, 08:22 PM   #18
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
That is, to the best of my knowledge, the "fix" for WIM... though I don't use it myself.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Bug Reports » Windows instant messenger (WIM) v 3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off