Thread Tools Display Modes
Unread 04-25-10, 03:04 PM   #1
tinyu
A Molten Giant
 
tinyu's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2006
Posts: 816
new error on login

i just updated my nUI+ to 5.06.13
and i get this error on login now

Date: 2010-04-26 06:28:28
ID: -2
Error occured in: Global
Count: 1
Message: ..\AddOns\nUI\Main\nUI_Splash.lua line 112:
attempt to concatenate field 'playerName' (a nil value)
Debug:
[C]: ?
nUI\Main\nUI_Splash.lua:112:
nUI\Main\nUI_Splash.lua:96
__________________


"There's no such thing as too many addons."
Lothaer
Titan Dev Team Member.
tinyu is offline  
Unread 04-25-10, 03:06 PM   #2
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Every time? Does '/nui rl' fix it?
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-25-10, 03:20 PM   #3
tinyu
A Molten Giant
 
tinyu's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2006
Posts: 816
yeah it does but then i login on a new toon and it happens again and i have to /rl again.
__________________


"There's no such thing as too many addons."
Lothaer
Titan Dev Team Member.
tinyu is offline  
Unread 04-25-10, 03:38 PM   #4
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
8-/

Hmmm... okay... I haven't seen that yet. I'll see if I can figure out what's up there. Sounds like your own character name isn't ready when you're entering the world, which is very odd.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-25-10, 05:12 PM   #5
Deimous
A Wyrmkin Dreamwalker
Join Date: Nov 2009
Posts: 50
No error, just... weirdness

So, here's the screenshot of what I experienced after updating to nui+ .13.

Click image for larger version

Name:	WoWScrnShot_042510_175750.jpg
Views:	41
Size:	365.0 KB
ID:	4181

No error messages attached to it. Also, it only happened twice and it was on the same character (I was just testing out the old bug by swapping between characters, which, btw, it seems to be working lots better). Not sure what to make of this. I don't know how to recreate it (been trying to since it happened a second time).
Deimous is offline  
Unread 04-25-10, 05:36 PM   #6
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
That's odd indeed... do you have BugSack or Swatter installed? If not, you might try installing them and see if they trap an error.

I presume this is with the new 5.06.13 installed?
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-25-10, 05:38 PM   #7
tinyu
A Molten Giant
 
tinyu's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2006
Posts: 816
that's what my screen looked like when i got that error i reported.
__________________


"There's no such thing as too many addons."
Lothaer
Titan Dev Team Member.
tinyu is offline  
Unread 04-25-10, 05:39 PM   #8
Deimous
A Wyrmkin Dreamwalker
Join Date: Nov 2009
Posts: 50
Yep, this is with the new version. I do have swatter installed, and checked the log, but the latest error it trapped was from hours before this update went out. So, I'm kinda stumped. lol. Hasn't happened yet since.
Deimous is offline  
Unread 04-25-10, 05:46 PM   #9
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Okay -- this may be the same name error that Tinyu reported. I'll keep an eye on it and see if I can run it down.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-25-10, 07:02 PM   #10
vbalbert
A Deviate Faerie Dragon
Join Date: Apr 2009
Posts: 8
5.06.13 Still not fixed, but closer

Here's my screen when coming on after I installed the latest:
Attached Thumbnails
Click image for larger version

Name:	nUI Display Problem.jpg
Views:	439
Size:	206.9 KB
ID:	4182  
vbalbert is offline  
Unread 04-25-10, 09:01 PM   #11
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Yeah... /sigh

It appears there's a new problem now... it seems the people who have been having the login bug are having other issues how. From the look of it, their character's name isn't available when they're entering the world and nUI's trying to print the "welcome to nUI" message -- which is throwing a new error.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-25-10, 11:06 PM   #12
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,031
I haven't tried the new version yet but have tried that upgraded file Scott. It seems to have gotten rid of all but one of the errors but I had my own addon errors as well so will have to get rid of those before I know for sure. But I will also try the new version as well once Ive got the other file tested out.
__________________
Xrystal is offline  
Unread 04-26-10, 07:03 AM   #13
tinyu
A Molten Giant
 
tinyu's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2006
Posts: 816
Just updated logged in and guess what NO ERRORS WOOOOT!!!
__________________


"There's no such thing as too many addons."
Lothaer
Titan Dev Team Member.
tinyu is offline  
Unread 04-26-10, 07:07 AM   #14
Belgarius
A Fallenroot Satyr
Join Date: Mar 2010
Posts: 24
Error still present with .14

Just upgraded from .13 to .14, and am still getting the same screen on login that I had with .13

Apparently, I am too thick to figure out how to attach screenshots...

Last edited by Belgarius : 04-26-10 at 07:10 AM.
Belgarius is offline  
Unread 04-26-10, 07:31 AM   #15
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Are you sure you're upgraded? Does it print "nUI 5.06.14 is loaded" when you log in?

As far as uploading screen shots... very easy... there's a paperclip icon in the message editor here on WoWI... click that to attach a file to your message.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-26-10, 08:28 AM   #16
Belgarius
A Fallenroot Satyr
Join Date: Mar 2010
Posts: 24
Aye, I am sure it was upgraded, as I remove old addons and install new ones or updates manually. Force of habit.

Strangely enough, the error has not reappeared on any of my characters on any server since the initial time, and they all show upgraded to .14 on initial login, so I am keeping my fingers crossed here. Once the error was cleared by reloading, it did not show the splash screen on the character in question, but all seems well so far.

Checked for that paperclip, not finding it here, might be a Firefox thing. I used the Insert Image button on my prior post, and it went through the paces, but no dice. Ah, well, here's hoping!
Belgarius is offline  
Unread 04-26-10, 08:40 AM   #17
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
If you don't see the paperclip, scroll down the editor page and you'll see a "manage attachments" button that does the same thing.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-26-10, 09:06 AM   #18
Belgarius
A Fallenroot Satyr
Join Date: Mar 2010
Posts: 24
Okay, got the error again. Nothing in Swatter, and it shows being upgraded to .14 this time, the splash screen is present, which is strange, since I logged into this character about three times since it showed up the first time. I tried the manage attachments on the first error screen, that is the one that looked like it worked, but didn't attach the screenshot. Trying it again on this post.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_042610_110316.jpg
Views:	452
Size:	465.7 KB
ID:	4186  
Belgarius is offline  
Unread 04-26-10, 10:15 AM   #19
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Okay -- this is, yet another, new error... further down the chain past the Splash screen error now. The player name and all else is present in the splash screen, so the error that's occurring now is not the same one that caused issues in the last update.

Now we just have to get an error recorded so we know where the new error is being thrown.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-26-10, 05:04 PM   #20
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,031
Can confirm that with v14 it doesn't trigger an error in bugsacks eyes but it definitely looks wrong somewhere. Image 2.

However, Scott, With v12 and the extra fix file you asked me to test this is the result. Image 1.

edit: Also, after a reloadUI, I get the splash screen to appear. But I didn't get the splash screen before that. Possibly the bug is occurring before the splash screen appears.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_042610_031417.jpg
Views:	444
Size:	257.1 KB
ID:	4190  Click image for larger version

Name:	WoWScrnShot_042710_000323.jpg
Views:	436
Size:	330.9 KB
ID:	4191  
__________________
Xrystal is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Bug Reports » new error on login

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off