Thread Tools Display Modes
Unread 04-30-10, 06:19 PM   #1
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
5.06.16 Startup Error...

Yes, I got it to bug out but hey at least it gave me an error rofl. But then again, it could be linked to that infopanel of mine. So perhaps, this fix may require some infopanel changes. Fortunately this infopanel of mine isn't on the site yet so only a couple of people are using it as far as I know rofl

Code:
[2010/05/01 01:14:47-3850-x1]: nUI-5.06.16 (Plus)\Plugins\nUI_Movers.lua:458: table index is nil
...\nUI_InfoPanel_GuildInfo\nUI_InfoPanel_GuildInfo.lua:73: in function `enableGuildInfo':
...\nUI_InfoPanel_GuildInfo\nUI_InfoPanel_GuildInfo.lua:136: in function `setEnabled':
...\nUI_InfoPanel_GuildInfo\nUI_InfoPanel_GuildInfo.lua:114: in function `initPanel':
nUI-5.06.16 (Plus)\Integration\nUI_InfoPanel.lua:793: in function `applyScale'
nUI-5.06.16 (Plus)\Integration\nUI_InfoPanel.lua:908: in function `applyOptions'
nUI-5.06.16 (Plus)\Integration\nUI_InfoPanel.lua:937: in function `applySkin'
nUI-5.06.16 (Plus)\Main\nUI.lua:252: in function <Interface\AddOns\nUI\Main\nUI.lua:137>
Edit: Okay another one .. again, seemingly linked to an infopanel. Not mine this time but based on one of mine

Code:
[2010/05/01 01:24:14-3852-x1]: ...UI_InfoPanel_Profesions\nUI_InfoPanel_Profesions.lua:155: attempt to index local 'Profesions' (a nil value):
...UI_InfoPanel_Profesions\nUI_InfoPanel_Profesions.lua:62: in function `initPanel':
nUI-5.06.16 (Plus)\Integration\nUI_InfoPanel.lua:793: in function `applyScale'
nUI-5.06.16 (Plus)\Integration\nUI_InfoPanel.lua:908: in function `applyOptions'
nUI-5.06.16 (Plus)\Integration\nUI_InfoPanel.lua:937: in function `applySkin'
nUI-5.06.16 (Plus)\Main\nUI.lua:252: in function <Interface\AddOns\nUI\Main\nUI.lua:137>
Oh yeah, definitely starting to look like the infopanels will be the erroring out ones now ... slowly going throught and working them out of the system to see which ones seem to be bugging out and my guess will be that they are using VARIABLES_LOADED as we all used to use that as the starting point for all our addons.

Code:
[2010/05/01 01:26:55-3853-x1]: ...\nUI_InfoPanel_MagePorts\nUI_InfoPanel_MagePorts.lua:150: attempt to index local 'MagePorts' (a nil value):
...\nUI_InfoPanel_MagePorts\nUI_InfoPanel_MagePorts.lua:62: in function `initPanel':
nUI-5.06.16 (Plus)\Integration\nUI_InfoPanel.lua:793: in function `applyScale'
nUI-5.06.16 (Plus)\Integration\nUI_InfoPanel.lua:908: in function `applyOptions'
nUI-5.06.16 (Plus)\Integration\nUI_InfoPanel.lua:937: in function `applySkin'
nUI-5.06.16 (Plus)\Main\nUI.lua:252: in function <Interface\AddOns\nUI\Main\nUI.lua:137>
__________________

Last edited by Xrystal : 04-30-10 at 06:28 PM.
Xrystal is offline  
Unread 04-30-10, 06:26 PM   #2
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Yeah -- I'm in the process of going through all of my plugins now to make sure they're all updated to use the same ADDON_LOADED event.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 04-30-10, 06:30 PM   #3
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
Yeah. Guess I will need to do my infopanel changes sooner than later now rofl. Was hoping to get this watchframe code confirmed working with its new infopanel setup and then convert all my addons to use it

Well, so far, it seems the 3 I mentioned are the only messed up ones on my system. That could however be due to the fact that they are all standalone infopanel addons and thus have the main framework in there as well as the infopanel stuff and its the mainframe stuff that will most likely be the cause of the problem with the wrong events now.

But yaay at least now I can test my other addons to make sure they utilise the right values for positioning etc.
__________________

Last edited by Xrystal : 04-30-10 at 06:36 PM.
Xrystal is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Bug Reports » 5.06.16 Startup Error...

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off