Thread Tools Display Modes
Unread 06-22-10, 06:42 PM   #1
Msecorsky
A Murloc Raider
Join Date: Mar 2010
Posts: 4
NUI+ break in the patch?

Looks like only the buttonbars are working... everything else seems out of place. Any ideas?

Thanks!
Msecorsky is offline  
Unread 06-22-10, 06:47 PM   #2
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
Its the chatFrame changes causing a minor glitch. Assuming you have managed to get back in game I'll jump in and double check that the temp fix I did on the test server still works. If Scott hasn't already got in to work on it
__________________
Xrystal is offline  
Unread 06-22-10, 06:50 PM   #3
ikathma
A Murloc Raider
Join Date: Jul 2007
Posts: 6
Aye, got the same problem, and my limited knowledge didn't fix anything or even able to suggest anything.
ikathma is offline  
Unread 06-22-10, 06:52 PM   #4
Msecorsky
A Murloc Raider
Join Date: Mar 2010
Posts: 4
Originally Posted by Xrystal View Post
Its the chatFrame changes causing a minor glitch. Assuming you have managed to get back in game I'll jump in and double check that the temp fix I did on the test server still works. If Scott hasn't already got in to work on it
Yep, in the game now, servers are finally up. Please don't think I'm complaining... you all rock.

Out loud.
Msecorsky is offline  
Unread 06-22-10, 06:59 PM   #5
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
Originally Posted by ikathma View Post
Aye, got the same problem, and my limited knowledge didn't fix anything or even able to suggest anything.
If you spotted them in your browsing the problem is due to the fact that they added a buttonframe for the chat frame buttons.

EG.

ChatFrame1
ChatFrame1Tab
ChatFrame1ButtonFrame
ChatFrame1ButtonFrameBottomButton ( that last part from memory rofl )
__________________
Xrystal is offline  
Unread 06-22-10, 07:00 PM   #6
DraconisRavenix
A Defias Bandit
 
DraconisRavenix's Avatar
Join Date: Nov 2009
Posts: 3
Cool WTB simple quick and ugly fix (if need be)

Not sure how it is from a mod/addon author point of view but, from a user/player point of view...

UI changes royally suck.

In other words, no harsh feelings at all towards the nUI+ team but, plenty towards Blizzard . This addon is insanely awesome on so many levels.

I'll keep an eye on this thread and the nUI+ download page but, if there's a fix that can't/won't be published that a coder can quickly do, that'd be great.
__________________
Knowledge is power.
Power corrupts.
Study hard.
DraconisRavenix is offline  
Unread 06-22-10, 07:08 PM   #7
lonebigfoot
A Kobold Labourer
Join Date: May 2010
Posts: 1
Looking forward to a fix

Ever since i got nUI+ I have loved it. Its just all around a great UI. But ya changes like the chat frame in the latest patch suck for addons like this. here is a screenshot once I was able to log in.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_062210_205524.jpg
Views:	698
Size:	258.0 KB
ID:	4464  
lonebigfoot is offline  
Unread 06-22-10, 07:10 PM   #8
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
If you guys are using nUI_InfoPanel_Chat/nUI_InfoPanel_Whispers or nUI_InfoPanel_GuildChat try disabling them and see if it at least improves things somewhat.
__________________
Xrystal is offline  
Unread 06-22-10, 07:13 PM   #9
Raesoth
OmNomNom's Pet
 
Raesoth's Avatar
Premium Member
Join Date: Jan 2008
Posts: 35
NUI 5
Prat 3.0
with hitsmode and the hits mode infopanel
and toomanyaddons

Message: Interface\FrameXML\UIPanelTemplates.lua:365: attempt to perform arithmetic on field 'cursorOffset' (a nil value)
Time: 06/22/10 19:12:14
Count: 106
Stack: Interface\FrameXML\UIPanelTemplates.lua:365: in function `ScrollingEdit_OnUpdate'
Interface\FrameXML\UIPanelTemplates.lua:342: in function `ScrollingEdit_OnTextChanged'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:449: in function `ScriptErrorsFrame_Update'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:413: in function `ScriptErrorsFrame_OnError'
[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:18: in function <[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:4>
[C]: ?
Interface\FrameXML\UIPanelTemplates.lua:365: in function `ScrollingEdit_OnUpdate'
Interface\FrameXML\UIPanelTemplates.lua:342: in function `ScrollingEdit_OnTextChanged'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:449: in function `ScriptErrorsFrame_Update'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:413: in function `ScriptErrorsFrame_OnError'
[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:18: in function <[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:4>
[C]: ?
...
[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:18: in function <[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:4>
[C]: ?
Interface\FrameXML\UIPanelTemplates.lua:365: in function `ScrollingEdit_OnUpdate'
Interface\FrameXML\UIPanelTemplates.lua:342: in function `ScrollingEdit_OnTextChanged'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:449: in function `ScriptErrorsFrame_Update'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:413: in function `ScriptErrorsFrame_OnError'
[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:18: in function <[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:4>
[C]: ?
Interface\FrameXML\UIPanelTemplates.lua:365: in function `ScrollingEdit_OnUpdate'
[string "*:OnUpdate"]:1: in function <[string "*:OnUpdate"]:1>

Locals: self = ScriptErrorsFrameScrollFrameText {
0 = <userdata>
text = "Message: ...youts\Default\InfoPanels\nUI_InfoPanel_CombatLog.lua:406: attempt to index local 'bottom' (a nil value)
Time: 06/22/10 19:12:13
Count: 1
Stack: ...youts\Default\InfoPanels\nUI_InfoPanel_CombatLog.lua:406: in function `setEnabled'
...youts\Default\InfoPanels\nUI_InfoPanel_CombatLog.lua:204: in function `initPanel'
Interface\AddOns\nUI\Integration\nUI_InfoPanel.lua:793: in function `applyScale'
Interface\AddOns\nUI\Integration\nUI_InfoPanel.lua:908: in function `applyOptions'
Interface\AddOns\nUI\Integration\nUI_InfoPanel.lua:937: in function `applySkin'
Interface\AddOns\nUI\Main\nUI.lua:252: in function <Interface\AddOns\nUI\Main\nUI.lua:137>

Locals: enabled = true
bottom = nil
down = nil
up = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = <function> defined =[C]:-1
(*temporary) = 2
(*temporary) = "attempt to index local 'bottom' (a nil value)"
plugin = nUI_InfoPanel_CombatLog {
handleCursorChange = true
}
elapsed = 0
scrollFrame = ScriptErrorsFrameScrollFrame {
0 = <userdata>
offset = 0
}
height = 193.99998045976
range = 0
scroll = 0
size = 193.99998045976
cursorOffset = nil
(*temporary) = nil
(*temporary) = ScriptErrorsFrameScrollFrame {
0 = <userdata>
offset = 0
}
(*temporary) = 0
(*temporary) = "attempt to perform arithmetic on field 'cursorOffset' (a nil value)"

__________

and

__________

Message: Interface\FrameXML\UIPanelTemplates.lua:365: C stack overflow
Time: 06/22/10 19:12:14
Count: 1
Stack: Interface\FrameXML\UIPanelTemplates.lua:365: in function `ScrollingEdit_OnUpdate'
Interface\FrameXML\UIPanelTemplates.lua:342: in function `ScrollingEdit_OnTextChanged'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:449: in function `ScriptErrorsFrame_Update'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:413: in function `ScriptErrorsFrame_OnError'
[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:18: in function <[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:4>
[C]: ?
Interface\FrameXML\UIPanelTemplates.lua:365: in function `ScrollingEdit_OnUpdate'
Interface\FrameXML\UIPanelTemplates.lua:342: in function `ScrollingEdit_OnTextChanged'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:449: in function `ScriptErrorsFrame_Update'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:413: in function `ScriptErrorsFrame_OnError'
[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:18: in function <[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:4>
[C]: ?
...
[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:18: in function <[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:4>
[C]: ?
Interface\FrameXML\UIPanelTemplates.lua:365: in function `ScrollingEdit_OnUpdate'
Interface\FrameXML\UIPanelTemplates.lua:342: in function `ScrollingEdit_OnTextChanged'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:449: in function `ScriptErrorsFrame_Update'
...e\AddOns\Blizzard_DebugTools\Blizzard_DebugTools.lua:413: in function `ScriptErrorsFrame_OnError'
[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:18: in function <[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:4>
[C]: ?
Interface\FrameXML\UIPanelTemplates.lua:365: in function `ScrollingEdit_OnUpdate'
[string "*:OnUpdate"]:1: in function <[string "*:OnUpdate"]:1>

Locals: self = ScriptErrorsFrameScrollFrameText {
0 = <userdata>
text = "Message: ...youts\Default\InfoPanels\nUI_InfoPanel_CombatLog.lua:406: attempt to index local 'bottom' (a nil value)
Time: 06/22/10 19:12:13
Count: 1
Stack: ...youts\Default\InfoPanels\nUI_InfoPanel_CombatLog.lua:406: in function `setEnabled'
...youts\Default\InfoPanels\nUI_InfoPanel_CombatLog.lua:204: in function `initPanel'
Interface\AddOns\nUI\Integration\nUI_InfoPanel.lua:793: in function `applyScale'
Interface\AddOns\nUI\Integration\nUI_InfoPanel.lua:908: in function `applyOptions'
Interface\AddOns\nUI\Integration\nUI_InfoPanel.lua:937: in function `applySkin'
Interface\AddOns\nUI\Main\nUI.lua:252: in function <Interface\AddOns\nUI\Main\nUI.lua:137>

Locals: enabled = true
bottom = nil
down = nil
up = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = <function> defined =[C]:-1
(*temporary) = 2
(*temporary) = "attempt to index local 'bottom' (a nil value)"
plugin = nUI_InfoPanel_CombatLog {
handleCursorChange = true
}
elapsed = 0
scrollFrame = ScriptErrorsFrameScrollFrame {
0 = <userdata>
offset = 0
}
height = 193.99998045976
range = 0
scroll = 0
size = 193.99998045976
cursorOffset = nil
(*temporary) = nil
(*temporary) = ScriptErrorsFrameScrollFrame {
0 = <userdata>
offset = 0
}
(*temporary) = 0
(*temporary) = "attempt to perform arithmetic on field 'cursorOffset' (a nil value)"
(*temporary) = <function> defined =[C]:-1
(*temporary) = "Interface\FrameXML\UIPanelTemplates.lua:365: attempt to perform arithmetic on field 'cursorOffset' (a nil value)"
(*temporary) = "C stack overflow"


Have 12 other similar errors if you want em, not doing much else sitting on an alien server with my level 1 toon all alone and exposed ... I miss my server already
__________________


Last edited by Raesoth : 06-22-10 at 07:18 PM.
Raesoth is offline  
Unread 06-22-10, 07:15 PM   #10
DraconisRavenix
A Defias Bandit
 
DraconisRavenix's Avatar
Join Date: Nov 2009
Posts: 3
Wink Dunno if this helps...

Originally Posted by Xrystal View Post
If you guys are using nUI_InfoPanel_Chat/nUI_InfoPanel_Whispers or nUI_InfoPanel_GuildChat try disabling them and see if it at least improves things somewhat.
I don't use any of those and my screen looks almost exactly as 'lonebigfoot' above.
__________________
Knowledge is power.
Power corrupts.
Study hard.
DraconisRavenix is offline  
Unread 06-22-10, 07:22 PM   #11
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
Okay, got it reasonably working with just nUI5 with the following changes and the screenshot below is the result.

If you try and manually move the chatframe it won't let you fill up the whole area nUI assigns to the chatframe. I believe this is due to how the new frames are built which I haven't managed to figure out yet myself.

But here are the changes I made to make it work for those industrialists out there

In nUI\Layouts\Default\InfoPanels\nUI_InfoPanel_CombatLog.lua

Lines : around 250 and 405

Change these lines in both areas :
--local bottom = _G["ChatFrame2BottomButton"];
--local down = _G["ChatFrame2DownButton"];
--local up = _G["ChatFrame2UpButton"];
To
local bottom = _G["ChatFrame2ButtonFrameBottomButton"];
local down = _G["ChatFrame2ButtonFrameDownButton"];
local up = _G["ChatFrame2ButtonFrameUpButton"];

This will fix the problem on the right hand side

In nUI\Integration\nUI_ChatFrame.lua
Lines : around 180

Change these lines
--local bottom = _G["ChatFrame"..i.."BottomButton"];
--local down = _G["ChatFrame"..i.."DownButton"];
--local up = _G["ChatFrame"..i.."UpButton"];
To these lines
local bottom = _G["ChatFrame"..i.."ButtonFrameBottomButton"];
local down = _G["ChatFrame"..i.."ButtonFrameDownButton"];
local up = _G["ChatFrame"..i.."ButtonFrameUpButton"];

This will fix the left hand side, somewhat

Until we figure out how to play with their new code it may be all we have until Scott can tweak the code more.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_062310_021544.jpg
Views:	682
Size:	244.9 KB
ID:	4466  
__________________
Xrystal is offline  
Unread 06-22-10, 07:24 PM   #12
ncash.navy
A Kobold Labourer
Join Date: Nov 2009
Posts: 1
Exact same screen here. I also do not use any of the addons mentioned.
ncash.navy is offline  
Unread 06-22-10, 07:27 PM   #13
Tegarbah
A Wyrmkin Dreamwalker
 
Tegarbah's Avatar
Join Date: Jun 2008
Posts: 58
Same here as well. Screenshot attached.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_062210_192414.jpg
Views:	601
Size:	434.8 KB
ID:	4467  
__________________



Tegarbah is offline  
Unread 06-22-10, 07:29 PM   #14
Raesoth
OmNomNom's Pet
 
Raesoth's Avatar
Premium Member
Join Date: Jan 2008
Posts: 35
Guess its time to get my hands dirty and mess with the code

Wish I could get over this mental block that lua isn't that hard . uh-huh ..

Let ya know how things go...

And Nope ... getting better but my left side is still broke but down to 1 error now

Message: Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:358: attempt to index local 'bottom' (a nil value)
Time: 06/22/10 19:39:49
Count: 1
Stack: Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:358: in function `applyScale'
Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:496: in function `applyOptions'
Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:600: in function `configFrame'
Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:126: in function <Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:112>

Locals: scale = 1
options = <table> {
strata = "BACKGROUND"
btn_size = 45
scale = 1
width = 585
fontsize = 11
height = 290
level = 3
btn_gap = -8
background = <table> {
}
}
anchor = nil
scale = 1
width = 438.75002261537
height = 206.62501994545
fontsize = 7.8375007565517
btn_hSize = 33.750001739644
btn_vSize = 32.062503094984
(for index) = 1
(for limit) = 10
(for step) = 1
i = 1
bottom = nil
down = nil
up = nil
(*temporary) = "ChatFrame1UpButton"
(*temporary) = nil
(*temporary) = "UpButton"
(*temporary) = 149.99999648557
(*temporary) = 1
(*temporary) = 0
(*temporary) = 1
(*temporary) = nil
(*temporary) = "attempt to index local 'bottom' (a nil value)"
frame = nUI_ChatFrame {
applyOptions = <function> defined @Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:460
options = <table> {
}
0 = <userdata>
scale = 1
width = 438.75002261537
configFrame = <function> defined @Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:504
applyScale = <function> defined @Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:287
height = 206.62501994545
btn_vSize = 32.062503094984
btn_hSize = 33.750001739644
applyAnchor = <function> defined @Interface\AddOns\nUI\Integration\nUI_ChatFrame.lua:421
__________________


Last edited by Raesoth : 06-22-10 at 07:41 PM.
Raesoth is offline  
Unread 06-22-10, 07:32 PM   #15
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
Okay, tested again with the usual suspects of Omen/Recount/Skada along with my own infopanels SmartDebuff/PallyPower/Decursive/DecursiveOmen. As you can see from this screenshot the combat log is similarly misaligned due to that extra mini frame that simply refuses to do as its told. You can faintly see the top part of it on the top left hand corner just outside the infopanel box.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_062310_023034.jpg
Views:	615
Size:	257.6 KB
ID:	4468  
__________________
Xrystal is offline  
Unread 06-22-10, 07:33 PM   #16
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
I am working on the patch... will have an update out shortly.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 06-22-10, 07:34 PM   #17
Ytek
A Kobold Labourer
Join Date: Jun 2010
Posts: 1
nui5

So if you have nui+ you need to downgrade it to nui5 and then make the changes listed? Just want to make sure I don't mess something up
Ytek is offline  
Unread 06-22-10, 07:35 PM   #18
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
YOu do not have to downgrade to make the fix.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 06-22-10, 07:38 PM   #19
Eddiedean
A Defias Bandit
Join Date: Jul 2009
Posts: 2
Originally Posted by spiel2001 View Post
I am working on the patch... will have an update out shortly.
Scott, we love you man!

Thanks for all the hard work and dedication!!
Eddiedean is offline  
Unread 06-22-10, 07:38 PM   #20
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
Now the big baby Prat with nUI. I suspect this is what is causing a big booboo as Prat being a chatframe addon will be highly possible to contain problems due to the patch.

Nope, apart from a few Prat error messages I couldn't see anything untoward happening but for the moment I think I'll forgo on Prat while we work this out personally.


Oops, missed some more changes in the ChatFrame.lua file.

Lines: around 360 and 400

Same Code Blocks Change the lines looking like the first 3 to the last 3

--local bottom = _G["ChatFrame"..i.."BottomButton"];
--local down = _G["ChatFrame"..i.."DownButton"];
--local up = _G["ChatFrame"..i.."UpButton"];

local bottom = _G["ChatFrame"..i.."ButtonFrameBottomButton"];
local down = _G["ChatFrame"..i.."ButtonFrameDownButton"];
local up = _G["ChatFrame"..i.."ButtonFrameUpButton"];
__________________
Xrystal is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Bug Reports » NUI+ break in the patch?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off