Reply
 
Thread Tools Display Modes
Old 10-10-10, 08:48 AM   #1
drakull
A Cyclonian
 
drakull's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2008
Posts: 49
Thumbs up Raid frames not showing on PTR.

Well, I'm working in the cataclysm version of my layout, using oUF 1.4.3 from the github and testing it on the PTR.

I noted that my party and raid frames are not working (I use the same code for both). I don't get any errors but they just don't show up. They do work fine in the live version.

Has something changed in the way we implement raid frames?

Here's my code:
Code:
local function CreateRaidStyle(self, unit)
    self.width = 72
    self.height = 28
    self.scale = cfg.raidscale
    self.mystyle = "raid"
    self.Range = {
        insideAlpha = 1,
        outsideAlpha = .3,
    }
    genStyle(self)
    self.Health.frequentUpdates = true
    self.Health.colorSmooth = true
    self.Health.bg.multiplier = 0.3
    self.Power.colorClass = true
    self.Power.bg.multiplier = 0.5
end

if cfg.ShowRaid or cfg.RaidShowSolo or cfg.ShowParty then
    oUF:RegisterStyle("oUF_DrkRaid", CreateRaidStyle)
    oUF:SetActiveStyle("oUF_DrkRaid")
	
	local maxGroups = 5
	if cfg.RaidShowAllGroups then maxGroups = 8 end
	local visible = ''
	if cfg.RaidShowSolo then
		visible = 'solo'
	end
	if cfg.ShowParty then
		if visible == '' then
			visible = 'party'
		else
			visible = visible..',party'
		end
	end
	if cfg.ShowRaid then
		if visible == '' then
			visible = 'raid'
		else
			visible = visible..',raid'
		end
	end
	raid = {} 
	for i = 1, maxGroups do 
		local group = oUF:SpawnHeader('oUF_DrkRaid'..i, nil, visible, 
			'showPlayer', true, 
			'showSolo', cfg.RaidShowSolo, 
			'showParty', cfg.ShowParty, 
			'showRaid', cfg.ShowRaid, 
			'xoffset', 9, 
			'yOffset', 5, 
			'point', "LEFT", 
			'groupFilter', tostring(i), 
			'groupingOrder', '1,2,3,4,5,6,7,8', 
			'groupBy', 'GROUP', 
			'maxColumns', 8, 
			'unitsPerColumn', 5, 
			'columnSpacing', 7, 
			'columnAnchorPoint', "UP") 
		if i == 1 then 
			group:SetPoint(RaidPos[1], RaidPos[2], RaidPos[3], RaidPos[4], RaidPos[5]) 
		else 
			group:SetPoint("TOPLEFT", raid[i-1], "TOPLEFT", 0, 35) 
		end 
		raid[i] = group 
	end  	
end
cfg.ShowRaid, cfg.RaidShowSolo and cfg.ShowParty values are set to true.

Last edited by drakull : 10-10-10 at 08:50 AM.
drakull is offline   Reply With Quote
Old 10-10-10, 08:59 AM   #2
haste
Featured Artist
 
haste's Avatar
Premium Member
Featured
Join Date: Dec 2005
Posts: 978
1.4.x won't work due to changes in now secure group headers work. On top of that I haven't fully decided how I want oUF to interact with them yet.

They do work on beta with the git version of oUF, but only if you know what you are doing .
__________________
「貴方は1人じゃないよ」
haste is offline   Reply With Quote
Old 10-11-10, 08:20 AM   #3
senomar
A Defias Bandit
AddOn Author - Click to view addons
Join Date: Jul 2008
Posts: 3
Originally Posted by haste View Post
1.4.x won't work due to changes in now secure group headers work. On top of that I haven't fully decided how I want oUF to interact with them yet.

They do work on beta with the git version of oUF, but only if you know what you are doing .
so, you are not targeting for a 4.0.1 release?
senomar is offline   Reply With Quote
Reply

Go BackWoWInterface » Featured Projects » oUF (Otravi Unit Frames) » Raid frames not showing on PTR.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off