Thread Tools Display Modes
Unread 03-07-11, 07:47 AM   #1
Protocol82
A Murloc Raider
 
Protocol82's Avatar
Join Date: Feb 2008
Posts: 7
Remove carbonite minimap

Hi peeps.

Ill explain how I use carbonite. I hit M for the big map and M again for it to shrink. But while shrunk it also has a minimap inside it. If I turn this feature off, none of the mining nodes appear, like when you are near a node and it flashes on the map. If I turn it on all the notes and quests markers dont match the normal carbonite map. Can I remove/disable the carbonite minimap but still keep the mining nodes?

I've tried making the minimap scale 0, but still it seems to be there. I just want it gone. Any ideas?
Protocol82 is offline  
Unread 03-07-11, 10:06 AM   #2
Jigain
A Molten Giant
 
Jigain's Avatar
Join Date: Jul 2009
Posts: 733
In the options, you can uncheck the option to merge the minimap with the Carbonite map. This places the Blizzard minimap back in the top right (unless otherwise modified by other addons), containing the usual node information and whatnot.

Then you can (also in the Carb options) check the option to hide the Carbonite map when M is pressed. This causes Carb to, instead of switching between two sizes and positions when M is pressed, toggle between one size and position or close the Carb map, making it more like the default world map (which toggles open and closed).

These two together should accomplish what I think you're asking for.
__________________


Jigain is offline  
Unread 03-07-11, 10:26 AM   #3
Protocol82
A Murloc Raider
 
Protocol82's Avatar
Join Date: Feb 2008
Posts: 7
Many thanks for reply. I don't think I can have my cake and eat it. While the normal minimap using your method returns to normal, I still would like the carbonite waypoints, quest areas etc to appear. But this can only be acheived when I merge maps. I just wish I could merge maps, but remove the minimap entirely, i dont need it. And wish the carbonite main map, both is max and min sizes, showed the mining nodes when I disable carbonite minimap.
Protocol82 is offline  
Unread 03-07-11, 11:08 AM   #4
jeffy162
Premium Member
 
jeffy162's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: May 2009
Posts: 1,839
Originally Posted by Protocol82 View Post
Hi peeps.

Ill explain how I use carbonite. I hit M for the big map and M again for it to shrink. But while shrunk it also has a minimap inside it. If I turn this feature off, none of the mining nodes appear, like when you are near a node and it flashes on the map. If I turn it on all the notes and quests markers dont match the normal carbonite map. Can I remove/disable the carbonite minimap but still keep the mining nodes?

I've tried making the minimap scale 0, but still it seems to be there. I just want it gone. Any ideas?
First things first: There is only one Carbonite map. It is either large (maximized), or small (minimized). The minimap is the default Blizzard map you always see in the upper right corner of you screen.

That being said: Unfortunately, if you don't have the Carbonite minimized map and the Blizzard minimap merged, you won't be seeing any active (currently able to be harvested) nodes, blinking or not, on your Carbonite minimized map. The reason for that is Blizzard has not released the API for that action for addon developers to be able to do things like that with their own maps.

One of the problems with merging the maps is that Blizzard and Carbonite use different amounts of zoom. IE: Blizzards minimap has 6 fixed zoom levels, whereas Carbonites map is able to zoom "infinitely". That sometimes causes problems with things lining up between the two maps. If you have that happen, you can hold the "ctrl" key to bring the Blizzard minimap to the top so you can find your node.

If you don't want to have the maps merged, open Carbonites options (type "/carb options" in chat, right click the Carbonite minimap button and choose "Options" in the menu, right click a non-icon area of any Carbonite map and choose "Options" in the menu) to the "Map Minimap" page and uncheck the first option, which is "Move Minimap into Carbonite map (reload required)". Since you seem to want to not see the Carbonite minimized map any more, after you uncheck that option go to the "Map" page and check the option to "Hide maximized map when ESC or map toggle (M) key pressed". That will hide the minimized map when using the "M" key instead in minimizing the map. If you choose to do this, though, unmerge the maps first or you won't have a minimap at all. If you don't want to use Carbonites maximized map either, just uncheck the first option on the "Map" page "Maximize Carbonite map instead of opening normal map".

If you chose to not use the Carbonite map, you can install something like GatherMate2 along with its GM2 Database to show the nodes on the Blizzard maps.

I would ask that you look in the main Carbonite folder in your "AddOns" folder and find the "CarboniteReadMe" plain text file. Please read through it. It will explain a lot about how to set Carbonite up and how the different parts of Carbonite work. Unfortunately, it's one of Carbonites best kept secrets.


EDIT: DOH!!! This is what happens when I try to be precise (concise?) about answering sometimes. I actually started this post over an hour ago, but between flipping back and forth between windows (WoWI and WoW) to make sure I had the right info (Ahhhh, the vagueries of an aging mind) and (unfortunately I'm easily distracted) doing something on one of my characters ... well ... you can see the results. 8^) /EDIT

Last edited by jeffy162 : 03-07-11 at 11:20 AM.
jeffy162 is offline  
Unread 03-07-11, 11:33 AM   #5
Protocol82
A Murloc Raider
 
Protocol82's Avatar
Join Date: Feb 2008
Posts: 7
Many thanks for that answer.
As you can see by the attached, things are going ok. I will just have the put up with the issue as its not a major one at all. Again, thanks for the concise answer, much appreciated.
Protocol82 is offline  
Unread 03-07-11, 05:47 PM   #6
jeffy162
Premium Member
 
jeffy162's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: May 2009
Posts: 1,839
WOW! Nice UI.

OH, and, you're welcome. I'm glad I could help.
jeffy162 is offline  
Unread 06-27-11, 03:16 PM   #7
lilocowboy
A Murloc Raider
Join Date: Feb 2010
Posts: 4
I have to ask. What UI are you using? That looks totally cool. Thanks!
lilocowboy is offline  
Unread 07-06-11, 05:59 PM   #8
link07
A Murloc Raider
Join Date: Jun 2011
Posts: 6
if the original poster would happen to look at this thread again, I would also love to know what UI that is
link07 is offline  
Unread 07-15-11, 09:27 AM   #9
iamagamer
A Kobold Labourer
Join Date: Mar 2011
Posts: 1
Wink Hi

Hello, I seem to have the same problem as stated above. Since the UI looks similar, I think it is a compatability issue. The UI looks like the one I am using (ElvUI). Good stuff, but really troublesome with the map. What I did was to arrange the default minimap in the place of choice and then align the carb minimap on top of it. seems to work for me. hope this helps.

also including my UI screenshot.

http://www.megapix.com/?p=ANZ4RNY4&e...1NIHP&expind=0

c ya guys
Rj

Last edited by iamagamer : 07-15-11 at 09:30 AM.
iamagamer is offline  
Unread 07-18-11, 02:50 AM   #10
Yuriko
A Murloc Raider
 
Yuriko's Avatar
Join Date: Dec 2007
Posts: 4
Originally Posted by jeffy162 View Post
If you don't want to have the maps merged, open Carbonites options (type "/carb options" in chat, right click the Carbonite minimap button and choose "Options" in the menu, right click a non-icon area of any Carbonite map and choose "Options" in the menu) to the "Map Minimap" page and uncheck the first option, which is "Move Minimap into Carbonite map (reload required)". Since you seem to want to not see the Carbonite minimized map any more, after you uncheck that option go to the "Map" page and check the option to "Hide maximized map when ESC or map toggle (M) key pressed". That will hide the minimized map when using the "M" key instead in minimizing the map.

After updating, I've somehow lost every single profile for Carbonite's settings. I've done the above about 20 times now, completely resetting it all between attempts. No matter what I do, my Carbonite map toggles between two sizes, either minimized then maximized, or in the reverse. I can't get it to just stay opened or closed no matter what I do.


Ideas?
__________________
"...but you and I, we've been through that, and this is not our fate. So let us not talk falsely now. The hour's getting late."
Yuriko is offline  
Unread 07-18-11, 08:14 AM   #11
Chmee
A Molten Giant
Join Date: Dec 2006
Posts: 960
There is, if I'm not mistaken, an option to hide the map instead of minimizing it. So hitting M (if that's your keybind) toggles between the map open full size, and the map closed (not minimized, but completely gone).
Chmee is offline  
Unread 07-18-11, 10:16 AM   #12
jeffy162
Premium Member
 
jeffy162's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: May 2009
Posts: 1,839
Originally Posted by Yuriko View Post

After updating, I've somehow lost every single profile for Carbonite's settings. I've done the above about 20 times now, completely resetting it all between attempts. No matter what I do, my Carbonite map toggles between two sizes, either minimized then maximized, or in the reverse. I can't get it to just stay opened or closed no matter what I do.


Ideas?
How -exactly- did you update your Carbonite installation?

What -exactly- are you looking to do with the Carbonite map?
__________________
Ahhhh, the vagueries of the aging mind. Wait.... What was I saying?

jeffy162 is offline  
Unread 07-19-11, 02:24 AM   #13
Yuriko
A Murloc Raider
 
Yuriko's Avatar
Join Date: Dec 2007
Posts: 4
Originally Posted by jeffy162 View Post
How -exactly- did you update your Carbonite installation?

What -exactly- are you looking to do with the Carbonite map?
Actually, thank you very much for looking in on this thread again, but it's no longer an issue.
When I got home tonight, I decided to completely delete all of my UI and start over from scratch. This served the double purpose of making sure I had a fresh, clean install of Carbonite, as well as giving me the opportunity to completely remake my interface.

Since the clean install worked right on the first try, I must assume that the update (which was done through the Curse Client) must have been flawed or corrupt, and that some part of it was still present after a delete and reinstall of Carbonite.

When it doubt, burn it all to the ground..!



__________________
"...but you and I, we've been through that, and this is not our fate. So let us not talk falsely now. The hour's getting late."

Last edited by Yuriko : 07-19-11 at 02:46 AM. Reason: Took more drastic measures
Yuriko is offline  
Unread 07-19-11, 09:40 AM   #14
jeffy162
Premium Member
 
jeffy162's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: May 2009
Posts: 1,839
Well, I don't think I'd go quite that far, but I'm glad to hear you have your problem solved.
__________________
Ahhhh, the vagueries of the aging mind. Wait.... What was I saying?

jeffy162 is offline  
 

Go BackWoWInterface » Featured Projects » Carbonite » Carbonite Archive » Remove carbonite minimap

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off