Thread Tools Display Modes
Old 01-11-12, 05:50 PM   #1
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Viewport bug

Tom --

I'm going to post several here as I confirm them along with the details I can get from the users. When you're sick of me posting them, let me know and I'll stop ~grin~

Simple code snippet to set a fair approximation the viewport being shown...

(pardon me if I do something stupid... not at my computer and doing this off the top of my head)

Code:
local height = UIParent:GetTop() - UIParent:GetBottom();
local width  = UIParent:GetRight() - UIParent:GetLeft();
local frame = CreateFrame( "Frame", "testFrame", UIParent );

frame:SetHeight( 512 * height / 768 );
frame:SetWidth( width );
frame:SetPoint( "BOTTOMLEFT", UIParent, "BOTTOMLEFT", 0, 0 );
frame:SetPoint( "BOTTOMRIGHT", UIParent, "BOTTOMRIGHT", 0, 0 );

WorldFrame:SetPoint( "BOTTOM", frame, "CENTER", 0, 0 );
.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/

Last edited by spiel2001 : 01-11-12 at 05:59 PM.
spiel2001 is offline  
Old 01-11-12, 05:52 PM   #2
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Running custom rig from iBUYPOWER, Windows 7 Home Premium 64-bit, AMD Phenom II X6 1090T processor at 3.20 GHz, 8 GB ram, ATI Radeon HD 5700 series vidcard, DX11.


Uther, Horde, Uldum, above Vir'naal Oasis. Happens anytime the lake there is in my field of view, regardless if I can see it or not. If I move the camera so it's facing somewhere other than that area, it's perfectly fine.

(note the black bar at the bottom of this screen shot -- that's the viewport. The bottom of the world frame is the top of the black bar, so there should be *no* 3D elements appearing below the top edge of that black bar -- however, you'll see several 3D elements well below the bottom of the world frame)
.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_011112_172420.jpg
Views:	343
Size:	1.72 MB
ID:	6706  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/

Last edited by spiel2001 : 01-11-12 at 06:07 PM.
spiel2001 is offline  
Old 01-11-12, 06:05 PM   #3
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Here's another one but without a screen shot -- but it's at least semi-descriptive and matches up with the other examples I have.

Unfortunately, I removed your addon because it was making it impossible to play in Throne of TIdes. The whole instance had mis-aligned graphic layers. All ground effects and target circles were not visible as they were being rendered under the ground level. I died many times due to this alone. Also, in a few groups one character was half underground, where the character next to them (both part of my party) was positioned correctly, but their nametag and raid marker were being rendered in the middle of their body. Very Odd.

I miss this addon greatly. I am a supporter and hope it gets fixed soon.

__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-11-12, 06:06 PM   #4
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Another lacking the detail or screen shots I asked for, but does give location, etc.

I can reproduce this problem in Uldum. Currently I'm seeing it happen at 61.1, 30.0 while facing SW. It does appear to be directionally linked. If I change my direction (whether it's the camera or the character's direction) it changes. I've seen it happen on my Tyrael's Charger or Celestial Steed and it's the mount that it happens to, not my character. It seems that it's happening on the east end of Ramakhen as well, at 55.5, 34.3.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-11-12, 06:32 PM   #5
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Here's another (wish they would provide screen shots as I asked /sigh)

PC: Home build
Windows 7
Nvidia GTX 260 ( I think)
Alliance
Vir' Naal, Uldum 59.7- 34.3
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-11-12, 06:38 PM   #6
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Here's one with more detail and some screen shots...

Dell Vostro 220 w/EVGA GTX 460

Alliance Priest

Dungeon: Throne of the Tides

As you can see in the attached images, with viewport enabled, my weapon enchant displays below ground. When viewport is disabled, everything shows correctly. If I still has my shadow spec, I would show you how bad it really is.

However, when in shadow spec, I could only see the top of my priest's head. On the elevator, it was like my shadow was standing on my shoulders while is was underground. Everyone else in the group also displayed above me. This happened throughout the dungeon.

So, if you're looking for a zone for testing, Throne of the Tides is the one.
(first shot is with viewport disabled, second with it enabled -- note missing enchant emitters with the viewport turned on -- the shoulder emitter is just barely visible in the ground)

.
Attached Thumbnails
Click image for larger version

Name:	Viewport Disabled.jpg
Views:	341
Size:	116.6 KB
ID:	6707  Click image for larger version

Name:	Viewport Enabled.jpg
Views:	343
Size:	135.0 KB
ID:	6708  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-11-12, 06:58 PM   #7
TSquared
Big Daddy!
Join Date: May 2008
Posts: 504
Disregard that last statement. He saw the thread on my machine & is looking into it.


Thanks Scott,

Could you copy this to a thread in your public forum? I need to give this info to the engine programmers, and they don't have access
to the strike team forum.

Last edited by TSquared : 01-12-12 at 10:04 AM.
TSquared is offline  
Old 01-12-12, 03:05 PM   #8
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
I have plenty more data if needed -- he can e-mail me at kscottpiel@nUIaddon.com if need be.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 06:55 AM   #9
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
@Cairenn -- can you copy this thread out to my support forum so the guys from the engine team can see it?

@TSquared -- I have a bunch more responses to my inquiry, so I'm adding their detail here if only to fill out more data in the event it helps the engine team run this down... disregard otherwise ~smile~
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 06:58 AM   #10
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Here again in Uldum... it appears that pretty much all of the reports I am getting are coming out of either Uldum or Throne of Tides.

I noticed the lack of water a few weeks ago, and chalked it up to the fact that my computer's old, relogged, and went along my merry way.
This area in Uldum is the only place I've noticed the bug, and since I don't herb very often, it really didn't make that lasting an impression on me until I received your email.
I've included a "before" and "after" of the lake near Ramkahen (191148 and 191156) for perspective, although that was most likely unnecesary. This bug appears only while travelling south along the river, never whil. travelling north.
I'm using XP on an HP with an ATI Radeon HD 4800. Hope this info helps.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_011112_191031.jpg
Views:	318
Size:	300.9 KB
ID:	6712  Click image for larger version

Name:	WoWScrnShot_011112_191148.jpg
Views:	317
Size:	202.1 KB
ID:	6713  Click image for larger version

Name:	WoWScrnShot_011112_191156.jpg
Views:	313
Size:	248.4 KB
ID:	6714  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:01 AM   #11
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Another one from Uldum...

Thanks!!

I've wondered what the 'viewport' problem was, and didn't even know I had it. I've also wondered how to get rid of that black bar at the bottom of my screencaps.. =)

I know there are other reliable places, but I don't go them as often as this one, so it's the only one I knew off the top of my head as soon as I read your email.

I have no screenshots before 6/11 that have the black bar and all my screenshots afterward 11/11 do. I took no screenshots to judge by between 6/11 and 11/11. I suspect some upgrade of nUI just turned 'viewport' back on for me, or I turned it on without knowing. I mention all this to say that I'm fairly sure, but not absolutely positive, that I had the viewport problem at this same location with the both my old and my new video cards in the desktop, both listed below. I put the new vidcard in the desktop 8/11. I didn't get the laptop until 10/11.

I mention both Power Supplies below as well, and I *know* I had the problem with both. Of course, I doubt they have anything to do with it, but you did ask for everything. =)

If I find other reliable places outside Uldum, I will send that info along as well, unless you tell me you don't want it.

Marty
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_011112_184417.jpg
Views:	317
Size:	408.9 KB
ID:	6715  Click image for larger version

Name:	WoWScrnShot_011112_184426.jpg
Views:	306
Size:	496.5 KB
ID:	6716  Click image for larger version

Name:	WoWScrnShot_011112_202044.jpg
Views:	307
Size:	389.4 KB
ID:	6717  Click image for larger version

Name:	WoWScrnShot_011112_202052.jpg
Views:	309
Size:	333.1 KB
ID:	6718  

__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:02 AM   #12
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Uldum again...

Hey there Scott.
I've actually noticed this bug for quite a while, so I'm glad you've asked for it!
I have attached two screenshots of me while in Uldum. As you can tell, the angle is important to when this bug occurs. My character (a level 83/4 orcish warrior at the time) does not move between these screenshots, only keyboard turning occurs. This has happened on all of my characters while in the Uldum zone. It always occurs while around the dam, and I have just done testing to prove that it only happens while facing the dam. In fact, I have narrowed it to Precisely the point where the enterences (both of them) Into the dam come on screen. The moment either of the enterences enter the screen, it bugs as shown in the screenshots.

I don't have a screen shot of it, but I also recall it happening within the Throne of the Tides a lot (almost the entire instance, except a small part at the start from memory). I'll see if I can grab a screenie of it sometime.

This bug existed on my old system, which has none of the same parts as my new one. My old system ran Windows 7 32bit, with an nvidia gtx260, Q6600 intel processor and four gigs of ram. These screenshots were taken on that old system. My new system which repeats the same effect is Windows 7 64bit, Nvidia gtx570, i5 2500K processor and sixteen gigs of ram. I have always run WoW Windowed (Full Screen). I used DX9 on the old card and DX11 on the new one.

I think that is everything that I could tell you, but let me know if there is anything else you want to know! The Sparklepony is an excellent method to test with since it has so many particles that jump with the effect.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_050511_213303.jpg
Views:	308
Size:	190.9 KB
ID:	6719  Click image for larger version

Name:	WoWScrnShot_050511_213305.jpg
Views:	308
Size:	184.9 KB
ID:	6720  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:05 AM   #13
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Uldum again... (this area appears to be to be completely unrelated to hardware)

I am using the nUI_Art_InvisibleMan, so I can see the dark bar at the bottom when the viewport is on without dropping the interface. One picture is with the viewport on and one with it off. Both are from the same positions. I am up in the air but it is the same if I am on the ground or in the palace. It seems lighting effects such as weapon glow, fire from the hippogryph, and water are below where they are supposed to be. When I fly over the water, the level raises to where it supposed to be.
This happens here all the time when the viewport is on for all my characters.
I have an HP Pavilion with an Intel Core 2 Quad Q9300 with 8GB memory, an Nvidia GeForce GT220, and Windows Vista 64 bit.
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_011112_191802.jpg
Views:	311
Size:	467.3 KB
ID:	6721  Click image for larger version

Name:	WoWScrnShot_011112_191821.jpg
Views:	305
Size:	460.8 KB
ID:	6722  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:06 AM   #14
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
A description of the problem from Throne of Tides

I don't play anymore but I noticed that My character was in the floor and water would dissapear in one of the dungeons when I played 2 weeks ago. The dungeon was Throne of the Tides. It happened everytime that I went in there for weeks. I Don't have a screenshot but my friends who also had NUI installed experienced the same issues. I also had my viewport enabled but even dissabled it still did the same thing. It was annoying because when you sat down your toon totally dissapered and bubbles and such around your toon appeared above it. Hope this helps some even though I can't get a screen shot for you.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:08 AM   #15
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Uldum and Throne of Tides...

Here you go Scott in Uldum on the river but it happens on the whole river and lake. I also got the running in the floor up to my neck in Throne of Tides 5 man but no screen shots hope this helps.
Attached Thumbnails
Click image for larger version

Name:	VP off.jpg
Views:	316
Size:	651.6 KB
ID:	6723  Click image for larger version

Name:	VP on.jpg
Views:	319
Size:	665.8 KB
ID:	6724  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:10 AM   #16
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Screen shots from Throne of Tides...
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_011212_061728.jpg
Views:	312
Size:	654.1 KB
ID:	6725  Click image for larger version

Name:	WoWScrnShot_011212_061745.jpg
Views:	317
Size:	755.0 KB
ID:	6726  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:11 AM   #17
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Uldum again...

Hi Spiel

Co-ords 54.9, 34.2 - Uldum. Also occurs over the dam area in uldum.

Good luck

Col
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_011212_205053.jpg
Views:	315
Size:	172.1 KB
ID:	6727  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:16 AM   #18
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Here's an Uldum with a dxDiag

I have this problem, and it is repeatable, on all my toons in Uldum. The problem goes away with the viewport disabled.
Alliance toons, Shandris server. This particular case occurs at 54.97, 36.11 but it happens anywhere near the dam. This particular toon is a Worgen Priest names Katicia

I've also attached a dxdiag so you can see what my system is

Attached Thumbnails
Click image for larger version

Name:	Untitled-1.jpg
Views:	315
Size:	205.4 KB
ID:	6729  
Attached Files
File Type: txt DxDiag.txt (33.9 KB, 307 views)
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:18 AM   #19
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
This one in Uldum shows 3D elements outside of the world screen again...

Scott, i'm not sure if this is also a blizzard bug or an nUI bug as well but the black bar behind the nUI interface is showing odd places of fire. where there is no fire on the surface of the map. the screen shot i'm including does not show nUI or any other add-ons if you need a list just ask for em and ill send a full list

viewport break Uldum @ zone in Bloodhoof server
this has been an ongoing bug since the beginning of 4.0.1 if that help at all on locating when the bug appeared
Attached Thumbnails
Click image for larger version

Name:	broken viewport.jpg
Views:	320
Size:	629.0 KB
ID:	6730  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Old 01-14-12, 07:20 AM   #20
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Here's one that shows a good example of the character walking in the ground... this happens on my own shadow priest, as well.
Attached Thumbnails
Click image for larger version

Name:	Untitled-1.jpg
Views:	314
Size:	268.4 KB
ID:	6731  
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Technical Support » Viewport bug

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off