Thread Tools Display Modes
Old 05-06-12, 04:57 PM   #1
danaere
A Murloc Raider
Join Date: May 2009
Posts: 5
Question chat window issues

I promise, I searched, but couldn't figure it out.

I downloaded nUI this morning. I reviewed the steps in the 'intro' email and followed all of them (renamed WTF and AddOn folders to backup, etc).

I have only nUI installed at this point - no other addons.

I have used the 'reset to default' option from within the chat windows (including the Combat window), I have used the /resetchat (or was it /chatreset ... whichever) to try and clear all the settings, then deleted and reinstalled nUI.

I ran the Repair tool, just in case! I've deleted WTF, Interface, and Cache and started from scratch. Logged in to verify things looked virgin, then installed nUI from there. No luck.

Repeatedly, when I log in for the first time after installing nUI, I get this:
Message: Interface\FrameXML\ChatFrame.lua:3946: attempt to perform arithmetic on a nil value
Time: 05/06/12 15:37:20
Count: 1
Stack: Interface\FrameXML\ChatFrame.lua:3946: in function `ChatEdit_UpdateHeader'
Interface\FrameXML\ChatFrame.lua:3671: in function `ChatEdit_ResetChatType'
Interface\FrameXML\ChatFrame.lua:3743: in function <Interface\FrameXML\ChatFrame.lua:3727>
Interface\FrameXML\ChatFrame.lua:3753: in function `ChatEdit_DeactivateChat'
Interface\FrameXML\InterfaceOptionsPanels.lua:978: in function `InterfaceOptionsSocialPanelChatStyle_SetChatStyle'
Interface\FrameXML\InterfaceOptionsPanels.lua:907: in function <Interface\FrameXML\InterfaceOptionsPanels.lua:894>

Locals: editBox = ChatFrame2EditBox {
0 = <userdata>
headerSuffix = ChatFrame2EditBoxHeaderSuffix {
}
focusLeft = ChatFrame2EditBoxFocusLeft {
}
focusRight = ChatFrame2EditBoxFocusRight {
}
chatFrame = ChatFrame2 {
}
addSpaceToAutoComplete = true
tabCompleteTableIndex = 1
focusMid = ChatFrame2EditBoxFocusMid {
}
header = ChatFrame2EditBoxHeader {
}
}
type = "SAY"
info = <table> {
sticky = 1
flashTabOnGeneral = false
flashTab = false
}
header = ChatFrame2EditBoxHeader {
0 = <userdata>
}
headerSuffix = ChatFrame2EditBoxHeaderSuffix {
0 = <userdata>
}
(*temporary) = nil
(*temporary) = nil
(*temporary) = ChatFrame2EditBoxHeader {
0 = <userdata>
}
(*temporary) = nil
(*temporary) = "SAY"
(*temporary) = "_SEND"
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to perform arithmetic on a nil value"


Also, the Map/Combat button in the lower right corner is there and clicks nicely but when I swap to 'Combat' it's all blank. Looking at other folks screenshots, I'm thinking that's not right.

Suggestions? Many thanks for any ideas.
danaere is offline  
Old 05-07-12, 02:01 AM   #2
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,013
Hmm, can you post a screenshot. ChatFrame2 is the CombatLog frame and should work out of the box but clearly isn't the case by the sounds of it.

It sounds like a value isn't being set properly and the first time log in is having a problem with it. It will take a while to track down unfortunately as there is no mention in the error what part of nUI is causing the problem to occur and replicating it would be an annoying time involving uninstalling and installing nUI.

But, at least it only happens on first log in ... each successive log in works fine ?
__________________
Xrystal is offline  
Old 05-07-12, 01:03 PM   #3
danaere
A Murloc Raider
Join Date: May 2009
Posts: 5
I can get a screenshot later tonight, no problem there.

The error shows up the first time I log in on any specific toon. It also showed up again when I loaded nUI+ last night for the first time.

The combat log window is clearly goofy - it wasn't sitting where it belonged, and after manually moving it to approximately the right spot, it doesn't always click right. Also moves when I log out and back in.
danaere is offline  
Old 05-07-12, 01:30 PM   #4
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,013
Ah, yeah I sometimes get that moving of the combat log chat frame. I've not located a pattern as of yet but I'm guessing its nUI fighting with blizzard for control of the frame along with whatever other addons that play with the frame may want to do.
__________________
Xrystal is offline  
Old 05-07-12, 07:01 PM   #5
danaere
A Murloc Raider
Join Date: May 2009
Posts: 5
Click image for larger version

Name:	WoWScrnShot_050712_175513.jpg
Views:	67
Size:	440.7 KB
ID:	6923

Hopefully this helps - you can see the popup error when I log in - on the lower right, the combat window is floating a little and the 'What happened' filters are oddly overlaying someone making bandages ...
danaere is offline  
Old 05-08-12, 12:30 AM   #6
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,013
Yeah thats the effect I've seen sometimes. But not everytime I log in so I usually just reposition the frame in the infopanel and carry on.
__________________
Xrystal is offline  
Old 05-10-12, 08:05 AM   #7
danaere
A Murloc Raider
Join Date: May 2009
Posts: 5
I'm still getting it every time I log in, and also the combat panel has moved every time.
danaere is offline  
Old 05-10-12, 01:24 PM   #8
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,013
One more question I think, does this happen on just one or two toons or is it on all your chaacters I am assuming everyone if you cleared out the wtf and freshly installed stuff but just checking.

I'll see if I can find a character that I still get this problem on and discern a pattern as to when I get it happening.
__________________
Xrystal is offline  
Old 05-10-12, 02:38 PM   #9
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,013
Okay, found a couple of toons that had the error message pop up. one of them had the combat log misalignment problem and the other didn't. The one that did I realigned and logged completely out and logged back in and all was fine.

Ah, however, the one that didn't have chat alignments still had the error logging out and back in. Solution in that case was to unlock and relock the frame in place and log out and back in and error message disappeared and chat frame still in place.

Give that a go.

When you log out the game updates chat-cache.txt file in your wtf folder. This contains the settings for your 10 chat windows.

If you still have your problem after the above checks try renaming that chat-cache.txt file after logging all the way out again and log back in. It should reset all chat frames and nUI will then reset all its changes to them which should re-write back to the file on logging out again.
__________________
Xrystal is offline  
Old 05-16-12, 07:30 AM   #10
bacardis
A Kobold Labourer
Join Date: Jan 2011
Posts: 1
kind of disappointed i donated to get access to premium downloads at nui only to find this errors he is describing how ever go download the free one works find so what gives?
bacardis is offline  
Old 05-16-12, 08:39 AM   #11
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,013
You downloaded nUI+ and you get error but when you downloaded nUI no error ?
Same version number ?

Nothing else different ?
Did you follow the same install instructions to the letter in both cases ?

This might help identify the cause if you answer yes to all the questions above as Scott should be able to identify what could be causing nUI+ to error out but not nUI.

Bear in mind that both nUI and nUI+ are free. Donations are simply that. As far as I am aware the only difference between the 2 versions are the raid frames for 25 and 40 man raids possibly 10 man raids but not 100% sure on that.
__________________
Xrystal is offline  
Old 05-16-12, 11:36 AM   #12
danaere
A Murloc Raider
Join Date: May 2009
Posts: 5
Originally Posted by bacardis View Post
kind of disappointed i donated to get access to premium downloads at nui only to find this errors he is describing how ever go download the free one works find so what gives?
Well actually, I specifically mentioned that I've had this problem with nUI and since upgrading to nUI+.

What's YOUR point as it pertains to this thread exactly?
danaere is offline  
Old 05-21-12, 11:15 AM   #13
generalhanor
A Deviate Faerie Dragon
Join Date: May 2012
Posts: 18
I get the same error he does, moved combat log box

I usually just put it back in place and move on
But if you find a fix for this that would be good
__________________
generalhanor is offline  
Old 05-21-12, 11:40 AM   #14
sigg
Featured Artist
 
sigg's Avatar
Featured
Join Date: Aug 2008
Posts: 1,198
It is a blizzard issue

If you move the editbox from the chatframe

The solution is here:

http://www.wowinterface.com/forums/s...ad.php?t=38910

Sigg
__________________
RDX manager
Sigg
sigg is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Technical Support » chat window issues

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off