Thread Tools Display Modes
Unread 09-04-12, 03:06 PM   #1
Seer
A Molten Giant
Join Date: Dec 2007
Posts: 649
Buttons went poof?

Ok, had something weird today. The buttons on the first action bar disappeared. The keybindings were gone as well (as in pressing a button did nothing, no errors at all). The other action bars were fine, tho paging the first bar didn't seem to do anyting, even tho all other bars have at least a few spells on them..

We started with heroic today (only madness left, rest was dead before patch). Everything was fine while we were waiting for the last few members to pop in.

Since we we're 2 short after waiting we went back to normal. I think at that point the buttons went away (switching from heroic to normal), not to sure tho. Might also have been after jumping to the platform we would start from.

The buttons on the other bars were still there. Reload didn't bring them back. Relogging made them appear for a second and poof gone again. Trying to drag a spell to the bar didnt work either, but I did get to see the outlines of the macro's/spells I had on the action bar.

I disabled nUI during the fight (horrible experience....). After the fight I enabled nUI again (using http://www.curse.com/addons/wow/neteaseui) and nUI loaded without reloading the UI and all the buttons were back.

I'll see if I can reproduce it somehow without bothering the rest of the raid group later this week. Thoughts (other then that I'm utterly mad)?

Sorry, no screenshots. Didnt want the raid to wait any longer and forgot because of that.



/edit as a side note, I use spell flash (even tho the flashing annoys me somewhat :-p). I disabled that first but it didn't make a difference. What is interesting to is that a macro gives several lua errors once (I'll post those later, the reloading cleared the errors apperently).

The macro isn't that special;

#showtooltip Soul Swap
/cast soulburn
/cast soul swap

/edit2

From bugsack.lua

["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"BittensSpellFlashLibrary\" tried to call the protected function \"nUI_TopLeftBar_Button7:Show()\".",
["time"] = "2012/09/04 21:16:05",
["stack"] = "!BugGrabber-r188\\BugGrabber.lua:587: in function <!BugGrabber\\BugGrabber.lua:587>\n<in C code>\nFrameXML\\ActionButton.lua:268: in function <FrameXML\\ActionButton.lua:253>\n<in C code>\nFrameXML\\ActionButton.lua:505: in function \"ActionButton_OnEvent\"\nFrameXML\\ActionButton.lua:124: in function <FrameXML\\ActionButton.lua:117>",
["session"] = 56,
["counter"] = 9,
}, -- [108]
{
["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"BittensSpellFlashLibrary\" tried to call the protected function \"nUI_LeftUnitBar_Button9:Show()\".",
["time"] = "2012/09/03 20:22:52",
["stack"] = "!BugGrabber-r188\\BugGrabber.lua:587: in function <!BugGrabber\\BugGrabber.lua:587>\n<in C code>\nFrameXML\\ActionButton.lua:268: in function <FrameXML\\ActionButton.lua:253>\n<in C code>\nFrameXML\\ActionButton.lua:505: in function \"ActionButton_OnEvent\"\nFrameXML\\ActionButton.lua:124: in function <FrameXML\\ActionButton.lua:117>",
["session"] = 56,
["counter"] = 19,
}, -- [109]
{
["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"BittensSpellFlashLibrary\" tried to call the protected function \"OverrideActionBarButton6:Show()\".",
["time"] = "2012/09/03 20:22:52",
["stack"] = "!BugGrabber-r188\\BugGrabber.lua:587: in function <!BugGrabber\\BugGrabber.lua:587>\n<in C code>\nFrameXML\\ActionButton.lua:268: in function <FrameXML\\ActionButton.lua:253>\n<in C code>\nFrameXML\\ActionButton.lua:505: in function \"ActionButton_OnEvent\"\nFrameXML\\ActionButton.lua:124: in function <FrameXML\\ActionButton.lua:117>",
["session"] = 56,
["counter"] = 17,
}, -- [110]
{
["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"BittensSpellFlashLibrary\" tried to call the protected function \"nUI_ActionBar_Button6:Show()\".",
["time"] = "2012/09/03 20:22:52",
["stack"] = "!BugGrabber-r188\\BugGrabber.lua:587: in function <!BugGrabber\\BugGrabber.lua:587>\n<in C code>\nFrameXML\\ActionButton.lua:268: in function <FrameXML\\ActionButton.lua:253>\n<in C code>\nFrameXML\\ActionButton.lua:505: in function \"ActionButton_OnEvent\"\nFrameXML\\ActionButton.lua:124: in function <FrameXML\\ActionButton.lua:117>",
["session"] = 56,
["counter"] = 17,
}, -- [111]
{
["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"BittensSpellFlashLibrary\" tried to call the protected function \"nUI_TopRightBar_Button9:Show()\".",
["time"] = "2012/09/03 20:22:52",
["stack"] = "!BugGrabber-r188\\BugGrabber.lua:587: in function <!BugGrabber\\BugGrabber.lua:587>\n<in C code>\nFrameXML\\ActionButton.lua:268: in function <FrameXML\\ActionButton.lua:253>\n<in C code>\nFrameXML\\ActionButton.lua:505: in function \"ActionButton_OnEvent\"\nFrameXML\\ActionButton.lua:124: in function <FrameXML\\ActionButton.lua:117>",
["session"] = 56,
["counter"] = 19,
}, -- [112]
__________________
Take it as you want or leave it as it is.

Last edited by Seer : 09-04-12 at 03:16 PM.
Seer is offline  
Unread 09-04-12, 06:33 PM   #2
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Those taint messages from bugsack are the result of that addon trying to call protected functions on the secure action button frames during combat. They *might* be related to your problem, but likely are not.

Let me know if you can reproduce it.

Also... make sure you didn't end up switching the page of the main action bar... you can press "shift-1" to select the first action page. Sometimes when button mashing folks accidentally change the action bar page and don't realize it, then freak out because the buttons are gone. Shift-1 should always bring you back to the main action bar page if that happens.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 09-04-12, 09:47 PM   #3
Dresden
A Murloc Raider
 
Dresden's Avatar
Join Date: Oct 2009
Posts: 8
This just happened to me. And I will enclose two screenshots. It was on the ultraxion fight and i believe it has something to do with the "Fading Light" button or the ExtraActionButton, because as soon as that should appear, bam, no more buttons. It would also explain while the first poster only experienced on certain platforms. One screenshot is right before the fight and the other is right as it is about to begin.

Hope this helps
Attached Thumbnails
Click image for larger version

Name:	WoWScrnShot_090412_205745.jpg
Views:	394
Size:	438.3 KB
ID:	7145  Click image for larger version

Name:	WoWScrnShot_090412_210108.jpg
Views:	386
Size:	438.0 KB
ID:	7146  
Dresden is offline  
Unread 09-04-12, 11:34 PM   #4
Seer
A Molten Giant
Join Date: Dec 2007
Posts: 649
Originally Posted by spiel2001 View Post
Those taint messages from bugsack are the result of that addon trying to call protected functions on the secure action button frames during combat. They *might* be related to your problem, but likely are not.
Yea, I'm sure its not related since with spellflash of I still didn't get the bar back. And I used that macro several times before the raid and no problems then. But don't recall other macro's having the same error, but might be mistaken about that.

Originally Posted by spiel2001 View Post
Also... make sure you didn't end up switching the page of the main action bar... you can press "shift-1" to select the first action page. Sometimes when button mashing folks accidentally change the action bar page and don't realize it, then freak out because the buttons are gone. Shift-1 should always bring you back to the main action bar page if that happens.
Well, we didn't have a fight yet so no button smashing yet. And when trying to drag a spell to the bar you could see the there were "ghostly" buttons (bit hard to describe) and it seemed you could drop it on the bar but nothing happened.. :-/

It was especially weird that the keybindings didn't work, that should not be the case if the bars were switched right?

And they came back after I enabled nUI again when the fight was done, no shift-1 needed.
__________________
Take it as you want or leave it as it is.

Last edited by Seer : 09-04-12 at 11:57 PM.
Seer is offline  
Unread 09-05-12, 12:57 AM   #5
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
If it is the extraactionbutton appearing and messing things up I apologise as that would be my fault. there probably is something that has to be done to get the buttons reset again. However, it seems the extra action bar has to be an additional bar on screen and not a page switch as it has been said that you need both sets of buttons available.
__________________
Xrystal is offline  
Unread 09-05-12, 02:42 AM   #6
Seer
A Molten Giant
Join Date: Dec 2007
Posts: 649
Originally Posted by Xrystal View Post
If it is the extraactionbutton appearing and messing things up I apologise as that would be my fault. there probably is something that has to be done to get the buttons reset again. However, it seems the extra action bar has to be an additional bar on screen and not a page switch as it has been said that you need both sets of buttons available.
Hm.. Don't remember to well but perhaps I did get that extra action button.. Then yea it would be your fault :-p


Kidding X, you're still the best ;-)

/btw. thanks Dresden for the additional info :-)
__________________
Take it as you want or leave it as it is.

Last edited by Seer : 09-05-12 at 04:52 AM.
Seer is offline  
Unread 09-08-12, 07:58 AM   #7
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
Okay guys, for now replace the following text in nui/bars/nui_buttonbar.lua

RegisterStateDriver(nUI_ActionBar, "page", "[vehicleui] 12; [extrabar] 13; [overridebar] 14; [bar:2] 2; [bar:3] 3; [bar:4] 4; [bar:5] 5; [bar:6] 6; [bonusbar:1] 7; [bonusbar:2] 8; [bonusbar:3] 9; [bonusbar:4] 10; [bonusbar:5] 11;1" );

with

RegisterStateDriver(nUI_ActionBar, "page", "[vehicleui] 12; [overridebar] 14; [bar:2] 2; [bar:3] 3; [bar:4] 4; [bar:5] 5; [bar:6] 6; [bonusbar:1] 7; [bonusbar:2] 8; [bonusbar:3] 9; [bonusbar:4] 10; [bonusbar:5] 11;1" );

This is of course is assuming you had already implemented my two patch files for the group bug and the overridebar being missing.

This should allow you to use any other addons that show the extra action button correctly while we try to figure out how to get it to work properly with nUI.
__________________
Xrystal is offline  
Unread 09-09-12, 04:19 PM   #8
Seer
A Molten Giant
Join Date: Dec 2007
Posts: 649
Been playing almost the entire day, and a complete DS heroic run as well. Other then 2 other mods causing a few lua errors everything went great.

*hugs X once again!
__________________
Take it as you want or leave it as it is.
Seer is offline  
Unread 09-10-12, 01:35 AM   #9
UrbanArmitage
An Aku'mai Servant
Join Date: Jun 2012
Posts: 37
I experienced the same thing running DS over the weekend. When in the Ultraxion and Madness fights my main spell bar was emptied as soon as the ExtraActionButton popped up.

Xrystal, thank you for finding a solution for us, but please can you explain a bit more about your other two patches required to make this work and possibly link to the threads here? I have updated my nUI for the group bug using your patch but am not sure what your overridebar patch is. Sorry.

Thanks for your efforts!
UrbanArmitage is offline  
Unread 09-10-12, 03:19 PM   #10
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,035
The link to my various updates are in my signature.

Bear in mind that at present nUI doesn't want the extra action bar thing to work. I came close as you can see but not quite there as the regular bar didn't return for some reason. Probably because it isn't designed to be like the override bar or other bar toggles where you move up and down the bar list.

The thread for the Override Bar fix includes a link to an addon that has been known to work alongside nUI to get the Extra Action Bar to display.

Unfortunately my understanding of action bars are a bit minimal so I am surprised I got the override bar working so quickly rofl.

Hopefully Scott will get a patch out in the next day or two containing these fixes but until then the list will stay in my signature.
__________________
Xrystal is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Bug Reports » Buttons went poof?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off