Reply
Thread Tools Display Modes
Unread 09-09-12, 10:21 AM   #1
Trimble Epic
An Aku'mai Servant
 
Trimble Epic's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2005
Posts: 31
Vehicle bars

How much longer until we get working vehicle bars? I just tried to complete that quest in westfall where you jump into a harvester and I was unable to do anything because of no vehicle bars.

Any updates?
Trimble Epic is offline   Reply With Quote
Unread 09-09-12, 11:16 AM   #2
Phaedre
A Murloc Raider
Join Date: Aug 2006
Posts: 8
I went to Argent Tournament and the vehicle bar I created worked perfectly when using one of the mounts to practice with. That's the only "vehicle" I've tested though.

I created a new action bar. Named it Vehicle Bar 1, set the state to Vehicle, added 10 buttons, and then followed these instructions from BlurredWorld changing "pet" to "vehicle"


Originally Posted by BlurredWorld from Google Group
I've got this one, I think.

If you've used the Ion chat command line to do anything with Ion before, you may have inadvertently toggled the nopet visibility to "show" for the pet bar.

Even if not, it should be pretty simple to correct. Bring Ion into bar edit mode and select your pet bar. Now in the chat pane type the following:

/ion vis pet

You should get something like this returned:

0: No Pet - Show
1: Pet Exists - Show

If 0 does indeed say No Pet - Show, then type the following to return it to a hidden state:

/ion vis pet 0

The text returned should now indicate 0: No Pet - Hide, and the bar should now work as intended.
I then tested at the Argent Tournament grounds. Once my vehicle buttons were populated I added the binds. Let me know if that works for you.

Ret
aka Draephae / Phaedre

Last edited by Phaedre : 09-09-12 at 11:17 AM. Reason: Additional information
Phaedre is offline   Reply With Quote
Unread 09-13-12, 10:59 AM   #3
Trimble Epic
An Aku'mai Servant
 
Trimble Epic's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2005
Posts: 31
Ok, so vehicle bars do work. Mostly.

However, I'm using a custom state bar as my primary bar, and custom states don't jive well with vehicles... Specifically, shift and alt custom states make the state manager get confused and if you touch shift or alt, it won't go back to the vehicle bar, like AT ALL.

But, at least I can do vehicle based quests now.
Trimble Epic is offline   Reply With Quote
Reply

Go BackWoWInterface » Featured Projects » Ion Engines, Engage! » Vehicle bars

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off