Reply
Thread Tools Display Modes
Unread 10-28-12, 08:40 PM   #1
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,411
Why is your CDN so lazy?

Sometimes it just decides it's taking a nap and can't be bothered to respond with the CSS, and I get HTML only (and sometimes images). I'd say this happens every 36 hours on average; sometimes it doesn't happen for a few days, while other times it happens multiple times in the same day. Clearing my browser's cache and reloading doesn't fix it. I just have to wait, anywhere from 30 seconds to 10 minutes, and then it will magically start sending me CSS again. I'm in the San Francisco Bay Area. Anyone else having this issue, or am I just special?
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 10-28-12, 09:52 PM   #2
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,965
Yeah I would like to know if any one else is having trouble. The CDN is Akamai one of the largest and most widely used.
Dolby is offline   Reply With Quote
Unread 10-28-12, 10:26 PM   #3
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,411
Is there anything I can do to help track down the issue?
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 10-28-12, 10:32 PM   #4
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,965
When you have issues try doing a trace route to cdn.wow.mmoui.com

Also if you have access to curl or wget try downloading an image or CSS that won't display for you. See if you get some HTML doc or something and share it here.

Thanks for your help.
Dolby is offline   Reply With Quote
Unread 10-28-12, 10:52 PM   #5
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,411
tracert #1:
Code:
Tracing route to cdn.wow.mmoui.com [23.3.68.129]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms    my.router [192.168.1.1]
  2    33 ms    39 ms    28 ms    98.248.144.1
  3    10 ms    10 ms     9 ms    te-5-6-ur04.pinole.ca.sfba.comcast.net [68.86.142.205]
  4    34 ms    11 ms    11 ms    te-0-2-0-12-ar01.oakland.ca.sfba.comcast.net [68.85.154.86]
  5    14 ms    22 ms    23 ms    he-2-12-0-0-cr01.sacramento.ca.ibone.comcast.net [68.86.90.129]
  6    28 ms    49 ms    29 ms    [pos-2-13-0-0-cr01.seattle.wa.ibone.comcast.net [68.86.85.161]
  7    55 ms    55 ms    55 ms    [pos-0-5-0-0-cr01.denver.co.ibone.comcast.net [68.86.88.5]
  8    52 ms    55 ms    53 ms    68.86.82.198
  9    52 ms    85 ms    67 ms    a23-3-68-129.deploy.akamaitechnologies.com [23.3.68.129]

Trace complete.
Reloaded the page. Still no CSS.

tracert #2:
Code:
Tracing route to cdn.wow.mmoui.com [23.3.68.129]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms    my.router [192.168.1.1]
  2    28 ms    27 ms    29 ms    98.248.144.1
  3    10 ms    12 ms     9 ms    te-5-6-ur04.pinole.ca.sfba.comcast.net [68.86.142.205]
  4    20 ms    11 ms    23 ms    te-0-2-0-12-ar01.oakland.ca.sfba.comcast.net [68.85.154.86]
  5    39 ms    11 ms    22 ms    he-2-12-0-0-cr01.sacramento.ca.ibone.comcast.net [68.86.90.129]
  6    29 ms    31 ms    27 ms    [pos-2-13-0-0-cr01.seattle.wa.ibone.comcast.net [68.86.85.161]
  7    55 ms    56 ms    54 ms    [pos-0-5-0-0-cr01.denver.co.ibone.comcast.net [68.86.88.5]
  8    53 ms    53 ms    51 ms    68.86.82.198
  9    53 ms    52 ms    54 ms    a23-3-68-129.deploy.akamaitechnologies.com [23.3.68.129]

Trace complete.
Reloaded again, and things were back to normal.

I'll try wget next time.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 10-28-12, 10:55 PM   #6
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,965
Thanks I'll send this to our CDN contact for them to investigate. If you can get a wget of what its really sending you that will help to.

Thanks again.
Dolby is offline   Reply With Quote
Unread 10-29-12, 01:06 AM   #7
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,411
Happened again.

Code:
wget -o log.txt http://cdn.wow.mmoui.com/clientscript/vbulletin_css/style-0ae33178-00016.css
Resulted in no CSS file being downloaded, and the following in log.txt:

Code:
--2012-10-29 00:04:06--  http://cdn.wow.mmoui.com/clientscript/vbulletin_css/style-0ae33178-00016.css
Resolving cdn.wow.mmoui.com... 23.3.68.129
Connecting to cdn.wow.mmoui.com|23.3.68.129|:80... failed: Connection refused.
When I hit Post Reply on this thread, it was working again, so I ran the same wget command again and got the CSS file and this log:

Code:
--2012-10-29 00:07:43--  http://cdn.wow.mmoui.com/clientscript/vbulletin_css/style-0ae33178-00016.css
Resolving cdn.wow.mmoui.com... 23.3.68.129
Connecting to cdn.wow.mmoui.com|23.3.68.129|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/css]
Saving to: `style-0ae33178-00016.css'

     0K .......... .......... .......... .......... ..........  304K
    50K .......... ..                                           212K=0.2s

2012-10-29 00:07:43 (280 KB/s) - `style-0ae33178-00016.css' saved [63860]
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!

Last edited by Phanx : 10-29-12 at 01:08 AM.
Phanx is offline   Reply With Quote
Reply

Go BackWoWInterface » Site Forums » Site help, bugs, suggestions/questions » Why is your CDN so lazy?

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off