Thread Tools Display Modes
Unread 01-18-13, 06:32 PM   #1
Insidious93
A Defias Bandit
Join Date: Oct 2010
Posts: 3
Questhelper 5.0.5.26r & nUI+

I searched the forums to find a near 3 year old post, so I would like to ask here since I am having issues, does the current build work? If so, what is required to make it work. I have simply installed the addon via curse, WoW accepts it as a loaded addon, but I cannot get it to load up. I'm leveling alts, and prior to switching to this today it was a very helpful tool.

Thanks in advance for any support! So far, I am really enjoying your work on this.
Insidious93 is offline  
Unread 01-18-13, 07:19 PM   #2
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
I'm not aware of any conflicts between Quest Helper and nUI. They have always played well together to the best of my knowledge.... though I have not used Quest Helper in quite some time now.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
spiel2001 is offline  
Unread 01-18-13, 08:21 PM   #3
Insidious93
A Defias Bandit
Join Date: Oct 2010
Posts: 3
I wouldnt have either. No error messages come up, nor anything negative with the UI. You can even bring up QH command line commands. But for whatever reason it will not work. I'll keep messing with it some more. If you find anything let me know, I will do the same if I find a solution.
Insidious93 is offline  
Unread 01-18-13, 08:33 PM   #4
Insidious93
A Defias Bandit
Join Date: Oct 2010
Posts: 3
Ok, opening the menu, then interface, then addons this error was generated when I clicked on QH.

Lua Error
Message: ...lper\libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66: CreateFrame(): Couldn't find inherited node "UIPanelButtonTemplate2"
Time: 01/18/13 21:27:56
Count: 1
Stack: (tail call): ?
[C]: ?
...lper\libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66: in function `?'
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:136: in function <...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:125>
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:174: in function `Create'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1113: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1051>
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1078: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1051>
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1538: in function `FeedGroup'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1814: in function `Open'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1842: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1840>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
(tail call): ?
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:20: in function <...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:19>
[C]: in function `Show'
Interface\FrameXML\InterfaceOptionsFrame.lua:28: in function `InterfaceOptionsList_DisplayPanel'
Interface\FrameXML\InterfaceOptionsFrame.lua:46: in function `InterfaceOptionsListButton_OnClick'
[string "*:OnClick"]:2: in function <[string "*:OnClick"]:1>

Locals: <none>

Followed by this:
Lua Error
Message: ...lper\libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66: CreateFrame(): Couldn't find inherited node "UIPanelButtonTemplate2"
Time: 01/18/13 21:31:04
Count: 4
Stack: (tail call): ?
[C]: ?
...lper\libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66: in function `?'
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:136: in function <...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:125>
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:174: in function `Create'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1113: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1051>
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1078: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1051>
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1538: in function `FeedGroup'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1814: in function `Open'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1842: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1840>
(tail call): ?
[C]: ?
[string "safecall Dispatcher[2]"]:9: in function <[string "safecall Dispatcher[2]"]:5>
(tail call): ?
...ce\AddOns\QuestHelper\libs\AceGUI-3.0\AceGUI-3.0.lua:314: in function `Fire'
...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:20: in function <...GUI-3.0\widgets\AceGUIContainer-BlizOptionsGroup.lua:19>
[C]: in function `Show'
Interface\FrameXML\UIParent.lua:1750: in function `SetUIPanel'
Interface\FrameXML\UIParent.lua:1555: in function `ShowUIPanel'
Interface\FrameXML\UIParent.lua:1481: in function <Interface\FrameXML\UIParent.lua:1477>
[C]: in function `SetAttribute'
Interface\FrameXML\UIParent.lua:2193: in function `ShowUIPanel'
[string "*:OnClick"]:2: in function <[string "*:OnClick"]:1>

Locals: <none>

Any thoughts there?

Update: I have switched to QuestMaster, as out of all the ones I have tried, it's the only one that works.

Last edited by Insidious93 : 01-18-13 at 09:41 PM. Reason: Update
Insidious93 is offline  
Unread 01-19-13, 07:21 AM   #5
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,032
That is a problem with the QuestHelper addon and/or the AceGUI library as it is using a template that I suspect no longer exists in Blizzard coding.

I suspect one or both of them have not been updated to 5.0 or above versions of wow yet.
__________________
Xrystal is offline  
Unread 01-19-13, 08:18 PM   #6
Coasty
A Flamescale Wyrmkin
Join Date: Aug 2009
Posts: 116
The last version QuestHelper was updated for was update 5.0.5, so I would suspect that update 5.10 broke it.
__________________
Paul Stout
nUI User and Contributor
coasty63@comcast.net
Coasty is offline  
Unread 01-19-13, 08:48 PM   #7
Xrystal
nUI User and Supporter
 
Xrystal's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 5,032
Hmm, maybe something else then .. I'm pretty sure UIPanelButtonTemplate2 was changed in 5.0.

Yeah looking at the blizz code they removed it in 5.0.4 so if your code isn't referencing the template directly it could be the library that needs updating.
__________________
Xrystal is offline  
 

Go BackWoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Technical Support » Questhelper 5.0.5.26r & nUI+

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off