Reply
Thread Tools Display Modes
Unread 08-01-13, 03:07 PM   #1
Seyn
A Defias Bandit
Join Date: Aug 2013
Posts: 3
Exclamation Sudden increase in graphic quality + temps

Hello,

I've run into a problem since installing Maryon UI. I think the problem is related to my PC and graphic drivers however, and the UI has just triggered it. I know a bit about computers but not enough to actually fix them so bear with me here .

I previously had a custom UI with a mish mash of addons set up how I liked. I've since backed up the Interface and WTF folders, and copied over the "new" versions from Maryon UI.

I logged in and everything is pretty and new and lovely. But for some reason, despite my graphics setting being exactly the same, all of my textures were MUCH crisper and with an unlimited FPS it was running at 91FPS.

I then locked my FPS on the Config.wtf file to 40, as I had done on my previous UI, to cut down on the heat, but the fan was still blowing like crazy and in comparison to the previous set-up I could tell it was a lot hotter.

My question is what has caused this sudden change, and what can I do to deal with it/reduce the heat? Even at 40FPS it was burning up.

I have my own idea, and hopefully someone who knows about computers can help me see if it's right:

For some reason, my computer runs both the Intel HD graphics and the NVIDIA graphics drivers. They both show up in the system tray and in Drivers. I can't get rid of the Intel one and on many games it defaults to it.
I think that, somehow, WoW was previously running on the Intel graphics giving me crappy textures and that the change to Maryon has changed something in a config file somewhere so it now runs with NVIDIA card. I guess this would explain the clearer textures and the heat increase.

Also, under System in WoW (ESC menu), I can select Monitor 1 or Default and this seems to change the speed of the system.

Under dxdiag, the Intel HD graphics 3000 also shows up under Display and the NVIDIA drivers isn't mentioned.

Is there a way to monitor this at all? Can I somehow stop the Intel driver being active so my laptop solely runs off of the NVIDIA?

System specs:

Windows 7 64Bit
intel core i7-2670QPM
8GB RAM
NVIDIA GeForce 555M GT / Intel HD 3000


Thank you for any help
Seyn is offline   Reply With Quote
Unread 08-01-13, 04:55 PM   #2
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,247
I don't know about the driver stuff, but have you checked the CPU usage of the addons in the UI to see if any of them are eating up inordinate amounts of CPU time? Searching this site for "memory" or "performance" will give you several options for addons that can show you CPU time (in addition to other stats like memory usage).
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 08-01-13, 08:27 PM   #3
MiRai
A Theradrim Guardian
Join Date: Jul 2011
Posts: 68
First, you should make sure you're using the most up-to-date drivers available from nvidia.com (not Windows Update). I don't have a technical answer as to why, but everyone I've ever helped with GPU-related issues who had used a laptop have had much better results after their drivers were up-to-date when dealing with the weird nVidia Optimus technology that switches between the integrated chip and the dedicated card.

Before anyone chimes in and says that you should always make sure your drivers are up-to-date all the time, that isn't always true in the realm of custom-built desktops. I'll agree it's good practice, but sometimes older drivers work much better than newer drivers depending on your hardware and the games that you primarily play.

Originally Posted by Seyn View Post
Is there a way to monitor this at all? Can I somehow stop the Intel driver being active so my laptop solely runs off of the NVIDIA?
You can use a program like GPU-Z to monitor your GPU usage, but to force the game to use the dedicated card you'll need to go into your nVidia Control Panel (Manage 3D Settings > Program Settings Tab) and set World of Warcraft to Prefer Maximum Performance under Power Management Mode. You can do this for your other games as well, but I wouldn't recommend changing it globally or else your GPU will be running at its full clock all the time -- That just creates unnecessary heat and power draw when your computer is idle.

I don't own, nor have I ever played games on, a laptop, but I'm relaying this information from personal experience when helping others.
MiRai is offline   Reply With Quote
Unread 08-02-13, 12:49 AM   #4
Seyn
A Defias Bandit
Join Date: Aug 2013
Posts: 3
Thanks for the responses.

Following a tip from the official forums, I deleted the existing Mayron UI WTF, Interface and Cache folders to start from default. The same issue occurred with the crisp textures and high heat.

I then installed the old set of Interface and WTF folders and the textures went back to being smudgy.

Is there a central config file that would show a difference in any background settings?

I'll be checking the drivers when I get back from work, and I'll also be giving it a good clean inside (although it's not that dusty). I'll check the addon usage as well.

Checking the CPU heat, it was running at 75-80 just on the character select screen.

Thanks
Seyn is offline   Reply With Quote
Unread 08-02-13, 12:58 AM   #5
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,247
Originally Posted by Seyn View Post
Is there a central config file that would show a difference in any background settings?
World of Warcraft > WTF > Config.wtf

MayronUI doesn't include a Config.wtf file, so after you install it, just copy over your old one. This will preserve your old video, sound, and other system settings.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 08-02-13, 05:11 AM   #6
ravagernl
A Pyroguard Emberseer
AddOn Author - Click to view addons
Join Date: Feb 2006
Posts: 1,145
Originally Posted by Phanx View Post
[...]
This will preserve your old video, sound, and other system settings.
For reference, MayronUI only sets the uiScaling option for the different profiles:
Code:
if SCALE_TYPE_SET == "1920x1080" then
		ConsoleExec("useUiScale 1")
		ConsoleExec("uiscale 0.7")
	elseif SCALE_TYPE_SET == "1680x1050" then
		ConsoleExec("useUiScale 1")
		ConsoleExec("uiscale 0.7")
	elseif SCALE_TYPE_SET == "1600x900" then
		ConsoleExec("useUiScale 1")
		ConsoleExec("uiscale 0.75")
	elseif SCALE_TYPE_SET == "1440x900" then
		ConsoleExec("useUiScale 1")
		ConsoleExec("uiscale 0.75")
	elseif SCALE_TYPE_SET == "1366x768" then
		ConsoleExec("useUiScale 1")
		ConsoleExec("uiscale 0.8")
	end
Have you tried switching the video mode for wow? It might have switched to fullscreen, or maximized window (and maybe that is causing the issue).

Last edited by ravagernl : 08-02-13 at 05:15 AM.
ravagernl is offline   Reply With Quote
Unread 08-02-13, 10:53 AM   #7
Seyn
A Defias Bandit
Join Date: Aug 2013
Posts: 3
Hiya,

Checked the settings for both set ups and they are exactly the same.

I'll read through my Config.wtf files and update the drivers. Hopefully that will either clear it up in my head, or just cut the heat down when it's looking crisp

I've got to be the only person complaining that they're graphics are too nice.
Seyn is offline   Reply With Quote
Reply

Go BackWoWInterface » General Discussion » Tech Chat » Sudden increase in graphic quality + temps

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off