Reply
Thread Tools Display Modes
Unread 08-03-14, 01:11 PM   #1
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,568
404 error with WoWI Mod Uploader

Attempting to use Shadowed's WoWI Mod Uploader to cross-post ZIPs produced by the Curse packager (since you guys don't have any way to pull in libraries when packaging from Git ) fails with a 404 error:

> java WoWIUploader -curse-page "librealminfo" -api-key "*****" -ftitle "LibRealmInfo"
Username: Phanx
Password: *****
Logged into Phanx, session id aed419ddfbdd039ad75c1855de44d2a3

Loading your submitted mods...
java.io.FileNotFoundException: http://www.wowinterface.com/downloads/editfile_xml.php?do=listfiles&l
=Phanx&p=fe19d34bb9e18f43e49fce9e1a77305c
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at WoWIUploader.getUserMods(WoWIUploader.java:346)
at WoWIUploader.<init>(WoWIUploader.java:173)
at WoWIUploader.main(WoWIUploader.java:1343)
No relevant, or exact matches found for "LibRealmInfo"
I realize this tool isn't an official WoWI product, but is the XML file it's looking for supposed to be missing from that location, and if so, is it still available at some other URL?
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 08-03-14, 05:27 PM   #2
Dolby
Every day I'm shuffling
 
Dolby's Avatar
Premium Member
WoWInterface Admin
Join Date: Feb 2004
Posts: 1,981
Sorry about that, looks like it was disabled a week or two ago. I've gone and re-enabled it and cleaned up a bit of the php since it was so old. Let me know if you have any trouble.

Thanks

I'm wondering what I would need to add support for 3rd party libraries? would it be as simple as just doing another git pull at the time of packaging?

Last edited by Dolby : 08-03-14 at 05:30 PM.
Dolby is offline   Reply With Quote
Unread 08-04-14, 12:07 AM   #3
p3lim
A Pyroguard Emberseer
 
p3lim's Avatar
AddOn Author - Click to view addons
Join Date: Feb 2007
Posts: 1,312
Originally Posted by Dolby View Post
I'm wondering what I would need to add support for 3rd party libraries? would it be as simple as just doing another git pull at the time of packaging?
Pretty much, you'd have a file like pkgmeta or gitmodules that specify both where to clone from and where it should go in the directory.

I'd personally prefer pkgmeta as it allow us to specify specific tags/branches that the packager should get.
p3lim is offline   Reply With Quote
Unread 08-04-14, 06:14 AM   #4
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,568
Using the same .pkgmeta file as Curse would be ideal, but I don't think .gitmodules would really work here, since it would only allow pulling libraries from other Git repos. With my existing addons using SVN, where I'm using svn:externals to tell the WoWI packager which libraries to include, I've already had to set up private SVN mirrors of several libraries that were in Git or Hg repos. However, most libraries are on SVN, and I don't really think setting up Git mirrors of every library is the best solution.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
Phanx is offline   Reply With Quote
Unread 08-04-14, 06:30 AM   #5
Phanx
A Pyroguard Emberseer
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 4,568
Originally Posted by Dolby View Post
Sorry about that, looks like it was disabled a week or two ago. I've gone and re-enabled it and cleaned up a bit of the php since it was so old. Let me know if you have any trouble.
Well, the WoWI side seems to (mostly*) work now, but cross-loading from Curse doesn't, as it fails with a "Failed to find download URL on wowace." Oh well... I guess that's what happens when you're trying to use a script that hasn't been updated in 4 years with websites that are constantly changing. I don't think it was really saving me a whole lot of time anyway, seeing as how the Curse packager doesn't run immediately, so I'd have to remember to go check for it periodically to know when to run the uploader script. Probably not worth spending your time trying to fix it.

*Mostly, because the version string doesn't make it onto the site (the ZIP file was uploaded, but the version shown on the website was blank) but I don't know whether that's an issue on WoWI or in the tool itself.

Edit: Just noticed it also cleared the WoW version compatibility flags on the addon page in addition to the addon version string.
__________________
Author/maintainer of Grid, PhanxChat, ShieldsUp, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!

Last edited by Phanx : 08-04-14 at 06:45 AM.
Phanx is offline   Reply With Quote
Reply

Go BackWoWInterface » Site Forums » Site help, bugs, suggestions/questions » 404 error with WoWI Mod Uploader

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off