Quantcast
View Bug Report
BattleGround Zoning error
Bug #: 2287
File: FuBar - SkillsPlusFu
Date: 10-09-06 06:44 AM
By: baloor
Status: Confirmed (Working on Fix)
When I zone into and out of battlegrounds, I consistently have this error returned.

FuBar_SkillsPlusFu\SkillsPlusFu.lua:548: attempt to index field `?' (a nil value)
FuBar_SkillsPlusFu\SkillsPlusFu.lua:548: in function `OnDataUpdate'
FuBarPlugin\FuBarPlugin-2.0.lua:157: in function `UpdateData'
FuBarPlugin\FuBarPlugin-2.0.lua:144: in function `obj_method'
AceEvent-2.0\AceEvent-2.0.lua:312: in function `TriggerEvent'
AceEvent-2.0\AceEvent-2.0.lua:894: in function AceEvent-2.0\AceEvent-2.0.lua:886
<in C code>: in function `ExpandSkillHeader'
Gatherer\Gatherer.lua:654: in function `Gatherer_GetSkills'
Gatherer\\Gatherer.lua:580: in function `Gatherer_OnEvent'
<string>:\"Gatherer:OnEvent\":2: in main chunk\n\n ---",

Not sure if it's SkillsPlusFu causing the issue or Gatherer.

RSS 2.0 Feed for Bug CommentsNotes Sort Options
By: Jayhawk - 10-09-06 10:30 AM
Thanks, I just recently noticed a similar error zoning via ship.
The strange thing is that that same bit of code is called multiple times from other places, which makes me wonder what goes wrong (and, yes, I too am using Gatherer).
By: baloor - 10-16-06 07:43 AM
If you want any further testing done to narrow it down, am willing to lend a hand.
By: Jayhawk - 10-20-06 03:52 AM
That would be great, as I don't have a clue what's going on.

I get a feeling its a library that gets confused. On the SkillsPlus Page a similar error was thrown/shown the other day.

Oh, what debugger do you use? It looks nifty
By: baloor - 10-22-06 09:46 PM
The error was captured using ImprovedErrorFrame. I grab a select few things like that from the Cosmos package.
I recently switched to using Bugsack, pretty much the same, but has a better interface.

Let me know if there is anything specific I should be trying.
By: Jayhawk - 10-25-06 01:25 AM
Well, what I'm interested in, is why that particular error occurs, as the actual code seems sound. Any help would be appreciated, but...don't go overboard. There's a lot more to life than debugging other people's code

I'll look into Bugsack. Thanks
By: baloor - 11-07-06 08:28 AM
I haven't had much chance to play around with this. But I can safely say that it only occurs when zoning, like entering BG or the Tram from IF to SW.
Additionally, out of all my toons, only my hunter and warlock get the error.

When I get some time to play around with it, I'll start removing other addons, see what happens. The only addon these two characters use the others dont is FuBar - PetInfo found here http://www.wowinterface.com/downloads/fileinfo.php?id=4797
By: Jayhawk - 11-07-06 09:11 AM
Intriguing...

I've noticed the zoning behaviour, but not the calss restriction. I am using FuBar - PetInfo too, though.